y4cs.aux

Yaneurao Game Library 4th for C#

y4cs.aux Namespace

Classes

Class | Description
CacheLoader | キャッシュメカニズムを実現するための基底クラス
CacheLoader.Info | このクラスの保持している情報構造体。
CodeConv | 日本語のコード変換を提供する。
DirEnumerator | ディレクトリ内のファイルを列挙するためのクラス。
FileArchiverBase | Fileで用いる、圧縮ファイルを扱うためのクラス。
FileArchiverSample | 独自形式の圧縮ファイルをシームレスに扱うためのクラス(サンプル)。
FileArchiverYzp |
FileArchiverZip |
FileArchiverZipFile | .zip ファイル(単体)をシームレスに扱うためのクラス。
FileSys | fileを扱うときに使うと良い。
FileSys.TmpFile |
GameFrame | ゲームで用いると便利なフレームクラス
LineParser |
LineParserIter | Class1 の概要の説明です。
StringConv | 文字列の変換補助用関数群

Interfaces

Interface | Description
ICacheObject | CacheLoaderで用いるオブジェクト基底クラス

Delegates

Delegate | Description
CacheLoader.CacheLoaderHandler |


CacheLoader Class

キャッシュメカニズムを実現するための基底クラス

For a list of all members of this type, see CacheLoader Members.

System.Object
Iter
CacheLoader

public class CacheLoader : Iter, IEnumerator, IEnumerable

Remarks

読み込んだファイルをためておき、古くなったファイルを自動的に 解放していく仕組み。 派生クラス側で loadFile と releaseFile をオーバーライドして使います。 詳しいことは、このクラスの派生クラス( SoundLoader , SurfaceLoader ) を見ればいいかも。 なお、オブジェクトは CacheObject の派生クラスだと仮定しています。

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

CacheLoader Members | y4cs.aux Namespace


CacheLoader Members

CacheLoader overview

Public Instance Constructors

CacheLoader Constructor Initializes a new instance of the CacheLoader class.

Public Instance Properties

Current
IsRunning (inherited from y4cs.native.iterator.Iter)
IsStarted (inherited from y4cs.native.iterator.Iter)

Public Instance Methods

checkRelease | 解放妥当性のチェック。
createInstance | cloneメソッド。
Dispose (inherited from y4cs.native.iterator.Iter) |
Equals (inherited from Object) |
get | noをアクセスする。暗黙のうちにオブジェクトは構築され、loadされる。
getCacheFiles | cacheしているファイル数を返す。
getCacheSize | cacheするバッファの上限を取得。
GetEnumerator |
GetHashCode (inherited from Object) |
getInfoList | ファイルリストの取得。
getObj | noを取得する。暗黙のうちにオブジェクトは構築されるが、loadはされない。
GetType (inherited from Object) |
isin | オブジェクトが生成されているかを調べる。
loadDefFile | 定義ファイルを読み込む。
loadDefRW | キャッシュリストを手渡しするための関数。
MoveNext |
print | 保持しているファイルリストの表示(デバッグ用)。
releaseAll | 保持していたキャッシュを解放する(ファイルリストは解放しない)。
releaseFileList | 保持していたファイルリスト、キャッシュを解放する。
releaseOldObject | 一番昔の時刻にアクセスされたファイルを解放するメソッド。
Reset |
Resume (inherited from y4cs.native.iterator.Iter) |
setCacheSize | cacheするバッファの上限を決める。
setUpdateCacheDelegate | 古いキャッシュの破棄メソッドの登録。
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
ToString (inherited from Object) |
updateFileList | ファイルリストを反映させる。

Protected Instance Fields

bStarted_ (inherited from y4cs.native.iterator.Iter) |
cachefiles | 実体を読み込んでいるファイルの数
cacheSize | cacheするサウンドバッファの上限(-1ならば無制限)。
filelist | ファイルリスト。
iterStart (inherited from y4cs.native.iterator.Iter) |
nowtime |
readPath | 実ファイル読み込みフォルダ。
state (inherited from y4cs.native.iterator.Iter) |
updateCacheDelegate | updateCacheで呼び出すdelegate。

Protected Instance Methods

checkCache | キャッシュがあふれたかを判定する。
createInfo | キャッシュ構造体のfactory。
Finalize |
getHelpper | 番号に対応するオブジェクトを読み込み、loadメソッドを呼び出す。
getHelpperObj | 番号に対応するオブジェクトを返す。
loadFile | 読み込みメソッド(派生クラス側でオーバーライドが必要)。
MemberwiseClone (inherited from Object) |
releaseFile | 解放メソッド(派生クラス側でオーバーライドが必要)。
yield (inherited from y4cs.native.iterator.Iter) |

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader Constructor

Initializes a new instance of the CacheLoader class.

public CacheLoader();

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader Fields

The fields of the CacheLoader class are listed below. For a complete list of CacheLoader class members, see the CacheLoader Members topic.

Protected Instance Fields

bStarted_ (inherited from y4cs.native.iterator.Iter) |
cachefiles | 実体を読み込んでいるファイルの数
cacheSize | cacheするサウンドバッファの上限(-1ならば無制限)。
filelist | ファイルリスト。
iterStart (inherited from y4cs.native.iterator.Iter) |
nowtime |
readPath | 実ファイル読み込みフォルダ。
state (inherited from y4cs.native.iterator.Iter) |
updateCacheDelegate | updateCacheで呼び出すdelegate。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.cachefiles Field

実体を読み込んでいるファイルの数

protected int cachefiles;

Remarks

キャッシュサイズに関して： システム全体で使用するテクスチャーサイズの総量を 固定したい場合などは、複数のTextureLoader間で このcacheSizeを共有する必要が出てくるが、 そういう使い方は現実的ではない（気がする）ので、 ここでは考えないことにする。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.cacheSize Field

cacheするサウンドバッファの上限(-1ならば無制限)。

protected long cacheSize;

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.filelist Field

ファイルリスト。

protected fastmap filelist;

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.nowtime Field

protected ulong nowtime;

Remarks

初期値は0で、アクセスごとにインクリメントされる。 long型なので、一秒間に100000回アクセスがあったとしても、 2^64 / 100000 / 60 / 60 / 24 / 365.24 = 5845420461年 よって実用上、十分であると言える。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.readPath Field

実ファイル読み込みフォルダ。

protected string readPath;

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.updateCacheDelegate Field

updateCacheで呼び出すdelegate。

protected CacheLoaderHandler updateCacheDelegate;

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader Properties

The properties of the CacheLoader class are listed below. For a complete list of CacheLoader class members, see the CacheLoader Members topic.

Public Instance Properties

Current
IsRunning (inherited from y4cs.native.iterator.Iter)
IsStarted (inherited from y4cs.native.iterator.Iter)

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader Methods

The methods of the CacheLoader class are listed below. For a complete list of CacheLoader class members, see the CacheLoader Members topic.

Public Instance Methods

checkRelease | 解放妥当性のチェック。
createInstance | cloneメソッド。
Dispose (inherited from y4cs.native.iterator.Iter) |
Equals (inherited from Object) |
get | noをアクセスする。暗黙のうちにオブジェクトは構築され、loadされる。
getCacheFiles | cacheしているファイル数を返す。
getCacheSize | cacheするバッファの上限を取得。
GetEnumerator |
GetHashCode (inherited from Object) |
getInfoList | ファイルリストの取得。
getObj | noを取得する。暗黙のうちにオブジェクトは構築されるが、loadはされない。
GetType (inherited from Object) |
isin | オブジェクトが生成されているかを調べる。
loadDefFile | 定義ファイルを読み込む。
loadDefRW | キャッシュリストを手渡しするための関数。
MoveNext |
print | 保持しているファイルリストの表示(デバッグ用)。
releaseAll | 保持していたキャッシュを解放する(ファイルリストは解放しない)。
releaseFileList | 保持していたファイルリスト、キャッシュを解放する。
releaseOldObject | 一番昔の時刻にアクセスされたファイルを解放するメソッド。
Reset |
Resume (inherited from y4cs.native.iterator.Iter) |
setCacheSize | cacheするバッファの上限を決める。
setUpdateCacheDelegate | 古いキャッシュの破棄メソッドの登録。
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
ToString (inherited from Object) |
updateFileList | ファイルリストを反映させる。

Protected Instance Methods

checkCache | キャッシュがあふれたかを判定する。
createInfo | キャッシュ構造体のfactory。
Finalize |
getHelpper | 番号に対応するオブジェクトを読み込み、loadメソッドを呼び出す。
getHelpperObj | 番号に対応するオブジェクトを返す。
loadFile | 読み込みメソッド(派生クラス側でオーバーライドが必要)。
MemberwiseClone (inherited from Object) |
releaseFile | 解放メソッド(派生クラス側でオーバーライドが必要)。
yield (inherited from y4cs.native.iterator.Iter) |

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.checkCache Method

キャッシュがあふれたかを判定する。

protected virtual void checkCache();

Remarks

必要ならば派生クラスでこのメソッドをオーバーライドするヨロシ。

Example

例)

                void checkCache() {
                    if (getCacheFiles() >= 10)
                        releaseOldObject();
                }
ディフォルトでは、全体のcache量(これは、CacheObjectのgetBufferSizeで取得 していく)が、cacheサイズに到達したら、一番最後にアクセスされたオブジェクト を解放するようになっている。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.checkRelease Method

解放妥当性のチェック。

public bool checkRelease(
Info info
);

Remarks

エンドレス再生中のBGM等、いくら一番最後にアクセスされたからと 言っても解放してはいけないデータがある。そういう場合は、派生クラス側で この関数がfalseを返すようにコーディングすること。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.createInfo Method

キャッシュ構造体のfactory。

protected virtual Info createInfo();

Remarks

構造体にさらに追加したい場合は、派生クラス側でこのfactoryを オーバーライドすること。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.createInstance Method

cloneメソッド。

public virtual object createInstance();

Remarks

派生クラス側でオーバーライドする

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.Finalize Method

protected override void Finalize();

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.get Method

noをアクセスする。暗黙のうちにオブジェクトは構築され、loadされる。

public virtual object get(
int no
);

Parameters

no

Return Value

Remarks

このクラスのものは仮コード。この派生クラスで実装しる。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.getCacheFiles Method

cacheしているファイル数を返す。

public int getCacheFiles();

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.getCacheSize Method

cacheするバッファの上限を取得。

public long getCacheSize();

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.GetEnumerator Method

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.getHelpper Method

番号に対応するオブジェクトを読み込み、loadメソッドを呼び出す。

protected object getHelpper(
int no
);

Remarks

ファイルリストに登録されていない番号ならnull。 実体化されていないならば実体化する。loadも行なう。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.getHelpperObj Method

番号に対応するオブジェクトを返す。

protected object getHelpperObj(
int no
);

Remarks

ファイルリストに登録されていない番号ならnull。 実体化されていないならば実体化する。loadは行なわない。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.getInfoList Method

ファイルリストの取得。

public fastmap getInfoList();

Remarks

最悪、こいつ使っていじってやって。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.getObj Method

noを取得する。暗黙のうちにオブジェクトは構築されるが、loadはされない。

public virtual object getObj(
int no
);

Remarks

このクラスのものは仮コード。この派生クラスで実装しる

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.isin Method

オブジェクトが生成されているかを調べる。

public bool isin(
int no
);

Remarks

例えば、Soundのloaderを考えてみよう。 Sound オブジェクトの生成と、Sound を読み込んでいるかとは 本来は別である。

cacheがあふれた場合、Sound.release()で、サウンドは解放するが、 Sound オブジェクト自体は解放しない。(これを解放すると、つぎに 要求されたときにnewが必要となるので、なるべくゲーム中に不要なnewを 発生させないためにこうなっている)

このクラスの派生クラス、例えば SoundLoader のgetメンバを呼び出すと、 Sound オブジェクトが生成されていなければ、生成し、かつ、サウンドを 読み込む。すなわち Sound.load が自動的に呼び出される。

このとき、サウンドオブジェクトが構築されているかどうかを 判定したりアクセスしたいということがある。基底クラスでは、 判定するほうのメンバを提供する。派生クラス側では、Sound.loadを 呼び出さない、単なるアクセス手段を提供する。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.loadDefFile Method

定義ファイルを読み込む。

public y4cs_result loadDefFile(
string filename
);

Parameters

filename
キャッシュするファイル名。

Return Value

y4cs_result列挙型。読み込みエラーが発生したときはno_error以外が返る。

Remarks

・定義ファイル仕様

file名 , 読み込み番号(load,getで指定するときの番号) , option1, option2 の繰り返し。読み込み番号,option1,2は省略可能。

以下はコメント 読み込み番号が指定された場合、そのあとは連番になる。 例)

  • a.wav , 2
  • b.wav # このファイルの番号は3になる
  • c.wav # このファイルの番号は4になる
ここで指定されているoptionが、どのような意味を持つかは、 このCacheLoaderクラスを使用するクラス(派生クラス？)に依存する。

その他、細かい解析ルールは、 LineParser クラスの内容に依存する。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.loadDefRW Method

キャッシュリストを手渡しするための関数。

public y4cs_result loadDefRW(
byte[] mem
);

Remarks

ファイルから読み込むかわりに、手渡しすることが出来る

Example

例)

            SoundLoader ca = new SoundLoader;
            ca.loadDefRW("ptn0.ogg \n ptn1.ogg \n");
            ca.play(1); // ptn1.oggが再生される

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.loadFile Method

読み込みメソッド(派生クラス側でオーバーライドが必要)。

protected virtual y4cs_result loadFile(
string filename,
ref object obj,
int option1,
int option2
);

Remarks

ファイル名のファイルを読み込み、objに入れて返す。 読み込みに失敗した場合は非0を返すように派生クラス側でコーディングする

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.MoveNext Method

public bool MoveNext();

Return Value

Implements

IEnumerator.MoveNext

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.print Method

保持しているファイルリストの表示(デバッグ用)。

public void print();

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.releaseAll Method

保持していたキャッシュを解放する(ファイルリストは解放しない)。

public void releaseAll();

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.releaseFile Method

解放メソッド(派生クラス側でオーバーライドが必要)。

protected virtual y4cs_result releaseFile(
ref object obj
);

Remarks

解放に失敗した場合は非0を返すように派生クラス側でコーディングする

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.releaseFileList Method

保持していたファイルリスト、キャッシュを解放する。

public void releaseFileList();

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.releaseOldObject Method

一番昔の時刻にアクセスされたファイルを解放するメソッド。

public virtual void releaseOldObject();

Remarks

通常、呼び出す必要はないが、派生クラス側で必要ならば呼び出してちょ ※　必要ならば派生クラス側でオーバーライドすること。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.setCacheSize Method

cacheするバッファの上限を決める。

public void setCacheSize(
long size
);

Remarks

cacheの単位はbyte。ディフォルトサイズは派生クラスで定義されている。 -1を設定すれば無制限キャッシュ。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.setUpdateCacheDelegate Method

古いキャッシュの破棄メソッドの登録。

public CacheLoaderHandler setUpdateCacheDelegate(
CacheLoaderHandler dg
);

Remarks

必要ならば設定してやってちょーだい。 派生クラスならば、単にcheckCacheメソッドをオーバーライドしても良い。

Example

            // 読み込み数が最大数(10)なら一番古いファイルを解放する場合は、
            //	こんなコードを書けば良い
            setUpdateCacheDelegate(delegate void updateCache(CacheLoader c) {
                if (c.getCacheFiles() >= 10)
                    c.releaseOldObject();
            });
注意:戻り値はdelegateなので、この派生クラスの派生クラス以降で この関数を使う場合は、delegate関数のなかで、この関数の戻りの delegateを呼び出す必要がある。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.updateFileList Method

ファイルリストを反映させる。

public void updateFileList();

Remarks

ファイルリストは内部的には連想配列になっているが、 巡回するときはvectorで巡回したほうが速い。 そこで、連想配列の内容をvectorに反映させるために呼び出す。 (loadDefFile/LoadDefRWでファイルを読み込むときはこの関数を 呼び出す必要はない。内部的に自動的に呼び出される)

※　必要があれば、派生クラス側でオーバーライドすること。

See Also

CacheLoader Class | y4cs.aux Namespace


CacheLoader.CacheLoaderHandler Delegate

public delegate void CacheLoader.CacheLoaderHandler(
CacheLoader c
);

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

y4cs.aux Namespace


CacheLoader.Info Class

このクラスの保持している情報構造体。

For a list of all members of this type, see CacheLoader.Info Members.

System.Object
CacheLoader.Info

public class CacheLoader.Info

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

CacheLoader.Info Members | y4cs.aux Namespace


CacheLoader.Info Members

CacheLoader.Info overview

Public Instance Constructors

CacheLoader.Info Constructor Initializes a new instance of the Info class.

Public Instance Fields

accesstime | 一番最後に参照された時刻(nowtimeを代入)。
bLoaded | 読み込まれているか。
bLoadFailed | 読み込み失敗の巻。
filename | 読み込みファイル名。
obj | 読み込んだデータ。
option1 | オプション。
option2 | オプション。

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

CacheLoader.Info Class | y4cs.aux Namespace


CacheLoader.Info Constructor

Initializes a new instance of the Info class.

public CacheLoader.Info();

See Also

CacheLoader.Info Class | y4cs.aux Namespace


CacheLoader.Info Fields

The fields of the CacheLoader.Info class are listed below. For a complete list of CacheLoader.Info class members, see the CacheLoader.Info Members topic.

Public Instance Fields

accesstime | 一番最後に参照された時刻(nowtimeを代入)。
bLoaded | 読み込まれているか。
bLoadFailed | 読み込み失敗の巻。
filename | 読み込みファイル名。
obj | 読み込んだデータ。
option1 | オプション。
option2 | オプション。

See Also

CacheLoader.Info Class | y4cs.aux Namespace


CacheLoader.Info.accesstime Field

一番最後に参照された時刻(nowtimeを代入)。

public ulong accesstime;

See Also

CacheLoader.Info Class | y4cs.aux Namespace


CacheLoader.Info.bLoaded Field

読み込まれているか。

public bool bLoaded;

See Also

CacheLoader.Info Class | y4cs.aux Namespace


CacheLoader.Info.bLoadFailed Field

読み込み失敗の巻。

public bool bLoadFailed;

See Also

CacheLoader.Info Class | y4cs.aux Namespace


CacheLoader.Info.filename Field

読み込みファイル名。

public string filename;

See Also

CacheLoader.Info Class | y4cs.aux Namespace


CacheLoader.Info.obj Field

読み込んだデータ。

public object obj;

See Also

CacheLoader.Info Class | y4cs.aux Namespace


CacheLoader.Info.option1 Field

オプション。

public int option1;

See Also

CacheLoader.Info Class | y4cs.aux Namespace


CacheLoader.Info.option2 Field

オプション。

public int option2;

See Also

CacheLoader.Info Class | y4cs.aux Namespace


CodeConv Class

日本語のコード変換を提供する。

For a list of all members of this type, see CodeConv Members.

System.Object
CodeConv

public class CodeConv

Remarks

日本語が出ないと嫌なので、簡単な変換関数を書いてみました。 参考ページ。 USC-2とUTF-8: http://homepage1.nifty.com/nomenclator/unicode/ucs_utf.htm ShiftJIS,Unicode(UTF-8): http://kamoland.com/comp/unicode.html 漢字コードについて: http://tohoho.wakusei.ne.jp/wwwkanji.htm

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

CodeConv Members | y4cs.aux Namespace


CodeConv Members

CodeConv overview

Public Static Methods

sjis_to_utf16le | sjisからutf16leへ。
sjis_to_utf8 | sjisからutf8へ
unicode_to_sjis |
unicode_to_utf8 |

Public Instance Constructors

CodeConv Constructor Initializes a new instance of the CodeConv class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

CodeConv Class | y4cs.aux Namespace


CodeConv Constructor

Initializes a new instance of the CodeConv class.

public CodeConv();

See Also

CodeConv Class | y4cs.aux Namespace


CodeConv Methods

The methods of the CodeConv class are listed below. For a complete list of CodeConv class members, see the CodeConv Members topic.

Public Static Methods

sjis_to_utf16le | sjisからutf16leへ。
sjis_to_utf8 | sjisからutf8へ
unicode_to_sjis |
unicode_to_utf8 |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

CodeConv Class | y4cs.aux Namespace


CodeConv.sjis_to_utf16le Method

sjisからutf16leへ。

public static string sjis_to_utf16le(
byte[] ansiStr
);

Parameters

ansiStr

Return Value

See Also

CodeConv Class | y4cs.aux Namespace


CodeConv.sjis_to_utf8 Method

sjisからutf8へ

public static byte[] sjis_to_utf8(
byte[] ansiStr
);

Parameters

ansiStr

Return Value

Remarks

memo: ISO-2022-JP ASCII文字セット：（１バイト文字）アルファベット、 数字、記号（合計94文字） JISX0208文字セット　 ：（２バイト文字）アルファベット、 ギリシャ文字、ロシア文字、数字、記号、第一水準漢字、第二水準漢字 （合計6879文字）

See Also

CodeConv Class | y4cs.aux Namespace


CodeConv.unicode_to_sjis Method

public static byte[] unicode_to_sjis(
string unicode
);

Parameters

unicode

Return Value

See Also

CodeConv Class | y4cs.aux Namespace


CodeConv.unicode_to_utf8 Method

public static byte[] unicode_to_utf8(
string unicode
);

Parameters

unicode

Return Value

See Also

CodeConv Class | y4cs.aux Namespace


DirEnumerator Class

ディレクトリ内のファイルを列挙するためのクラス。

For a list of all members of this type, see DirEnumerator Members.

System.Object
Iter
DirEnumerator

public class DirEnumerator : Iter, IEnumerator, IEnumerable

Example

使用例)

            DirEnumerator d = new DirEnumerator;
            d.setDir("temp/");
            foreach(char[] filename;d)
                printf("%.*s\n",filename);
※　現在のところ圧縮ファイルの中まで見に行く機能は未実装。 c:\doxygen\yaneSDK4D以下のすべてのファイルを unicode -> mbsに変換するサンプル
            DirEnumerator d = new DirEnumerator;
            d.setDir(r"c:\doxygen\yaneSDK4D");
            foreach(char[] filename;d){
                printf("now convert %.*s\n",filename);
                void[] v = FileSys.read(filename);
                if (v) {
                    void[] v2 = cast(void[])(toMBS((wchar[])v));
                    FileSys.write(filename,v2);
                }
            }
            return 0;

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

DirEnumerator Members | y4cs.aux Namespace


DirEnumerator Members

DirEnumerator overview

Public Static Methods

isDir | nameはディレクトリ名か？
isFile | nameはファイル名か？

Public Instance Constructors

DirEnumerator Constructor Initializes a new instance of the DirEnumerator class.

Public Instance Properties

Current
IsRunning (inherited from y4cs.native.iterator.Iter)
IsStarted (inherited from y4cs.native.iterator.Iter)

Public Instance Methods

Dispose (inherited from y4cs.native.iterator.Iter) |
Equals (inherited from Object) |
GetEnumerator |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isFileOnly | setFileOnlyで設定した内容を取得。
isSubDir | setSubDirで設定した内容を取得。
MoveNext |
Reset |
Resume (inherited from y4cs.native.iterator.Iter) |
setDir | 検索するディレクトリ名を設定。
setFileOnly | ファイルのみを対象とする(default:true)。
setSubDir | サブフォルダも検索対象にする(default:true)。
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
ToString (inherited from Object) |

Protected Instance Fields

bStarted_ (inherited from y4cs.native.iterator.Iter)
iterStart (inherited from y4cs.native.iterator.Iter)
state (inherited from y4cs.native.iterator.Iter)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
yield (inherited from y4cs.native.iterator.Iter)

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator Constructor

Initializes a new instance of the DirEnumerator class.

public DirEnumerator();

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator Properties

The properties of the DirEnumerator class are listed below. For a complete list of DirEnumerator class members, see the DirEnumerator Members topic.

Public Instance Properties

Current
IsRunning (inherited from y4cs.native.iterator.Iter)
IsStarted (inherited from y4cs.native.iterator.Iter)

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator Methods

The methods of the DirEnumerator class are listed below. For a complete list of DirEnumerator class members, see the DirEnumerator Members topic.

Public Static Methods

isDir | nameはディレクトリ名か？
isFile | nameはファイル名か？

Public Instance Methods

Dispose (inherited from y4cs.native.iterator.Iter) |
Equals (inherited from Object) |
GetEnumerator |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isFileOnly | setFileOnlyで設定した内容を取得。
isSubDir | setSubDirで設定した内容を取得。
MoveNext |
Reset |
Resume (inherited from y4cs.native.iterator.Iter) |
setDir | 検索するディレクトリ名を設定。
setFileOnly | ファイルのみを対象とする(default:true)。
setSubDir | サブフォルダも検索対象にする(default:true)。
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
yield (inherited from y4cs.native.iterator.Iter)

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.GetEnumerator Method

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.isDir Method

nameはディレクトリ名か？

public static bool isDir(
string name
);

Remarks

このファイルが存在しないと、例外が発生。

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.isFile Method

nameはファイル名か？

public static bool isFile(
string name
);

Remarks

このファイルが存在しないと、例外が発生。

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.isFileOnly Method

setFileOnlyで設定した内容を取得。

public bool isFileOnly();

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.isSubDir Method

setSubDirで設定した内容を取得。

public bool isSubDir();

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.MoveNext Method

public bool MoveNext();

Return Value

Implements

IEnumerator.MoveNext

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.setDir Method

検索するディレクトリ名を設定。

public void setDir(
string dirname_
);

Remarks

最後は'\'でも'/'でも、そうでなくとも良い。

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.setFileOnly Method

ファイルのみを対象とする(default:true)。

public void setFileOnly(
bool bFileOnly_
);

See Also

DirEnumerator Class | y4cs.aux Namespace


DirEnumerator.setSubDir Method

サブフォルダも検索対象にする(default:true)。

public void setSubDir(
bool bSubDir_
);

See Also

DirEnumerator Class | y4cs.aux Namespace


FileArchiverBase Class

Fileで用いる、圧縮ファイルを扱うためのクラス。

For a list of all members of this type, see FileArchiverBase Members.

System.Object
FileArchiverBase

public abstract class FileArchiverBase

Remarks

Fileにこのクラスの派生クラスをセットしてやれば、 FileSys.readやisExistで、圧縮ファイルも検索するようになる 実装例として FileArchiverZipFile も参考にすること。

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FileArchiverBase Members | y4cs.aux Namespace


FileArchiverBase Members

FileArchiverBase overview

Public Instance Methods

Equals (inherited from Object) |
getEnumerator | ファイルのenumeratorを返す。
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isExist |
read | 存在するか調べて読み込む。
ToString (inherited from Object) |
write | ファイルを書き込む。

Protected Instance Constructors

FileArchiverBase Constructor Initializes a new instance of the FileArchiverBase class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileArchiverBase Class | y4cs.aux Namespace


FileArchiverBase Constructor

Initializes a new instance of the FileArchiverBase class.

protected FileArchiverBase();

See Also

FileArchiverBase Class | y4cs.aux Namespace


FileArchiverBase Methods

The methods of the FileArchiverBase class are listed below. For a complete list of FileArchiverBase class members, see the FileArchiverBase Members topic.

Public Instance Methods

Equals (inherited from Object) |
getEnumerator | ファイルのenumeratorを返す。
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isExist |
read | 存在するか調べて読み込む。
ToString (inherited from Object) |
write | ファイルを書き込む。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileArchiverBase Class | y4cs.aux Namespace


FileArchiverBase.getEnumerator Method

ファイルのenumeratorを返す。

public abstract DirEnumerator getEnumerator();

Return Value

Remarks

自分のサポートする書庫ファイルの場合は、そのenumeratorを返す。

See Also

FileArchiverBase Class | y4cs.aux Namespace


FileArchiverBase.isExist Method

public abstract bool isExist(
string filename
);

See Also

FileArchiverBase Class | y4cs.aux Namespace


FileArchiverBase.read Method

存在するか調べて読み込む。

public abstract byte[] read(
string filename
);

Parameters

filename

Return Value

Remarks

存在しないときは、nullが戻る path等は無視。file名には '/'は用いておらず、'\'を用いてあり (linux環境では'/')、また、".."や"."は付帯していないと仮定して良い。

See Also

FileArchiverBase Class | y4cs.aux Namespace


FileArchiverBase.write Method

ファイルを書き込む。

public abstract y4cs_result write(
string filename,
byte[] data
);

Parameters

filename
data

Return Value

Remarks

このクラスのreadで読み出せるように書き込みを実装する (実装しなくとも良い) 書き出しに成功すれば0,失敗すれば非0が返るようにする。

See Also

FileArchiverBase Class | y4cs.aux Namespace


FileArchiverSample Class

独自形式の圧縮ファイルをシームレスに扱うためのクラス(サンプル)。

For a list of all members of this type, see FileArchiverSample Members.

System.Object
FileArchiverBase
FileArchiverSample

public class FileArchiverSample : FileArchiverBase

Remarks

FileSys.addArchiverでセットすれば、 FileSys.read / readRW / isExistで読み込るようになる。

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FileArchiverSample Members | y4cs.aux Namespace


FileArchiverSample Members

FileArchiverSample overview

Public Instance Constructors

FileArchiverSample Constructor Initializes a new instance of the FileArchiverSample class.

Public Instance Methods

Equals (inherited from Object) |
getEnumerator | enumeratorも実装しなくてok。
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isExist | 存在するかどうかのチェック関数。
read | 読み込む関数。
ToString (inherited from Object) |
write | 書き込む関数。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileArchiverSample Class | y4cs.aux Namespace


FileArchiverSample Constructor

Initializes a new instance of the FileArchiverSample class.

public FileArchiverSample();

See Also

FileArchiverSample Class | y4cs.aux Namespace


FileArchiverSample Methods

The methods of the FileArchiverSample class are listed below. For a complete list of FileArchiverSample class members, see the FileArchiverSample Members topic.

Public Instance Methods

Equals (inherited from Object) |
getEnumerator | enumeratorも実装しなくてok。
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isExist | 存在するかどうかのチェック関数。
read | 読み込む関数。
ToString (inherited from Object) |
write | 書き込む関数。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileArchiverSample Class | y4cs.aux Namespace


FileArchiverSample.getEnumerator Method

enumeratorも実装しなくてok。

public override DirEnumerator getEnumerator();

Return Value

See Also

FileArchiverSample Class | y4cs.aux Namespace


FileArchiverSample.isExist Method

存在するかどうかのチェック関数。

public override bool isExist(
string filename
);

Parameters

filename

Return Value

Remarks

ここでは、与えられたファイル名に".bin"を付与したファイルが存在すれば trueを返します。

See Also

FileArchiverSample Class | y4cs.aux Namespace


FileArchiverSample.read Method

読み込む関数。

public override byte[] read(
string filename
);

Parameters

filename

Return Value

Remarks

ここでは与えられたファイル名に".bin"を付与したファイルがあれば 読み込みます。(独自の圧縮形式等ならば、そのあと、decode処理を 行なえば良い)。

See Also

FileArchiverSample Class | y4cs.aux Namespace


FileArchiverSample.write Method

書き込む関数。

public override y4cs_result write(
string filename,
byte[] rdata
);

Parameters

filename
rdata

Return Value

Remarks

ここでは与えられたファイル名に".bin"を付与したファイルに書き出します。 (独自の圧縮形式等ならば、そのあと、encode処理を行なってから 書き出すと良い) この関数は実装していなくてもok

See Also

FileArchiverSample Class | y4cs.aux Namespace


FileArchiverYzp Class

For a list of all members of this type, see FileArchiverYzp Members.

System.Object
FileArchiverBase
FileArchiverYzp

public class FileArchiverYzp : FileArchiverBase

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FileArchiverYzp Members | y4cs.aux Namespace


FileArchiverYzp Members

FileArchiverYzp overview

Public Instance Constructors

FileArchiverYzp Overloaded. Initializes a new instance of the FileArchiverYzp class.

Public Instance Methods

Equals (inherited from Object) |
getEnumerator |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isExist |
read | Overloaded.
setPass | パスワードをあとから設定する。
ToString (inherited from Object) |
write |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileArchiverYzp Class | y4cs.aux Namespace


FileArchiverYzp Constructor

Initializes a new instance of the FileArchiverYzp class.

Overload List

Initializes a new instance of the FileArchiverYzp class.

public FileArchiverYzp();

public FileArchiverYzp(string);

See Also

FileArchiverYzp Class | y4cs.aux Namespace


FileArchiverYzp Constructor ()

Initializes a new instance of the FileArchiverYzp class.

public FileArchiverYzp();

See Also

FileArchiverYzp Class | y4cs.aux Namespace | FileArchiverYzp Constructor Overload List


FileArchiverYzp Constructor (String)

public FileArchiverYzp(
string password_
);

See Also

FileArchiverYzp Class | y4cs.aux Namespace | FileArchiverYzp Constructor Overload List


FileArchiverYzp Methods

The methods of the FileArchiverYzp class are listed below. For a complete list of FileArchiverYzp class members, see the FileArchiverYzp Members topic.

Public Instance Methods

Equals (inherited from Object) |
getEnumerator |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isExist |
read | Overloaded.
setPass | パスワードをあとから設定する。
ToString (inherited from Object) |
write |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileArchiverYzp Class | y4cs.aux Namespace


FileArchiverYzp.getEnumerator Method

public override DirEnumerator getEnumerator();

See Also

FileArchiverYzp Class | y4cs.aux Namespace


FileArchiverYzp.isExist Method

public override bool isExist(
string filename
);

See Also

FileArchiverYzp Class | y4cs.aux Namespace


read Method

Yaneurao Game Library 4th for C#

FileArchiverYzp.read Method

Overload List

public override byte[] read(string);

public bool read(string,string,bool,out byte[]);

See Also

FileArchiverYzp Class | y4cs.aux Namespace


FileArchiverYzp.read Method (String)

public override byte[] read(
string filename
);

See Also

FileArchiverYzp Class | y4cs.aux Namespace | FileArchiverYzp.read Overload List


FileArchiverYzp.read Method (String, String, Boolean, Byte[])

public bool read(
string filename,
string innerFileName,
bool bRead,
out byte[] buff
);

See Also

FileArchiverYzp Class | y4cs.aux Namespace | FileArchiverYzp.read Overload List


FileArchiverYzp.setPass Method

パスワードをあとから設定する。

public void setPass(
string pass
);

Parameters

pass

Remarks

passwordが""(空の文字列)なら、暗号化パスワードは 設定されていないことになる。

writeするときにも、ここで設定した暗号化パスワードを用いて 書き込みされる。

readするときは、暗号化されていないファイルならば、 パスワードが設定されてようが、されていまいが、構わず読み込める。 暗号化しているファイルの場合、パスワードが設定されていないと 読み込めない。パスワードがwriteした時のものと異なっている場合は 正しく読み込めない。

See Also

FileArchiverYzp Class | y4cs.aux Namespace


FileArchiverYzp.write Method

public override y4cs_result write(
string filename,
byte[] data
);

Parameters

filename
data

Return Value

See Also

FileArchiverYzp Class | y4cs.aux Namespace


FileArchiverZip Class

For a list of all members of this type, see FileArchiverZip Members.

System.Object
FileArchiverBase
FileArchiverZip

public class FileArchiverZip : FileArchiverBase

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FileArchiverZip Members | y4cs.aux Namespace


FileArchiverZip Members

FileArchiverZip overview

Public Instance Constructors

FileArchiverZip Constructor Initializes a new instance of the FileArchiverZip class.

Public Instance Methods

Equals (inherited from Object)
getEnumerator
GetHashCode (inherited from Object)
GetType (inherited from Object)
isExist
read
ToString (inherited from Object)
write

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileArchiverZip Class | y4cs.aux Namespace


FileArchiverZip Constructor

Initializes a new instance of the FileArchiverZip class.

public FileArchiverZip();

See Also

FileArchiverZip Class | y4cs.aux Namespace


FileArchiverZip Methods

The methods of the FileArchiverZip class are listed below. For a complete list of FileArchiverZip class members, see the FileArchiverZip Members topic.

Public Instance Methods

Equals (inherited from Object)
getEnumerator
GetHashCode (inherited from Object)
GetType (inherited from Object)
isExist
read
ToString (inherited from Object)
write

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileArchiverZip Class | y4cs.aux Namespace


FileArchiverZip.getEnumerator Method

public override DirEnumerator getEnumerator();

See Also

FileArchiverZip Class | y4cs.aux Namespace


FileArchiverZip.isExist Method

public override bool isExist(
string filename
);

See Also

FileArchiverZip Class | y4cs.aux Namespace


FileArchiverZip.read Method

public override byte[] read(
string filename
);

See Also

FileArchiverZip Class | y4cs.aux Namespace


FileArchiverZip.write Method

public override y4cs_result write(
string filename,
byte[] data
);

Parameters

filename
data

Return Value

See Also

FileArchiverZip Class | y4cs.aux Namespace


FileArchiverZipFile Class

.zip ファイル(単体)をシームレスに扱うためのクラス。

For a list of all members of this type, see FileArchiverZipFile Members.

System.Object
FileArchiverBase
FileArchiverZipFile

public class FileArchiverZipFile : FileArchiverBase

Remarks

src/some.txt.zipのアーカイブがあれば、 src/some.txt とアクセスすることが出来る。

Example

使用例)

                FileSys.addArchiver(new FileArchiverZipFile);
                void[] data = FileSys.read("src/some.txt");
※ phobosのzlibのランタイムを使用しているため、通常のzipファイルではなく zlibで扱っているzipファイルしか解凍できない。

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FileArchiverZipFile Members | y4cs.aux Namespace


FileArchiverZipFile Members

FileArchiverZipFile overview

Public Instance Constructors

FileArchiverZipFile Constructor Initializes a new instance of the FileArchiverZipFile class.

Public Instance Methods

Equals (inherited from Object) |
getEnumerator | enumeratorも実装しなくてok。
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isExist |
read |
ToString (inherited from Object) |
write |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileArchiverZipFile Class | y4cs.aux Namespace


FileArchiverZipFile Constructor

Initializes a new instance of the FileArchiverZipFile class.

public FileArchiverZipFile();

See Also

FileArchiverZipFile Class | y4cs.aux Namespace


FileArchiverZipFile Methods

The methods of the FileArchiverZipFile class are listed below. For a complete list of FileArchiverZipFile class members, see the FileArchiverZipFile Members topic.

Public Instance Methods

Equals (inherited from Object) |
getEnumerator | enumeratorも実装しなくてok。
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isExist |
read |
ToString (inherited from Object) |
write |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileArchiverZipFile Class | y4cs.aux Namespace


FileArchiverZipFile.getEnumerator Method

enumeratorも実装しなくてok。

public override DirEnumerator getEnumerator();

Return Value

See Also

FileArchiverZipFile Class | y4cs.aux Namespace


FileArchiverZipFile.isExist Method

public override bool isExist(
string filename
);

Parameters

filename

Return Value

See Also

FileArchiverZipFile Class | y4cs.aux Namespace


FileArchiverZipFile.read Method

public override byte[] read(
string filename
);

Parameters

filename

Return Value

See Also

FileArchiverZipFile Class | y4cs.aux Namespace


FileArchiverZipFile.write Method

public override y4cs_result write(
string filename,
byte[] data
);

Parameters

filename
data

Return Value

See Also

FileArchiverZipFile Class | y4cs.aux Namespace


FileSys Class

fileを扱うときに使うと良い。

For a list of all members of this type, see FileSys Members.

System.Object
FileSys

public class FileSys

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FileSys Members | y4cs.aux Namespace


FileSys Members

FileSys overview

Public Static Methods

addPath |
concat |
getDirName | 親フォルダ名を返す。
getPathList |
getPureFileName |
getTmpFile |
isExist |
isRealExist |
makeFullName | Overloaded.
read |
readRW |
readSimple |
setPath |
write | Overloaded.
writeSimple |

Public Instance Constructors

FileSys Constructor Initializes a new instance of the FileSys class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileSys Class | y4cs.aux Namespace


FileSys Constructor

Initializes a new instance of the FileSys class.

public FileSys();

See Also

FileSys Class | y4cs.aux Namespace


FileSys Methods

The methods of the FileSys class are listed below. For a complete list of FileSys class members, see the FileSys Members topic.

Public Static Methods

addPath |
concat |
getDirName | 親フォルダ名を返す。
getPathList |
getPureFileName |
getTmpFile |
isExist |
isRealExist |
makeFullName | Overloaded.
read |
readRW |
readSimple |
setPath |
write | Overloaded.
writeSimple |

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileSys Class | y4cs.aux Namespace


FileSys.addPath Method

public static void addPath(
string p
);

See Also

FileSys Class | y4cs.aux Namespace


FileSys.concat Method

public static string concat(
string a,
string b
);

See Also

FileSys Class | y4cs.aux Namespace


FileSys.getDirName Method

親フォルダ名を返す。

public static string getDirName(
string fname
);

Parameters

fname

Return Value

Remarks

ディレクトリ名の取得。 例えば、 "d:\path\foo.bat" なら "d:\path\" を返します。 "d:\path"や"d:\path\"ならば、"d:\"を返します。 ※　std.path.getDirNameでは、"d:\path\"に対しては "d:\path"を返すことに注意。 ※　windows環境においては、'/' は使えないことに注意。 (std.path.sep=='\\'であるため) ※　終端は必ず'\'のついている状態になる ※　終端が ".." , "..\" , "../"ならば、これは駆け上がり不可。 (".."の場合も終端は必ず'\'のついている状態になる)

See Also

FileSys Class | y4cs.aux Namespace


FileSys.getPathList Method

public static vector getPathList();

See Also

FileSys Class | y4cs.aux Namespace


FileSys.getPureFileName Method

public static string getPureFileName(
string filename
);

Parameters

filename

Return Value

See Also

FileSys Class | y4cs.aux Namespace


FileSys.getTmpFile Method

public static TmpFile getTmpFile(
string filename
);

See Also

FileSys Class | y4cs.aux Namespace


FileSys.isExist Method

public static bool isExist(
string filename
);

See Also

FileSys Class | y4cs.aux Namespace


FileSys.isRealExist Method

public static string isRealExist(
string filename
);

See Also

FileSys Class | y4cs.aux Namespace


makeFullName Method

Yaneurao Game Library 4th for C#

FileSys.makeFullName Method

Overload List

public static string makeFullName(string);

public static string makeFullName(string,string);

See Also

FileSys Class | y4cs.aux Namespace


FileSys.makeFullName Method (String)

public static string makeFullName(
string filename
);

See Also

FileSys Class | y4cs.aux Namespace | FileSys.makeFullName Overload List


FileSys.makeFullName Method (String, String)

public static string makeFullName(
string localpath,
string filename
);

See Also

FileSys Class | y4cs.aux Namespace | FileSys.makeFullName Overload List


FileSys.read Method

public static byte[] read(
string filename
);

See Also

FileSys Class | y4cs.aux Namespace


FileSys.readRW Method

public static SDL_RWops readRW(
string filename
);

See Also

FileSys Class | y4cs.aux Namespace


FileSys.readSimple Method

public static byte[] readSimple(
string filename
);

See Also

FileSys Class | y4cs.aux Namespace


FileSys.setPath Method

public static void setPath(
string[] p
);

See Also

FileSys Class | y4cs.aux Namespace


write Method

Yaneurao Game Library 4th for C#

FileSys.write Method

Overload List

public static y4cs_result write(string,byte[]);

public static y4cs_result write(string,byte[],FileArchiverBase);

See Also

FileSys Class | y4cs.aux Namespace


FileSys.write Method (String, Byte[])

public static y4cs_result write(
string filename,
byte[] data
);

See Also

FileSys Class | y4cs.aux Namespace | FileSys.write Overload List


FileSys.write Method (String, Byte[], FileArchiverBase)

public static y4cs_result write(
string filename,
byte[] data,
FileArchiverBase arc
);

See Also

FileSys Class | y4cs.aux Namespace | FileSys.write Overload List


FileSys.writeSimple Method

public static y4cs_result writeSimple(
string filename,
byte[] rdata
);

See Also

FileSys Class | y4cs.aux Namespace


FileSys.TmpFile Class

For a list of all members of this type, see FileSys.TmpFile Members.

System.Object
FileSys.TmpFile

public class FileSys.TmpFile : IDisposable

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FileSys.TmpFile Members | y4cs.aux Namespace


FileSys.TmpFile Members

FileSys.TmpFile overview

Public Instance Constructors

FileSys.TmpFile Overloaded. Initializes a new instance of the FileSys.TmpFile class.

Public Instance Methods

Dispose |
Equals (inherited from Object) |
getFileName | ファイル名を返す。
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
release | 確保していたテンポラリファイルを解放する(作成していたときのみ)。
setFile | 実在するファイルを設定する。
setMemory | byte[]を渡して、テンポラリファイルを生成する。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileSys.TmpFile Class | y4cs.aux Namespace


FileSys.TmpFile Constructor

事前に用意されたファイルをセットする。

Overload List

バッファを渡して、そのバッファの内容のファイルを生成。

public FileSys.TmpFile(byte[]);

事前に用意されたファイルをセットする。

public FileSys.TmpFile(string);

See Also

FileSys.TmpFile Class | y4cs.aux Namespace


FileSys.TmpFile Constructor (String)

事前に用意されたファイルをセットする。

public FileSys.TmpFile(
string file
);

Parameters

file

See Also

FileSys.TmpFile Class | y4cs.aux Namespace | FileSys.TmpFile Constructor Overload List


FileSys.TmpFile Constructor (Byte[])

バッファを渡して、そのバッファの内容のファイルを生成。

public FileSys.TmpFile(
byte[] mem
);

Parameters

mem

Remarks

内部的にはmakeFileを用いてテンポラリファイルを生成している。

See Also

FileSys.TmpFile Class | y4cs.aux Namespace | FileSys.TmpFile Constructor Overload List


FileSys.TmpFile Methods

The methods of the FileSys.TmpFile class are listed below. For a complete list of FileSys.TmpFile class members, see the FileSys.TmpFile Members topic.

Public Instance Methods

Dispose |
Equals (inherited from Object) |
getFileName | ファイル名を返す。
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
release | 確保していたテンポラリファイルを解放する(作成していたときのみ)。
setFile | 実在するファイルを設定する。
setMemory | byte[]を渡して、テンポラリファイルを生成する。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FileSys.TmpFile Class | y4cs.aux Namespace


FileSys.TmpFile.Dispose Method

public void Dispose();

Implements

IDisposable.Dispose

See Also

FileSys.TmpFile Class | y4cs.aux Namespace


FileSys.TmpFile.getFileName Method

ファイル名を返す。

public string getFileName();

Return Value

Remarks

setFileで設定されたファイル名および、setMemoryで メモリを渡されたときに生成されたテンポラリファイル名を返します。

See Also

FileSys.TmpFile Class | y4cs.aux Namespace


FileSys.TmpFile.release Method

確保していたテンポラリファイルを解放する(作成していたときのみ)。

public void release();

Remarks

setMemoryでファイルを生成していたときのみファイルを削除。 setFileで設定していた場合は、ファイルは削除しない。

See Also

FileSys.TmpFile Class | y4cs.aux Namespace


FileSys.TmpFile.setFile Method

実在するファイルを設定する。

public void setFile(
string file
);

Parameters

file

Remarks

実在するファイルなので終了するときに削除はされない。 削除されるのは、setMemoryでファイルを生成したときのみ。

See Also

FileSys.TmpFile Class | y4cs.aux Namespace


FileSys.TmpFile.setMemory Method

byte[]を渡して、テンポラリファイルを生成する。

public y4cs_result setMemory(
byte[] mem
);

Parameters

mem

Return Value

Remarks

渡されるmemが、nullならば、テンポラリファイルは生成しない。 生成に失敗したら非0が返る。 @portnote テンポラリファイルの作成は環境依存。移植時に注意が必要。

See Also

FileSys.TmpFile Class | y4cs.aux Namespace


GameFrame Class

ゲームで用いると便利なフレームクラス

For a list of all members of this type, see GameFrame Members.

System.Object
GameFrame

public class GameFrame

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

GameFrame Members | y4cs.aux Namespace


GameFrame Members

GameFrame overview

Public Static Methods

pollEvent

Public Instance Constructors

GameFrame Constructor Initializes a new instance of the GameFrame class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

GameFrame Class | y4cs.aux Namespace


GameFrame Constructor

Initializes a new instance of the GameFrame class.

public GameFrame();

See Also

GameFrame Class | y4cs.aux Namespace


GameFrame Methods

The methods of the GameFrame class are listed below. For a complete list of GameFrame class members, see the GameFrame Members topic.

Public Static Methods

pollEvent

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

GameFrame Class | y4cs.aux Namespace


GameFrame.pollEvent Method

public static int pollEvent();

See Also

GameFrame Class | y4cs.aux Namespace


ICacheObject Interface

CacheLoaderで用いるオブジェクト基底クラス

For a list of all members of this type, see ICacheObject Members.

public interface ICacheObject

Remarks

確保しているバッファのサイズを返す関数のみを持っている。 CacheLoader は、この関数に問い合わせ、指定されているキャッシュ容量に なれば解放するようにディフォルト動作はなっている。

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

ICacheObject Members | y4cs.aux Namespace


ICacheObject Members

ICacheObject overview

Public Instance Methods

getBufferSize 確保しているバッファのサイズを返す関数。

See Also

ICacheObject Interface | y4cs.aux Namespace


ICacheObject Methods

The methods of the ICacheObject interface are listed below. For a complete list of ICacheObject interface members, see the ICacheObject Members topic.

Public Instance Methods

getBufferSize 確保しているバッファのサイズを返す関数。

See Also

ICacheObject Interface | y4cs.aux Namespace


ICacheObject.getBufferSize Method

確保しているバッファのサイズを返す関数。

ulong getBufferSize();

Return Value

確保しているバッファサイズ。

See Also

ICacheObject Interface | y4cs.aux Namespace


LineParser Class

For a list of all members of this type, see LineParser Members.

System.Object
LineParser

public class LineParser : IEnumerable

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

LineParser Members | y4cs.aux Namespace


LineParser Members

LineParser overview

Public Static Methods

getDecimal | Overloaded.
getNum | Overloaded.

Public Instance Constructors

LineParser Overloaded. Initializes a new instance of the LineParser class.

Public Instance Methods

Equals (inherited from Object) |
getDecimal | Overloaded.
GetEnumerator |
GetHashCode (inherited from Object) |
getNum | Overloaded.
getStr |
GetType (inherited from Object) |
isEnd |
setLine |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

LineParser Class | y4cs.aux Namespace


LineParser Constructor

Initializes a new instance of the LineParser class.

Overload List

Initializes a new instance of the LineParser class.

public LineParser();

public LineParser(string);

See Also

LineParser Class | y4cs.aux Namespace


LineParser Constructor ()

Initializes a new instance of the LineParser class.

public LineParser();

See Also

LineParser Class | y4cs.aux Namespace | LineParser Constructor Overload List


LineParser Constructor (String)

public LineParser(
string linebuf
);

See Also

LineParser Class | y4cs.aux Namespace | LineParser Constructor Overload List


LineParser Methods

The methods of the LineParser class are listed below. For a complete list of LineParser class members, see the LineParser Members topic.

Public Static Methods

getDecimal | Overloaded.
getNum | Overloaded.

Public Instance Methods

Equals (inherited from Object) |
getDecimal | Overloaded.
GetEnumerator |
GetHashCode (inherited from Object) |
getNum | Overloaded.
getStr |
GetType (inherited from Object) |
isEnd |
setLine |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

LineParser Class | y4cs.aux Namespace


getDecimal Method

Yaneurao Game Library 4th for C#

LineParser.getDecimal Method

Overload List

public double getDecimal(double);

public static double getDecimal(string,double);

See Also

LineParser Class | y4cs.aux Namespace


LineParser.getDecimal Method (Double)

public double getDecimal(
double def
);

See Also

LineParser Class | y4cs.aux Namespace | LineParser.getDecimal Overload List


LineParser.getDecimal Method (String, Double)

public static double getDecimal(
string s,
double def
);

See Also

LineParser Class | y4cs.aux Namespace | LineParser.getDecimal Overload List


LineParser.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

LineParser Class | y4cs.aux Namespace


getNum Method

Yaneurao Game Library 4th for C#

LineParser.getNum Method

Overload List

public long getNum(long);

public static long getNum(string,long);

See Also

LineParser Class | y4cs.aux Namespace


LineParser.getNum Method (Int64)

public long getNum(
long def
);

See Also

LineParser Class | y4cs.aux Namespace | LineParser.getNum Overload List


LineParser.getNum Method (String, Int64)

public static long getNum(
string s,
long def
);

See Also

LineParser Class | y4cs.aux Namespace | LineParser.getNum Overload List


LineParser.getStr Method

public string getStr();

See Also

LineParser Class | y4cs.aux Namespace


LineParser.isEnd Method

public bool isEnd();

See Also

LineParser Class | y4cs.aux Namespace


LineParser.setLine Method

public void setLine(
string linebuf
);

See Also

LineParser Class | y4cs.aux Namespace


LineParserIter Class

Class1 の概要の説明です。

For a list of all members of this type, see LineParserIter Members.

System.Object
LineParserIter

public class LineParserIter : IEnumerator

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

LineParserIter Members | y4cs.aux Namespace


LineParserIter Members

LineParserIter overview

Public Instance Constructors

LineParserIter Constructor

Public Instance Properties

Current

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

LineParserIter Class | y4cs.aux Namespace


LineParserIter Constructor

public LineParserIter(
LineParser parser
);

Parameters

parser

See Also

LineParserIter Class | y4cs.aux Namespace


LineParserIter Properties

The properties of the LineParserIter class are listed below. For a complete list of LineParserIter class members, see the LineParserIter Members topic.

Public Instance Properties

Current

See Also

LineParserIter Class | y4cs.aux Namespace


LineParserIter.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

LineParserIter Class | y4cs.aux Namespace


LineParserIter Methods

The methods of the LineParserIter class are listed below. For a complete list of LineParserIter class members, see the LineParserIter Members topic.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

LineParserIter Class | y4cs.aux Namespace


LineParserIter.MoveNext Method

public bool MoveNext();

Return Value

Implements

IEnumerator.MoveNext

See Also

LineParserIter Class | y4cs.aux Namespace


LineParserIter.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

LineParserIter Class | y4cs.aux Namespace


StringConv Class

文字列の変換補助用関数群

For a list of all members of this type, see StringConv Members.

System.Object
StringConv

public abstract class StringConv

Requirements

Namespace: y4cs.aux

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

StringConv Members | y4cs.aux Namespace


StringConv Members

StringConv overview

Public Static Methods

print |
toBin | Overloaded.
toConvHelpperS |
toConvHelpperU |
toDec | Overloaded.
toHex | Overloaded.
toOct | Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

StringConv Constructor Initializes a new instance of the StringConv class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

StringConv Class | y4cs.aux Namespace


StringConv Constructor

Initializes a new instance of the StringConv class.

protected StringConv();

See Also

StringConv Class | y4cs.aux Namespace


StringConv Methods

The methods of the StringConv class are listed below. For a complete list of StringConv class members, see the StringConv Members topic.

Public Static Methods

print |
toBin | Overloaded.
toConvHelpperS |
toConvHelpperU |
toDec | Overloaded.
toHex | Overloaded.
toOct | Overloaded.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

StringConv Class | y4cs.aux Namespace


StringConv.print Method

public static void print(
string data
);

See Also

StringConv Class | y4cs.aux Namespace


toBin Method

Yaneurao Game Library 4th for C#

StringConv.toBin Method

Overload List

public static string toBin(int);

public static string toBin(int,int);

See Also

StringConv Class | y4cs.aux Namespace


StringConv.toBin Method (Int32)

public static string toBin(
int u
);

See Also

StringConv Class | y4cs.aux Namespace | StringConv.toBin Overload List


StringConv.toBin Method (Int32, Int32)

public static string toBin(
int u,
int m
);

See Also

StringConv Class | y4cs.aux Namespace | StringConv.toBin Overload List


StringConv.toConvHelpperS Method

public static string toConvHelpperS(
int u,
int n,
int m,
char c
);

See Also

StringConv Class | y4cs.aux Namespace


StringConv.toConvHelpperU Method

public static string toConvHelpperU(
uint u,
int n,
int m,
char c
);

See Also

StringConv Class | y4cs.aux Namespace


toDec Method

Yaneurao Game Library 4th for C#

StringConv.toDec Method

Overload List

public static string toDec(int);

public static string toDec(int,int);

See Also

StringConv Class | y4cs.aux Namespace


StringConv.toDec Method (Int32)

public static string toDec(
int u
);

See Also

StringConv Class | y4cs.aux Namespace | StringConv.toDec Overload List


StringConv.toDec Method (Int32, Int32)

public static string toDec(
int u,
int m
);

See Also

StringConv Class | y4cs.aux Namespace | StringConv.toDec Overload List


toHex Method

Yaneurao Game Library 4th for C#

StringConv.toHex Method

Overload List

public static string toHex(uint);

public static string toHex(uint,int);

See Also

StringConv Class | y4cs.aux Namespace


StringConv.toHex Method (UInt32)

public static string toHex(
uint u
);

See Also

StringConv Class | y4cs.aux Namespace | StringConv.toHex Overload List


StringConv.toHex Method (UInt32, Int32)

public static string toHex(
uint u,
int m
);

See Also

StringConv Class | y4cs.aux Namespace | StringConv.toHex Overload List


toOct Method

Yaneurao Game Library 4th for C#

StringConv.toOct Method

Overload List

public static string toOct(int);

public static string toOct(int,int);

See Also

StringConv Class | y4cs.aux Namespace


StringConv.toOct Method (Int32)

public static string toOct(
int u
);

See Also

StringConv Class | y4cs.aux Namespace | StringConv.toOct Overload List


StringConv.toOct Method (Int32, Int32)

public static string toOct(
int u,
int m
);

See Also

StringConv Class | y4cs.aux Namespace | StringConv.toOct Overload List


y4cs.draw

Yaneurao Game Library 4th for C#

y4cs.draw Namespace

Classes

Class | Description
DrawContext | 描画用のContext。
DrawLayer | 描画Layerクラスの基底クラス。
Font | 文字の描画用クラス
FontLoader | 文字フォントのcacheシステム。
FontRepository | 文字テクスチャーのキャッシュ用クラス。
FontRepository.Info | ひとつの文字に対する情報。
FpsLayer | FPSを画面に表示するクラス。
Screen | 画面を表現しているサーフェース
Surface | 描画のためのサーフェース
Texture | Screen に画像を描画するためのサーフェース
TextureLoader | Texture の cacheメカニズムを実現する。
TextureVector | テクスチャーのvector。
TextureVector.TextureInfo | それぞれのテクスチャーの存在する位置を表す構造体。

Interfaces

Interface | Description
ITextureBase | Texture転送の基底クラス。
ITextureTrans | Texture転送の基底クラス。

Structures

Structure | Description
Point |
Rect |
Size | サイズを表している構造体。


DrawContext Class

描画用のContext。

For a list of all members of this type, see DrawContext Members.

System.Object
DrawContext

public class DrawContext

Remarks

矩形でのclippingの実現のために、openGLの glViewport(x1,screenSizeY-y2,x2-x1,y2-y1); glOrtho(x1,x2,y2,y1,0,256); を行なっている箇所があるので、これがまずければ、このDrawContext依存系の 描画は行なわないこと。

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

DrawContext Members | y4cs.draw Namespace


DrawContext Members

DrawContext overview

Public Instance Constructors

DrawContext Constructor コンストラクタ。

Public Instance Fields

bClip | clipするときはこれがtrue。
bottom | 描画するときのclip情報 下。
bottomR | rateとscreenSize,offsetを反映させたもの。実clip座標。
left | 描画するときのclip情報 左。
leftR | rateとscreenSize,offsetを反映させたもの。実clip座標。
offsetRX | offsetRX = offsetX * screenSizeX , offsetRY = offsetY * screenSizeY。
offsetRY | offsetRX = offsetX * screenSizeX , offsetRY = offsetY * screenSizeY。
offsetX | スクリーンのオフセット値。
offsetY | スクリーンのオフセット値。
rateX | 描画時の倍率。
rateY | 描画時の倍率。
right | 描画するときのclip情報 右。
rightR | rateとscreenSize,offsetを反映させたもの。実clip座標。
screenSizeX | 640×480ならば640。
screenSizeY | 640×480ならば480。
top | 描画するときのclip情報 上。
topR | rateとscreenSize,offsetを反映させたもの。実clip座標。

Public Instance Methods

clone | クローンメソッド。
disableClip | クリップを無効にする(default)。
enableClip | クリップを有効にする。
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getOffset | スクリーンのオフセット値を取得する。
getRate | 描画時の倍率の取得。
getScreenSize | 画面サイズの取得。
GetType (inherited from Object) |
isClip | クリップが有効かどうかを取得する。
setClipRect | Overloaded. クリップする矩形を指定する。
setOffset | スクリーンのオフセット値を設定する。
setRate | 描画時の倍率の設定。
setScreenSize | 画面サイズの設定。
ToString (inherited from Object) |
update | update。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext Constructor

コンストラクタ。

public DrawContext();

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext Fields

The fields of the DrawContext class are listed below. For a complete list of DrawContext class members, see the DrawContext Members topic.

Public Instance Fields

bClip | clipするときはこれがtrue。
bottom | 描画するときのclip情報 下。
bottomR | rateとscreenSize,offsetを反映させたもの。実clip座標。
left | 描画するときのclip情報 左。
leftR | rateとscreenSize,offsetを反映させたもの。実clip座標。
offsetRX | offsetRX = offsetX * screenSizeX , offsetRY = offsetY * screenSizeY。
offsetRY | offsetRX = offsetX * screenSizeX , offsetRY = offsetY * screenSizeY。
offsetX | スクリーンのオフセット値。
offsetY | スクリーンのオフセット値。
rateX | 描画時の倍率。
rateY | 描画時の倍率。
right | 描画するときのclip情報 右。
rightR | rateとscreenSize,offsetを反映させたもの。実clip座標。
screenSizeX | 640×480ならば640。
screenSizeY | 640×480ならば480。
top | 描画するときのclip情報 上。
topR | rateとscreenSize,offsetを反映させたもの。実clip座標。

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.bClip Field

clipするときはこれがtrue。

public bool bClip;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.bottom Field

描画するときのclip情報 下。

public float bottom;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.bottomR Field

rateとscreenSize,offsetを反映させたもの。実clip座標。

public float bottomR;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.left Field

描画するときのclip情報 左。

public float left;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.leftR Field

rateとscreenSize,offsetを反映させたもの。実clip座標。

public float leftR;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.offsetRX Field

offsetRX = offsetX * screenSizeX , offsetRY = offsetY * screenSizeY。

public float offsetRX;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.offsetRY Field

offsetRX = offsetX * screenSizeX , offsetRY = offsetY * screenSizeY。

public float offsetRY;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.offsetX Field

スクリーンのオフセット値。

public float offsetX;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.offsetY Field

スクリーンのオフセット値。

public float offsetY;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.rateX Field

描画時の倍率。

public float rateX;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.rateY Field

描画時の倍率。

public float rateY;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.right Field

描画するときのclip情報 右。

public float right;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.rightR Field

rateとscreenSize,offsetを反映させたもの。実clip座標。

public float rightR;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.screenSizeX Field

640×480ならば640。

public float screenSizeX;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.screenSizeY Field

640×480ならば480。

public float screenSizeY;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.top Field

描画するときのclip情報 上。

public float top;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.topR Field

rateとscreenSize,offsetを反映させたもの。実clip座標。

public float topR;

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext Methods

The methods of the DrawContext class are listed below. For a complete list of DrawContext class members, see the DrawContext Members topic.

Public Instance Methods

clone | クローンメソッド。
disableClip | クリップを無効にする(default)。
enableClip | クリップを有効にする。
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getOffset | スクリーンのオフセット値を取得する。
getRate | 描画時の倍率の取得。
getScreenSize | 画面サイズの取得。
GetType (inherited from Object) |
isClip | クリップが有効かどうかを取得する。
setClipRect | Overloaded. クリップする矩形を指定する。
setOffset | スクリーンのオフセット値を設定する。
setRate | 描画時の倍率の設定。
setScreenSize | 画面サイズの設定。
ToString (inherited from Object) |
update | update。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.clone Method

クローンメソッド。

public DrawContext clone();

Return Value

Remarks

データメンバのcopyは行なわない。 あくまで同じ型のオブジェクトを生成するだけ。

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.disableClip Method

クリップを無効にする(default)。

public void disableClip();

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.enableClip Method

クリップを有効にする。

public void enableClip();

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.getOffset Method

スクリーンのオフセット値を取得する。

public void getOffset(
out float ox,
out float oy
);

Parameters

ox
oy

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.getRate Method

描画時の倍率の取得。

public void getRate(
out float rateX_,
out float rateY_
);

Parameters

rateX_
rateY_

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.getScreenSize Method

画面サイズの取得。

public void getScreenSize(
out float x,
out float y
);

Parameters

x
y

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.isClip Method

クリップが有効かどうかを取得する。

public bool isClip();

Return Value

See Also

DrawContext Class | y4cs.draw Namespace


setClipRect Method

Yaneurao Game Library 4th for C#

DrawContext.setClipRect Method

Overload List

public void setClipRect();

クリップする矩形を指定する。

public void setClipRect(ref Rect);

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.setClipRect Method ()

public void setClipRect();

See Also

DrawContext Class | y4cs.draw Namespace | DrawContext.setClipRect Overload List


DrawContext.setClipRect Method (Rect)

クリップする矩形を指定する。

public void setClipRect(
ref Rect rc
);

Parameters

rc

Remarks

ここで指定するRectの座標系は、 (screenSizeX,screenSizeY)を基準とする。

Rectの(left,bottm)の点は含まない。

>

すなわち、 screenSizeX = 640, screenSize Y = 480 のときに (0,0,640,480)のRectをClip矩形として渡した場合、 top = 0, left = 0, right = 1.0 , bottom = 1.0 がclip位置として記録されることになる。 rc = nullの場合、(0,0,1.0,1.0)が設定される。

See Also

DrawContext Class | y4cs.draw Namespace | DrawContext.setClipRect Overload List


DrawContext.setOffset Method

スクリーンのオフセット値を設定する。

public void setOffset(
float ox,
float oy
);

Parameters

ox
oy

Remarks

Screen.setOffsetで設定される値は、視体積を変更するので クリップとは関係ないが、ここで変更されるoffsetは直接的に 描画に関係してくる。 offsetX = 1.0 ならば、一画面分(rateX)描画時にオフセットが加わる。 すなわち、(-640,-480)に描画したものが(0,0)に描画される

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.setRate Method

描画時の倍率の設定。

public void setRate(
float rateX_,
float rateY_
);

Parameters

rateX_
rateY_

Remarks

640×480の画面を想定してコーディングしたものを 320×240の画面にうまく描画されるようにするためには setRate(0.5,0.5)を行なえば良い。

update での計算式を見ればわかるように、 offset , clipRect に関係してくる。

defaultでは(1.0,1.0)

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.setScreenSize Method

画面サイズの設定。

public void setScreenSize(
float x,
float y
);

Parameters

x
y

Remarks

(screenSizeX,screenSizeY)にそのまま反映します。

See Also

DrawContext Class | y4cs.draw Namespace


DrawContext.update Method

update。

public void update();

Remarks

1.offsetの値を反映させる

            offsetRX = offsetX * screenSizeX * rateX;
            offsetRY = offsetY * screenSizeY * rateY;

2.rectの値を反映させる
            leftR = left * screenSizeX * rateX;
            topR  = top  * screenSizeY * rateY;
            rightR= right * screenSizeX * rateX;
            bottomR= bottom * screenSizeY * rateY;

See Also

DrawContext Class | y4cs.draw Namespace


DrawLayer Class

描画Layerクラスの基底クラス。

For a list of all members of this type, see DrawLayer Members.

System.Object
DrawLayer

public abstract class DrawLayer

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

DrawLayer Members | y4cs.draw Namespace


DrawLayer Members

DrawLayer overview

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
onDraw | (x,y)の座標に描画する。
ToString (inherited from Object) |

Protected Instance Constructors

DrawLayer Constructor Initializes a new instance of the DrawLayer class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DrawLayer Class | y4cs.draw Namespace


DrawLayer Constructor

Initializes a new instance of the DrawLayer class.

protected DrawLayer();

See Also

DrawLayer Class | y4cs.draw Namespace


DrawLayer Methods

The methods of the DrawLayer class are listed below. For a complete list of DrawLayer class members, see the DrawLayer Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
onDraw | (x,y)の座標に描画する。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

DrawLayer Class | y4cs.draw Namespace


DrawLayer.onDraw Method

(x,y)の座標に描画する。

public abstract void onDraw(
Screen context,
int x,
int y
);

See Also

DrawLayer Class | y4cs.draw Namespace


Font Class

文字の描画用クラス

For a list of all members of this type, see Font Members.

System.Object
Font

public class Font : ICacheObject, IDisposable

Remarks

文字の描画にはttf(true type font)を使用します。 文字の描画ごとに、ttfを展開して、テクスチャーorサーフェースを 再構築していたのではすごく遅いので、何らかの方法でキャッシュして 使うことをお勧めします。

Example

            Screen screen = new Screen;
            screen.setVideoMode(640,480,0);

            char[] fontname = "GT200001.TTF";
            Font font = new Font;
            font.open(fontname,30);
            Texture fontTxt = new Texture;
            fontTxt.setSurface(font.drawBlended("hoge hoge天才にょ"));

            while (GameFrame.pollEvent()==0){
                screen.blt(fontTxt,0,0);
                screen.update();
            }

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Font Members | y4cs.draw Namespace


Font Members

Font overview

Public Instance Constructors

Font Constructor Initializes a new instance of the Font class.

Public Instance Methods

close | フォントを閉じる(解放する)。
Dispose | Overloaded.
drawBlended | Overloaded. 文字を描画したサーフェースを返します。
drawBlendedUnicode | Overloaded.
drawBlendedUTF8 | Overloaded. 文字を描画したサーフェースを返します。
drawSolid | Overloaded. 文字を描画したサーフェースを返します。
drawSolidUnicode | Overloaded. 文字を描画したサーフェースを返します。
drawSolidUTF8 | Overloaded. 文字を描画したサーフェースを返します。
Equals (inherited from Object) |
getBufferSize | 読み込んでいるフォントのファイルサイズを返す。
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
open | Overloaded. フォントをオープンする。
setColor | 文字の色を設定する。
ToString (inherited from Object) |

Protected Instance Fields

font フォント実体。

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

Font Class | y4cs.draw Namespace


Font Constructor

Initializes a new instance of the Font class.

public Font();

See Also

Font Class | y4cs.draw Namespace


Font Fields

The fields of the Font class are listed below. For a complete list of Font class members, see the Font Members topic.

Protected Instance Fields

font フォント実体。

See Also

Font Class | y4cs.draw Namespace


Font.font Field

フォント実体。

protected IntPtr font;

See Also

Font Class | y4cs.draw Namespace


Font Methods

The methods of the Font class are listed below. For a complete list of Font class members, see the Font Members topic.

Public Instance Methods

close | フォントを閉じる(解放する)。
Dispose | Overloaded.
drawBlended | Overloaded. 文字を描画したサーフェースを返します。
drawBlendedUnicode | Overloaded.
drawBlendedUTF8 | Overloaded. 文字を描画したサーフェースを返します。
drawSolid | Overloaded. 文字を描画したサーフェースを返します。
drawSolidUnicode | Overloaded. 文字を描画したサーフェースを返します。
drawSolidUTF8 | Overloaded. 文字を描画したサーフェースを返します。
Equals (inherited from Object) |
getBufferSize | 読み込んでいるフォントのファイルサイズを返す。
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
open | Overloaded. フォントをオープンする。
setColor | 文字の色を設定する。
ToString (inherited from Object) |

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

Font Class | y4cs.draw Namespace


Font.close Method

フォントを閉じる(解放する)。

public void close();

See Also

Font Class | y4cs.draw Namespace


Dispose Method

Yaneurao Game Library 4th for C#

Font.Dispose Method

Overload List

public void Dispose();

protected void Dispose(bool);

See Also

Font Class | y4cs.draw Namespace


Font.Dispose Method ()

public void Dispose();

Implements

IDisposable.Dispose

See Also

Font Class | y4cs.draw Namespace | Font.Dispose Overload List


Font.Dispose Method (Boolean)

protected void Dispose(
bool disposing
);

Parameters

disposing

See Also

Font Class | y4cs.draw Namespace | Font.Dispose Overload List


drawBlended Method

Yaneurao Game Library 4th for C#

Font.drawBlended Method

文字を描画したサーフェースを返します。

Overload List

文字を描画したサーフェースを返します。

public Surface drawBlended(string);

サーフェースに文字列を描画します。

public void drawBlended(Surface,string);

See Also

Font Class | y4cs.draw Namespace


Font.drawBlended Method (String)

文字を描画したサーフェースを返します。

public Surface drawBlended(
string str
);

Remarks

drawSolid のα付きサーフェースを返すバージョン。 綺麗なかわりに、遅い。

漢字は出ない。漢字を出したいときはUTF8かUnicodeバージョンを用いること。

See Also

Font Class | y4cs.draw Namespace | Font.drawBlended Overload List


Font.drawBlended Method (Surface, String)

サーフェースに文字列を描画します。

public void drawBlended(
Surface surface,
string str
);

Remarks

サーフェースをnewしたくないときは、こちらを使うよろし。

See Also

Font Class | y4cs.draw Namespace | Font.drawBlended Overload List


drawBlendedUnicode Method

Yaneurao Game Library 4th for C#

Font.drawBlendedUnicode Method

Overload List

public Surface drawBlendedUnicode(string);

サーフェースに文字列を描画します。

public void drawBlendedUnicode(Surface,string);

See Also

Font Class | y4cs.draw Namespace


Font.drawBlendedUnicode Method (String)

public Surface drawBlendedUnicode(
string str
);

See Also

Font Class | y4cs.draw Namespace | Font.drawBlendedUnicode Overload List


Font.drawBlendedUnicode Method (Surface, String)

サーフェースに文字列を描画します。

public void drawBlendedUnicode(
Surface surface,
string str
);

Remarks

サーフェースをnewしたくないときは、こちらを使うよろし。

See Also

Font Class | y4cs.draw Namespace | Font.drawBlendedUnicode Overload List


drawBlendedUTF8 Method

Yaneurao Game Library 4th for C#

Font.drawBlendedUTF8 Method

文字を描画したサーフェースを返します。

Overload List

文字を描画したサーフェースを返します。

public Surface drawBlendedUTF8(byte[]);

サーフェースに文字列を描画します。

public void drawBlendedUTF8(Surface,byte[]);

See Also

Font Class | y4cs.draw Namespace


Font.drawBlendedUTF8 Method (Byte[])

文字を描画したサーフェースを返します。

public Surface drawBlendedUTF8(
byte[] str
);

Remarks

drawSolid のα付きサーフェースを返すバージョン。 綺麗なかわりに、遅い。

See Also

Font Class | y4cs.draw Namespace | Font.drawBlendedUTF8 Overload List


Font.drawBlendedUTF8 Method (Surface, Byte[])

サーフェースに文字列を描画します。

public void drawBlendedUTF8(
Surface surface,
byte[] str
);

Remarks

サーフェースをnewしたくないときは、こちらを使うよろし。

See Also

Font Class | y4cs.draw Namespace | Font.drawBlendedUTF8 Overload List


drawSolid Method

Yaneurao Game Library 4th for C#

Font.drawSolid Method

文字を描画したサーフェースを返します。

Overload List

文字を描画したサーフェースを返します。

public Surface drawSolid(string);

サーフェースに文字列を描画します。

public void drawSolid(Surface,string);

See Also

Font Class | y4cs.draw Namespace


Font.drawSolid Method (String)

文字を描画したサーフェースを返します。

public Surface drawSolid(
string str
);

Remarks

漢字は出ない。 漢字を出したいときはUTF8かUnicodeバージョンを用いること。

生成されるサーフェースは、αなし。

See Also

Font Class | y4cs.draw Namespace | Font.drawSolid Overload List


Font.drawSolid Method (Surface, String)

サーフェースに文字列を描画します。

public void drawSolid(
Surface surface,
string str
);

Remarks

サーフェースをnewしたくないときは、こちらを使うよろし。

See Also

Font Class | y4cs.draw Namespace | Font.drawSolid Overload List


drawSolidUnicode Method

Yaneurao Game Library 4th for C#

Font.drawSolidUnicode Method

文字を描画したサーフェースを返します。

Overload List

文字を描画したサーフェースを返します。

public Surface drawSolidUnicode(string);

サーフェースに文字列を描画します。

public void drawSolidUnicode(Surface,string);

See Also

Font Class | y4cs.draw Namespace


Font.drawSolidUnicode Method (String)

文字を描画したサーフェースを返します。

public Surface drawSolidUnicode(
string str
);

Remarks

画質はあらいです。そのかわり早いです。

生成されるサーフェースは、αなし。

See Also

Font Class | y4cs.draw Namespace | Font.drawSolidUnicode Overload List


Font.drawSolidUnicode Method (Surface, String)

サーフェースに文字列を描画します。

public void drawSolidUnicode(
Surface surface,
string str
);

Remarks

サーフェースをnewしたくないときは、こちらを使うよろし。

See Also

Font Class | y4cs.draw Namespace | Font.drawSolidUnicode Overload List


drawSolidUTF8 Method

Yaneurao Game Library 4th for C#

Font.drawSolidUTF8 Method

文字を描画したサーフェースを返します。

Overload List

文字を描画したサーフェースを返します。

public Surface drawSolidUTF8(byte[]);

サーフェースに文字列を描画します。

public void drawSolidUTF8(Surface,byte[]);

See Also

Font Class | y4cs.draw Namespace


Font.drawSolidUTF8 Method (Byte[])

文字を描画したサーフェースを返します。

public Surface drawSolidUTF8(
byte[] str
);

Remarks

画質はあらいです。そのかわり早いです。

生成されるサーフェースは、αなし。

See Also

Font Class | y4cs.draw Namespace | Font.drawSolidUTF8 Overload List


Font.drawSolidUTF8 Method (Surface, Byte[])

サーフェースに文字列を描画します。

public void drawSolidUTF8(
Surface surface,
byte[] str
);

Remarks

サーフェースをnewしたくないときは、こちらを使うよろし。

See Also

Font Class | y4cs.draw Namespace | Font.drawSolidUTF8 Overload List


Font.Finalize Method

protected override void Finalize();

See Also

Font Class | y4cs.draw Namespace


Font.getBufferSize Method

読み込んでいるフォントのファイルサイズを返す。

public ulong getBufferSize();

Implements

ICacheObject.getBufferSize

See Also

Font Class | y4cs.draw Namespace


open Method

Yaneurao Game Library 4th for C#

Font.open Method

フォントをオープンする。

Overload List

フォントをオープンする。

public y4cs_result open(int,int);

フォントをオープンする。

public y4cs_result open(string,int);

フォントをオープンする。

public y4cs_result open(string,int,int);

フォントをオープンする。

public y4cs_result open(SDL_RWops,int);

フォントをオープンする(RWopsから)。

public y4cs_result open(SDL_RWops,int,int);

See Also

Font Class | y4cs.draw Namespace


Font.open Method (Int32, Int32)

フォントをオープンする。

public y4cs_result open(
int openNo,
int fontsize
);

Remarks

MSゴシックとMS明朝をオープンするバージョン。

0 : msgothic.ttc : MSゴシック 1 : msmincho.ttc : MS明朝 2 : msgothic.ttc : MSPゴシック 3 : msmincho.ttc : MSP明朝 をオープンします。

See Also

Font Class | y4cs.draw Namespace | Font.open Overload List


Font.open Method (String, Int32)

フォントをオープンする。

public y4cs_result open(
string fontname,
int fontsize
);

Remarks

openのindex=0決め打ちバージョン。

See Also

Font Class | y4cs.draw Namespace | Font.open Overload List


Font.open Method (String, Int32, Int32)

フォントをオープンする。

public y4cs_result open(
string fontname,
int fontsize,
int index
);

Remarks

指定するのは、フォント名。 indexは、ttc(true type collection＝ttfが複数入ったフォントファイル)の ときに、何番目のものかを指定する。0番から始まる番号。

Windowsならフォルダは決まっているので、カレントとパスの通っている ところに無ければ、そこから取得する。

Linuxのほうは、カレント、あとパスの通っているところから取得する。

Example

例) Windowsでは、 msgothic.ttc : MSゴシック msmincho.ttc : MS明朝

Linuxの場合、日本語フォントを用いる場合は、 GT書体 (東京大学多国語処理研究会) http://www.l.u-tokyo.ac.jp/GT/ などから持ってきて、msgothic.ttcやmsmincho.ttcとリネームして カレントフォルダに配置しておくようにしてください。

フォントフォルダの検索に用いているAPIは、 win95の場合はIE4.0以降をインストールしてないとダメ win98以降は使える。

See Also

Font Class | y4cs.draw Namespace | Font.open Overload List


Font.open Method (SDL_RWops, Int32)

フォントをオープンする。

public y4cs_result open(
SDL_RWops rw,
int fontsize
);

Remarks

openのindex=0決め打ちバージョン。

See Also

Font Class | y4cs.draw Namespace | Font.open Overload List


Font.open Method (SDL_RWops, Int32, Int32)

フォントをオープンする(RWopsから)。

public y4cs_result open(
SDL_RWops rw,
int fontsize,
int index
);

Remarks

indexは、ttc(true type collection＝ttfが複数入ったフォントファイル)の ときに、何番目のものかを指定する。0番から始まる番号。

See Also

Font Class | y4cs.draw Namespace | Font.open Overload List


Font.setColor Method

文字の色を設定する。

public void setColor(
int r_,
int g_,
int b_
);

Remarks

各、RGB、0～255までで指定する。 drawを呼び出すまでに設定すればok。

設定しなければ、(255,255,255) すなわち、白が指定されている状態になる。 設定された値は、再設定されるまで有効。

See Also

Font Class | y4cs.draw Namespace


FontLoader Class

文字フォントのcacheシステム。

For a list of all members of this type, see FontLoader Members.

System.Object
Iter
CacheLoader
FontLoader

public class FontLoader : CacheLoader

Remarks

Font を CacheLoader で cache する仕組みです。

文字フォントはリソースが大きいので、ゲーム中に読み込みや解放を 繰り返すべきではないと考えます

そこで、一度読み込んだフォントを(読み込みフォントの総容量が一定に 達するまでは)解放しない仕組みが必要となります。

このクラスは、その機能を実現します。

            int	loadDefFile(char[] filename);
で読み込む定義ファイルは、
  • msgothic.ttc , 0 , 16 , 0
  • msmincho.ttc , 1 , 24 , 1
  • msmincho.ttc , 2 , 40 , 0
のように書き、ひとつ目は、ファイル名、二つ目は、読み込む番号、3,4つ目は option1,2である。option1はフォントサイズ,option2はフォントのindex (Font.openの時に指定するindex)を指定する。これらは指定しない場合0を 意味するのでoption1は必ず指定する必要がある。

番号は指定してもしなくても良い。指定しない場合、自動的に0から始まる 連番となる。指定した場合、そこから連番となる。(CやDのenumと似たものだと 考えれば良い。)

また、フォントは文字サイズごとに生成する必要がある。そこで頻繁に 文字サイズを変更するとリソースの再読み込みで結構時間がかかることになる。 これを回避するためには、 TextureFontRepository を用いると良い。

このクラスでキャッシュするフォントのサイズは、ディフォルトでは32MB。 MS明朝,MSゴシックは10M程度あるので、32MBではひょっとすると少ないかも 知れないが。

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FontLoader Members | y4cs.draw Namespace


FontLoader Members

FontLoader overview

Public Instance Constructors

FontLoader Constructor Initializes a new instance of the FontLoader class.

Public Instance Properties

Current (inherited from CacheLoader)
IsRunning (inherited from y4cs.native.iterator.Iter)
IsStarted (inherited from y4cs.native.iterator.Iter)

Public Instance Methods

checkRelease (inherited from CacheLoader) | 解放妥当性のチェック。
createInstance | Fontのcloneメソッド。
Dispose (inherited from y4cs.native.iterator.Iter) |
Equals (inherited from Object) |
get | noのフォントを生成して返す。
getCacheFiles (inherited from CacheLoader) | cacheしているファイル数を返す。
getCacheSize (inherited from CacheLoader) | cacheするバッファの上限を取得。
GetEnumerator (inherited from CacheLoader) |
GetHashCode (inherited from Object) |
getInfoList (inherited from CacheLoader) | ファイルリストの取得。
getObj | 指定された番号のオブジェクトを構築して返す。
GetType (inherited from Object) |
isin (inherited from CacheLoader) | オブジェクトが生成されているかを調べる。
loadDefFile (inherited from CacheLoader) | 定義ファイルを読み込む。
loadDefRW (inherited from CacheLoader) | キャッシュリストを手渡しするための関数。
MoveNext (inherited from CacheLoader) |
print (inherited from CacheLoader) | 保持しているファイルリストの表示(デバッグ用)。
releaseAll (inherited from CacheLoader) | 保持していたキャッシュを解放する(ファイルリストは解放しない)。
releaseFileList (inherited from CacheLoader) | 保持していたファイルリスト、キャッシュを解放する。
releaseOldObject (inherited from CacheLoader) | 一番昔の時刻にアクセスされたファイルを解放するメソッド。
Reset (inherited from CacheLoader) |
Resume (inherited from y4cs.native.iterator.Iter) |
setCacheSize (inherited from CacheLoader) | cacheするバッファの上限を決める。
setUpdateCacheDelegate (inherited from CacheLoader) | 古いキャッシュの破棄メソッドの登録。
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
ToString (inherited from Object) |
updateFileList (inherited from CacheLoader) | ファイルリストを反映させる。

Protected Instance Fields

bStarted_ (inherited from y4cs.native.iterator.Iter) |
cachefiles (inherited from CacheLoader) | 実体を読み込んでいるファイルの数
cacheSize (inherited from CacheLoader) | cacheするサウンドバッファの上限(-1ならば無制限)。
filelist (inherited from CacheLoader) | ファイルリスト。
iterStart (inherited from y4cs.native.iterator.Iter) |
nowtime (inherited from CacheLoader) |
readPath (inherited from CacheLoader) | 実ファイル読み込みフォルダ。
state (inherited from y4cs.native.iterator.Iter) |
updateCacheDelegate (inherited from CacheLoader) | updateCacheで呼び出すdelegate。

Protected Instance Methods

checkCache (inherited from CacheLoader) | キャッシュがあふれたかを判定する。
createInfo (inherited from CacheLoader) | キャッシュ構造体のfactory。
Finalize (inherited from CacheLoader) |
getHelpper (inherited from CacheLoader) | 番号に対応するオブジェクトを読み込み、loadメソッドを呼び出す。
getHelpperObj (inherited from CacheLoader) | 番号に対応するオブジェクトを返す。
loadFile | フォントを読み込むための関数。LoadCacheからのオーバーライド。
MemberwiseClone (inherited from Object) |
releaseFile | フォントを解放するための関数。LoadCacheからのオーバーライド。
yield (inherited from y4cs.native.iterator.Iter) |

See Also

FontLoader Class | y4cs.draw Namespace


FontLoader Constructor

Initializes a new instance of the FontLoader class.

public FontLoader();

See Also

FontLoader Class | y4cs.draw Namespace


FontLoader Methods

The methods of the FontLoader class are listed below. For a complete list of FontLoader class members, see the FontLoader Members topic.

Public Instance Methods

checkRelease (inherited from CacheLoader) | 解放妥当性のチェック。
createInstance | Fontのcloneメソッド。
Dispose (inherited from y4cs.native.iterator.Iter) |
Equals (inherited from Object) |
get | noのフォントを生成して返す。
getCacheFiles (inherited from CacheLoader) | cacheしているファイル数を返す。
getCacheSize (inherited from CacheLoader) | cacheするバッファの上限を取得。
GetEnumerator (inherited from CacheLoader) |
GetHashCode (inherited from Object) |
getInfoList (inherited from CacheLoader) | ファイルリストの取得。
getObj | 指定された番号のオブジェクトを構築して返す。
GetType (inherited from Object) |
isin (inherited from CacheLoader) | オブジェクトが生成されているかを調べる。
loadDefFile (inherited from CacheLoader) | 定義ファイルを読み込む。
loadDefRW (inherited from CacheLoader) | キャッシュリストを手渡しするための関数。
MoveNext (inherited from CacheLoader) |
print (inherited from CacheLoader) | 保持しているファイルリストの表示(デバッグ用)。
releaseAll (inherited from CacheLoader) | 保持していたキャッシュを解放する(ファイルリストは解放しない)。
releaseFileList (inherited from CacheLoader) | 保持していたファイルリスト、キャッシュを解放する。
releaseOldObject (inherited from CacheLoader) | 一番昔の時刻にアクセスされたファイルを解放するメソッド。
Reset (inherited from CacheLoader) |
Resume (inherited from y4cs.native.iterator.Iter) |
setCacheSize (inherited from CacheLoader) | cacheするバッファの上限を決める。
setUpdateCacheDelegate (inherited from CacheLoader) | 古いキャッシュの破棄メソッドの登録。
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
ToString (inherited from Object) |
updateFileList (inherited from CacheLoader) | ファイルリストを反映させる。

Protected Instance Methods

checkCache (inherited from CacheLoader) | キャッシュがあふれたかを判定する。
createInfo (inherited from CacheLoader) | キャッシュ構造体のfactory。
Finalize (inherited from CacheLoader) |
getHelpper (inherited from CacheLoader) | 番号に対応するオブジェクトを読み込み、loadメソッドを呼び出す。
getHelpperObj (inherited from CacheLoader) | 番号に対応するオブジェクトを返す。
loadFile | フォントを読み込むための関数。LoadCacheからのオーバーライド。
MemberwiseClone (inherited from Object) |
releaseFile | フォントを解放するための関数。LoadCacheからのオーバーライド。
yield (inherited from y4cs.native.iterator.Iter) |

See Also

FontLoader Class | y4cs.draw Namespace


FontLoader.createInstance Method

Fontのcloneメソッド。

public override object createInstance();

Return Value

See Also

FontLoader Class | y4cs.draw Namespace


FontLoader.get Method

noのフォントを生成して返す。

public override object get(
int no
);

Parameters

no

Return Value

See Also

FontLoader Class | y4cs.draw Namespace


FontLoader.getObj Method

指定された番号のオブジェクトを構築して返す。

public override object getObj(
int no
);

Parameters

no

Return Value

Remarks

暗黙のうちにオブジェクトは構築されるが、openはされない。 (この点、 get とは異なる)

See Also

FontLoader Class | y4cs.draw Namespace


FontLoader.loadFile Method

フォントを読み込むための関数。LoadCacheからのオーバーライド。

protected override y4cs_result loadFile(
string filename,
ref object obj,
int option1,
int option2
);

Parameters

filename
obj
option1
option2

Return Value

See Also

FontLoader Class | y4cs.draw Namespace


FontLoader.releaseFile Method

フォントを解放するための関数。LoadCacheからのオーバーライド。

protected override y4cs_result releaseFile(
ref object obj
);

Parameters

obj

Return Value

See Also

FontLoader Class | y4cs.draw Namespace


FontRepository Class

文字テクスチャーのキャッシュ用クラス。

For a list of all members of this type, see FontRepository Members.

System.Object
FontRepository

public class FontRepository

Remarks

Example

            FontLoader loader = new FontLoader();
            loader.loadDefRW("msmincho.ttc , 0 , 50 , 0\n");

            FontRepository fr = new FontRepository;
            fr.setLoader(loader,0);
            fr.setMax(100);

            //	メインループにて

            TextureVector fonttv = fr.getTexture("この文字列描画どや！");
            //	↑font repositoryから取り出すので、超ハヤー（ﾟДﾟ）

            //		fonttv.setSurface(
            //			loader.get(0).drawBlendedUnicode("この文字列描画どや！"));
            //	↑毎フレーム文字列フォントを生成するとすごく負荷がかかる

            screen.setColor(255,0,0);

            screen.blt(fonttv,30,100);
            screen.resetColor();

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FontRepository Members | y4cs.draw Namespace


FontRepository Members

FontRepository overview

Public Instance Constructors

FontRepository Constructor Initializes a new instance of the FontRepository class.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getTexture | Overloaded. 文字に対応するフォントを取得。
GetType (inherited from Object) |
release | 保持しているフォントを解放する。
setLoader | フォントローダーとその使用するナンバーを指定設定する。
setMax | キャッシュする文字の数。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FontRepository Class | y4cs.draw Namespace


FontRepository Constructor

Initializes a new instance of the FontRepository class.

public FontRepository();

See Also

FontRepository Class | y4cs.draw Namespace


FontRepository Methods

The methods of the FontRepository class are listed below. For a complete list of FontRepository class members, see the FontRepository Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getTexture | Overloaded. 文字に対応するフォントを取得。
GetType (inherited from Object) |
release | 保持しているフォントを解放する。
setLoader | フォントローダーとその使用するナンバーを指定設定する。
setMax | キャッシュする文字の数。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FontRepository Class | y4cs.draw Namespace


getTexture Method

Yaneurao Game Library 4th for C#

FontRepository.getTexture Method

文字に対応するフォントを取得。

Overload List

文字に対応するフォントを取得。

public Texture getTexture(char);

文字列に対する文字ベクタを取得。

public TextureVector getTexture(string);

See Also

FontRepository Class | y4cs.draw Namespace


FontRepository.getTexture Method (Char)

文字に対応するフォントを取得。

public Texture getTexture(
char w
);

Parameters

w

Return Value

Remarks

キャッシュから文字をかき集めるので、ここでかき集めた 文字列(テクスチャ)はいずれ解放されるので、使用するのは その描画フレームで限りにすること。

See Also

FontRepository Class | y4cs.draw Namespace | FontRepository.getTexture Overload List


FontRepository.getTexture Method (String)

文字列に対する文字ベクタを取得。

public TextureVector getTexture(
string str
);

Parameters

str

Return Value

See Also

FontRepository Class | y4cs.draw Namespace | FontRepository.getTexture Overload List


FontRepository.release Method

保持しているフォントを解放する。

public void release();

See Also

FontRepository Class | y4cs.draw Namespace


FontRepository.setLoader Method

フォントローダーとその使用するナンバーを指定設定する。

public void setLoader(
FontLoader loader_,
int no_
);

Parameters

loader_
no_

Remarks

以降、getTextureでは、このフォントが読み込まれる。

See Also

FontRepository Class | y4cs.draw Namespace


FontRepository.setMax Method

キャッシュする文字の数。

public void setMax(
int max
);

Parameters

max

See Also

FontRepository Class | y4cs.draw Namespace


FontRepository.Info Class

ひとつの文字に対する情報。

For a list of all members of this type, see FontRepository.Info Members.

System.Object
FontRepository.Info

public class FontRepository.Info

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FontRepository.Info Members | y4cs.draw Namespace


FontRepository.Info Members

FontRepository.Info overview

Public Instance Constructors

FontRepository.Info Constructor Initializes a new instance of the Info class.

Public Instance Fields

loader | 使用しているフォントローダー。
no | フォントナンバー(FontLoaderのナンバー)。
texture | そのテクスチャ(null = 未生成)。
time | このTextureを参照された最後の時間。
w | キャッシュしている文字。

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FontRepository.Info Class | y4cs.draw Namespace


FontRepository.Info Constructor

Initializes a new instance of the Info class.

public FontRepository.Info();

See Also

FontRepository.Info Class | y4cs.draw Namespace


FontRepository.Info Fields

The fields of the FontRepository.Info class are listed below. For a complete list of FontRepository.Info class members, see the FontRepository.Info Members topic.

Public Instance Fields

loader | 使用しているフォントローダー。
no | フォントナンバー(FontLoaderのナンバー)。
texture | そのテクスチャ(null = 未生成)。
time | このTextureを参照された最後の時間。
w | キャッシュしている文字。

See Also

FontRepository.Info Class | y4cs.draw Namespace


FontRepository.Info.loader Field

使用しているフォントローダー。

public FontLoader loader;

See Also

FontRepository.Info Class | y4cs.draw Namespace


FontRepository.Info.no Field

フォントナンバー(FontLoaderのナンバー)。

public int no;

See Also

FontRepository.Info Class | y4cs.draw Namespace


FontRepository.Info.texture Field

そのテクスチャ(null = 未生成)。

public Texture texture;

See Also

FontRepository.Info Class | y4cs.draw Namespace


FontRepository.Info.time Field

このTextureを参照された最後の時間。

public ulong time;

See Also

FontRepository.Info Class | y4cs.draw Namespace


FontRepository.Info.w Field

キャッシュしている文字。

public char w;

See Also

FontRepository.Info Class | y4cs.draw Namespace


FpsLayer Class

FPSを画面に表示するクラス。

For a list of all members of this type, see FpsLayer Members.

System.Object
DrawLayer
FpsLayer

public class FpsLayer : DrawLayer

Remarks

FpsTimerをセットしておけば、それを画面に表示してくれる。 あくまでデバッグ用。もしくは、サンプル目的。 自分用は、これを改造して使ってもらえれば良いと思う。

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FpsLayer Members | y4cs.draw Namespace


FpsLayer Members

FpsLayer overview

Public Instance Constructors

FpsLayer Overloaded. Initializes a new instance of the FpsLayer class.

Public Instance Methods

Equals (inherited from Object) |
getFpsTimer | FpsTimerのgetter。
GetHashCode (inherited from Object) |
getSize | 文字のサイズの取得。
GetType (inherited from Object) |
onDraw | 描画メソッド。
setFpsTimer | FpsTimerのsetter。
setSize | 文字のサイズの設定。
ToString (inherited from Object) |

Protected Instance Fields

fpstimer | fps timer。
size | 文字サイズ。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FpsLayer Class | y4cs.draw Namespace


FpsLayer Constructor

Overload List

Initializes a new instance of the FpsLayer class.

public FpsLayer();

public FpsLayer(FpsTimer);

See Also

FpsLayer Class | y4cs.draw Namespace


FpsLayer Constructor (FpsTimer)

public FpsLayer(
FpsTimer fpstimer_
);

Parameters

fpstimer_

See Also

FpsLayer Class | y4cs.draw Namespace | FpsLayer Constructor Overload List


FpsLayer Constructor ()

Initializes a new instance of the FpsLayer class.

public FpsLayer();

See Also

FpsLayer Class | y4cs.draw Namespace | FpsLayer Constructor Overload List


FpsLayer Fields

The fields of the FpsLayer class are listed below. For a complete list of FpsLayer class members, see the FpsLayer Members topic.

Protected Instance Fields

fpstimer | fps timer。
size | 文字サイズ。

See Also

FpsLayer Class | y4cs.draw Namespace


FpsLayer.fpstimer Field

fps timer。

protected FpsTimer fpstimer;

See Also

FpsLayer Class | y4cs.draw Namespace


FpsLayer.size Field

文字サイズ。

protected int size;

See Also

FpsLayer Class | y4cs.draw Namespace


FpsLayer Methods

The methods of the FpsLayer class are listed below. For a complete list of FpsLayer class members, see the FpsLayer Members topic.

Public Instance Methods

Equals (inherited from Object) |
getFpsTimer | FpsTimerのgetter。
GetHashCode (inherited from Object) |
getSize | 文字のサイズの取得。
GetType (inherited from Object) |
onDraw | 描画メソッド。
setFpsTimer | FpsTimerのsetter。
setSize | 文字のサイズの設定。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FpsLayer Class | y4cs.draw Namespace


FpsLayer.getFpsTimer Method

FpsTimerのgetter。

public FpsTimer getFpsTimer();

See Also

FpsLayer Class | y4cs.draw Namespace


FpsLayer.getSize Method

文字のサイズの取得。

public int getSize();

See Also

FpsLayer Class | y4cs.draw Namespace


FpsLayer.onDraw Method

描画メソッド。

public override void onDraw(
Screen screen,
int x,
int y
);

See Also

FpsLayer Class | y4cs.draw Namespace


FpsLayer.setFpsTimer Method

FpsTimerのsetter。

public void setFpsTimer(
FpsTimer fpstimer_
);

Remarks

コンストラクタで渡しそびれた時のために。

See Also

FpsLayer Class | y4cs.draw Namespace


FpsLayer.setSize Method

文字のサイズの設定。

public void setSize(
int size_
);

Remarks

defaultは25。 ※ 色は、Screenに対してセットすればok。

See Also

FpsLayer Class | y4cs.draw Namespace


ITextureBase Interface

Texture転送の基底クラス。

For a list of all members of this type, see ITextureBase Members.

public interface ITextureBase

Remarks

Texture , TextureVector の基底クラス。

描画の基本的な考えかた。 ITextureBaseは、転送元の描画矩形を保持しています。 これは転送元矩形という言葉で表されます。 ただし、実際は矩形である必要はなく、 TextureVector のように、 矩形の集合や、何らかの集合であっても構いません。概念的な矩形だと 考えてください。 この転送元矩形を Screen.blt メソッドによって、転送先に転送すると いう風に捉えます。転送先は、矩形、凸四角形、clipされた矩形etc..です。 文字列集合は、それぞれの文字 Texture の集合だと考えることが 出来るでしょう。これが TexturVector の実体です。 よって、 TextureVector は、単なる矩形と考えて、 Screen.blt を用いて Texture 同様に描画することができます。

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

ITextureBase Members | y4cs.draw Namespace


ITextureBase Members

ITextureBase overview

Public Instance Methods

blt | Overloaded. このテクスチャを指定のscreenにbltする。
getHeight | テスクチャの高さを得る。
getWidth | テクスチャの幅を得る。

See Also

ITextureBase Interface | y4cs.draw Namespace


ITextureBase Methods

The methods of the ITextureBase interface are listed below. For a complete list of ITextureBase interface members, see the ITextureBase Members topic.

Public Instance Methods

blt | Overloaded. このテクスチャを指定のscreenにbltする。
getHeight | テスクチャの高さを得る。
getWidth | テクスチャの幅を得る。

See Also

ITextureBase Interface | y4cs.draw Namespace


blt Method

Yaneurao Game Library 4th for C#

ITextureBase.blt Method

このテクスチャを指定のscreenにbltする。

Overload List

このテクスチャを指定のscreenにbltする。

void blt(DrawContext,float,float);

このテクスチャを指定のscreenにbltする。

void blt(DrawContext,float,float,ref Rect);

このテクスチャを指定のscreenにbltする。

void blt(DrawContext,float,float,ref Rect,ref Size);

このテクスチャを指定のscreenにbltする。

void blt(DrawContext,Point[],Point[]);

このテクスチャを指定のscreenにbltする。

void blt(DrawContext,ref Rect,Point[]);

See Also

ITextureBase Interface | y4cs.draw Namespace


ITextureBase.blt Method (DrawContext, Single, Single)

このテクスチャを指定のscreenにbltする。

void blt(
DrawContext drawContext,
float x,
float y
);

Parameters

drawContext
x
y

Remarks

visitorパターンのために実装してある。 Screen.bltからVisitorとして呼び出される。

See Also

ITextureBase Interface | y4cs.draw Namespace | ITextureBase.blt Overload List


ITextureBase.blt Method (DrawContext, Single, Single, Rect)

このテクスチャを指定のscreenにbltする。

void blt(
DrawContext drawContext,
float x,
float y,
ref Rect srcRect
);

Parameters

drawContext
x
y
srcRect

Remarks

visitorパターンのために実装してある。 Screen.bltからVisitorとして呼び出される。

See Also

ITextureBase Interface | y4cs.draw Namespace | ITextureBase.blt Overload List


ITextureBase.blt Method (DrawContext, Single, Single, Rect, Size)

このテクスチャを指定のscreenにbltする。

void blt(
DrawContext drawContext,
float x,
float y,
ref Rect srcRect,
ref Size dstSize
);

Parameters

drawContext
x
y
srcRect
dstSize

Remarks

visitorパターンのために実装してある。 Screen.bltからVisitorとして呼び出される。

See Also

ITextureBase Interface | y4cs.draw Namespace | ITextureBase.blt Overload List


ITextureBase.blt Method (DrawContext, Point[], Point[])

このテクスチャを指定のscreenにbltする。

void blt(
DrawContext src,
Point[] srcPoint,
Point[] dstPoint
);

Parameters

src
srcPoint
dstPoint

Remarks

visitorパターンのために実装してある。 Screen.bltからVisitorとして呼び出される。 これ、 TextureVector では未実装。(面倒だから)

See Also

ITextureBase Interface | y4cs.draw Namespace | ITextureBase.blt Overload List


ITextureBase.blt Method (DrawContext, Rect, Point[])

このテクスチャを指定のscreenにbltする。

void blt(
DrawContext src,
ref Rect srcRect,
Point[] dstPoint
);

Parameters

src
srcRect
dstPoint

Remarks

visitorパターンのために実装してある。 Screen.bltからVisitorとして呼び出される。

See Also

ITextureBase Interface | y4cs.draw Namespace | ITextureBase.blt Overload List


ITextureBase.getHeight Method

テスクチャの高さを得る。

float getHeight();

Return Value

See Also

ITextureBase Interface | y4cs.draw Namespace


ITextureBase.getWidth Method

テクスチャの幅を得る。

float getWidth();

Return Value

See Also

ITextureBase Interface | y4cs.draw Namespace


ITextureTrans Interface

Texture転送の基底クラス。

For a list of all members of this type, see ITextureTrans Members.

public interface ITextureTrans

Remarks

@todo : 現状、interfaceクラスのダウンキャストが未実装で、abstractクラスの場合、 多重継承に該当してしまうので、このクラスはまだ実装できない。

            abstract class T1 { }
            abstract class T2 { }
            abstract class TT : T1,T2 {}

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

ITextureTrans Members | y4cs.draw Namespace


ITextureTrans Members

ITextureTrans overview

Public Instance Methods

blt このテクスチャーを指定のscreenにbltする。

See Also

ITextureTrans Interface | y4cs.draw Namespace


ITextureTrans Methods

The methods of the ITextureTrans interface are listed below. For a complete list of ITextureTrans interface members, see the ITextureTrans Members topic.

Public Instance Methods

blt このテクスチャーを指定のscreenにbltする。

See Also

ITextureTrans Interface | y4cs.draw Namespace


ITextureTrans.blt Method

このテクスチャーを指定のscreenにbltする。

void blt(
Screen screen,
float x,
float y
);

Remarks

（visitorパターンのために実装してある）

See Also

ITextureTrans Interface | y4cs.draw Namespace


Point Structure

For a list of all members of this type, see Point Members.

System.Object
ValueType
Point

public struct Point

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Point Members | y4cs.draw Namespace


Point Members

Point overview

Public Instance Fields

x | x座標。
y | y座標。

Public Instance Methods

Equals (inherited from ValueType) |
GetHashCode (inherited from ValueType) |
GetType (inherited from Object) |
setPoint | 各データを設定する。
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Point Class | y4cs.draw Namespace


Point Fields

The fields of the Point structure are listed below. For a complete list of Point structure members, see the Point Members topic.

Public Instance Fields

x | x座標。
y | y座標。

See Also

Point Class | y4cs.draw Namespace


Point.x Field

x座標。

public float x;

See Also

Point Class | y4cs.draw Namespace


Point.y Field

y座標。

public float y;

See Also

Point Class | y4cs.draw Namespace


Point Methods

The methods of the Point structure are listed below. For a complete list of Point structure members, see the Point Members topic.

Public Instance Methods

Equals (inherited from ValueType) |
GetHashCode (inherited from ValueType) |
GetType (inherited from Object) |
setPoint | 各データを設定する。
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Point Class | y4cs.draw Namespace


Point.setPoint Method

各データを設定する。

public void setPoint(
float x_,
float y_
);

Parameters

x_
y_

See Also

Point Class | y4cs.draw Namespace


Rect Structure

For a list of all members of this type, see Rect Members.

System.Object
ValueType
Rect

public struct Rect

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Rect Members | y4cs.draw Namespace


Rect Members

Rect overview

Public Instance Fields

bottom | 下。
left | 左。
right | 右。
top | 上。

Public Instance Methods

Equals (inherited from ValueType) |
GetHashCode (inherited from ValueType) |
GetType (inherited from Object) |
setRect | 各データを設定する。
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Rect Class | y4cs.draw Namespace


Rect Fields

The fields of the Rect structure are listed below. For a complete list of Rect structure members, see the Rect Members topic.

Public Instance Fields

bottom | 下。
left | 左。
right | 右。
top | 上。

See Also

Rect Class | y4cs.draw Namespace


Rect.bottom Field

下。

public float bottom;

See Also

Rect Class | y4cs.draw Namespace


Rect.left Field

左。

public float left;

See Also

Rect Class | y4cs.draw Namespace


Rect.right Field

右。

public float right;

See Also

Rect Class | y4cs.draw Namespace


Rect.top Field

上。

public float top;

See Also

Rect Class | y4cs.draw Namespace


Rect Methods

The methods of the Rect structure are listed below. For a complete list of Rect structure members, see the Rect Members topic.

Public Instance Methods

Equals (inherited from ValueType) |
GetHashCode (inherited from ValueType) |
GetType (inherited from Object) |
setRect | 各データを設定する。
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Rect Class | y4cs.draw Namespace


Rect.setRect Method

各データを設定する。

public void setRect(
float left_,
float top_,
float right_,
float bottom_
);

Parameters

left_
top_
right_
bottom_

See Also

Rect Class | y4cs.draw Namespace


Screen Class

画面を表現しているサーフェース

For a list of all members of this type, see Screen Members.

System.Object
Screen

public class Screen

Remarks

描画にはopenGLを用いています。 画面にbmp,png,etc..画像を描画するためには、 Texture クラスを用います。 2D描画するときも、 Texture クラスを用います。

座標系は、ディフォルトで、ウィンドゥの左上が(0,0)、右下が(640,480)となる ※　右上の(640,480)というのは、ウィンドゥサイズにより異なります。

視体積(見える部分)の深さ(z方向)は、0～256が初期値として設定してあります。 つまりは、 glOrtho(0,640,480,0,0,256); // 256 = depth としてあります。これは、setVideoModeのときに設定されます。 もし、これでまずければ再設定するようにしてください。

関数の説明で2Dと書いてあるのは、2Dに特化した描画のときに用いるべきもので 3D描画の時に用いてうまく動くかどうかは保証しません。

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Screen Members | y4cs.draw Namespace


Screen Members

Screen overview

Public Instance Constructors

Screen Constructor Initializes a new instance of the Screen class.

Public Instance Methods

beginScreenTest | スクリーン解像度をテストする(2D/3D)。
blendAddColor | ブレンドとしてaddColorを指定する。
blendAddColorAlpha | 転送元がα付きサーフェースのときのaddcolor。
blendSrcAlpha | ブレンドとして、αブレンドを指定する。
blendSubColor | ブレンドとしてsubColorを指定する。
blendSubColorAlpha | 転送元がα付きサーフェースのときのsubcolor
blt | Overloaded. 画像の描画(2D)。
bltRotate | Overloaded. bltの回転機能つき。
clear | 画面のクリア(2D/3D)。
disableBlend | ブレンドを無効化する。
drawLine | 直線を引く(2D)。
drawLines |
drawPolygon | Overloaded. 三角形ポリゴンを描く(2D)。
drawString | openGLを用いた、簡単な文字列の描画。
enableBlend | ブレンドを有効にする。
endScreenTest | スクリーン解像度のテスト終了(2D/3D)。
Equals (inherited from Object) |
getColor | Overloaded.
getDrawContext | 描画用のコンテクストを取得。
GetHashCode (inherited from Object) |
getHeight | このサーフェースの高さを得る。
GetType (inherited from Object) |
getWidth | このサーフェースの幅を得る。
resetColor | 色をリセットする(2D/3D)。
setCaption | ウィンドゥキャプションの設定(2D/3D)。
setClearColor | Overloaded. clearするときの色を設定する(2D/3D)。
setColor | Overloaded. 色を設定する(2D/3D)。
setDrawContext | 描画用のコンテクストの設定。
setLineWidth | drawLine,drawStringの線の太さをピクセル単位で指定する。
setScreenOffset | 画面にオフセットを加える(2D)。
setVideoMode | 画面解像度の変更(2D/3D)。
setView | Overloaded. 視体積の設定(2D)。
testVideoMode | スクリーン解像度のテスト(2D/3D)。
ToString (inherited from Object) |
unbind | テクスチャーのバインドを解除する。
update | 実画面に描画を行なう(2D/3D)。

Protected Instance Fields

a | setColorで設定されている色。
b | setColorで設定されている色。
bBlend | ブレンドモードか。
bTestScreen | スクリーンテスト中か。
bTestScreenSuccess | スクリーンテストに成功した。
drawContext | 描画用のコンテクスト。
g | setColorで設定されている色。
moji |
mojiData |
offsetX | スクリーンのオフセット値。
offsetY | スクリーンのオフセット値。
r | setColorで設定されている色。
screenX | スクリーンのサイズ。
screenY | スクリーンのサイズ。
strCaption | ウィンドゥキャプション。

Protected Instance Methods

Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
setView | Overloaded. 視体積の設定(こちらは内部的に使用される)。

See Also

Screen Class | y4cs.draw Namespace


Screen Constructor

Initializes a new instance of the Screen class.

public Screen();

See Also

Screen Class | y4cs.draw Namespace


Screen Fields

The fields of the Screen class are listed below. For a complete list of Screen class members, see the Screen Members topic.

Protected Instance Fields

a | setColorで設定されている色。
b | setColorで設定されている色。
bBlend | ブレンドモードか。
bTestScreen | スクリーンテスト中か。
bTestScreenSuccess | スクリーンテストに成功した。
drawContext | 描画用のコンテクスト。
g | setColorで設定されている色。
moji |
mojiData |
offsetX | スクリーンのオフセット値。
offsetY | スクリーンのオフセット値。
r | setColorで設定されている色。
screenX | スクリーンのサイズ。
screenY | スクリーンのサイズ。
strCaption | ウィンドゥキャプション。

See Also

Screen Class | y4cs.draw Namespace


Screen.a Field

setColorで設定されている色。

protected int a;

See Also

Screen Class | y4cs.draw Namespace


Screen.b Field

setColorで設定されている色。

protected int b;

See Also

Screen Class | y4cs.draw Namespace


Screen.bBlend Field

ブレンドモードか。

protected bool bBlend;

See Also

Screen Class | y4cs.draw Namespace


Screen.bTestScreen Field

スクリーンテスト中か。

protected bool bTestScreen;

See Also

Screen Class | y4cs.draw Namespace


Screen.bTestScreenSuccess Field

スクリーンテストに成功した。

protected bool bTestScreenSuccess;

See Also

Screen Class | y4cs.draw Namespace


Screen.drawContext Field

描画用のコンテクスト。

protected DrawContext drawContext;

See Also

Screen Class | y4cs.draw Namespace


Screen.g Field

setColorで設定されている色。

protected int g;

See Also

Screen Class | y4cs.draw Namespace


Screen.moji Field

protected readonly string moji;

See Also

Screen Class | y4cs.draw Namespace


Screen.mojiData Field

protected readonly ushort[] mojiData;

See Also

Screen Class | y4cs.draw Namespace


Screen.offsetX Field

スクリーンのオフセット値。

protected int offsetX;

See Also

Screen Class | y4cs.draw Namespace


Screen.offsetY Field

スクリーンのオフセット値。

protected int offsetY;

See Also

Screen Class | y4cs.draw Namespace


Screen.r Field

setColorで設定されている色。

protected int r;

See Also

Screen Class | y4cs.draw Namespace


Screen.screenX Field

スクリーンのサイズ。

protected int screenX;

See Also

Screen Class | y4cs.draw Namespace


Screen.screenY Field

スクリーンのサイズ。

protected int screenY;

See Also

Screen Class | y4cs.draw Namespace


Screen.strCaption Field

ウィンドゥキャプション。

protected string strCaption;

See Also

Screen Class | y4cs.draw Namespace


Screen Methods

The methods of the Screen class are listed below. For a complete list of Screen class members, see the Screen Members topic.

Public Instance Methods

beginScreenTest | スクリーン解像度をテストする(2D/3D)。
blendAddColor | ブレンドとしてaddColorを指定する。
blendAddColorAlpha | 転送元がα付きサーフェースのときのaddcolor。
blendSrcAlpha | ブレンドとして、αブレンドを指定する。
blendSubColor | ブレンドとしてsubColorを指定する。
blendSubColorAlpha | 転送元がα付きサーフェースのときのsubcolor
blt | Overloaded. 画像の描画(2D)。
bltRotate | Overloaded. bltの回転機能つき。
clear | 画面のクリア(2D/3D)。
disableBlend | ブレンドを無効化する。
drawLine | 直線を引く(2D)。
drawLines |
drawPolygon | Overloaded. 三角形ポリゴンを描く(2D)。
drawString | openGLを用いた、簡単な文字列の描画。
enableBlend | ブレンドを有効にする。
endScreenTest | スクリーン解像度のテスト終了(2D/3D)。
Equals (inherited from Object) |
getColor | Overloaded.
getDrawContext | 描画用のコンテクストを取得。
GetHashCode (inherited from Object) |
getHeight | このサーフェースの高さを得る。
GetType (inherited from Object) |
getWidth | このサーフェースの幅を得る。
resetColor | 色をリセットする(2D/3D)。
setCaption | ウィンドゥキャプションの設定(2D/3D)。
setClearColor | Overloaded. clearするときの色を設定する(2D/3D)。
setColor | Overloaded. 色を設定する(2D/3D)。
setDrawContext | 描画用のコンテクストの設定。
setLineWidth | drawLine,drawStringの線の太さをピクセル単位で指定する。
setScreenOffset | 画面にオフセットを加える(2D)。
setVideoMode | 画面解像度の変更(2D/3D)。
setView | Overloaded. 視体積の設定(2D)。
testVideoMode | スクリーン解像度のテスト(2D/3D)。
ToString (inherited from Object) |
unbind | テクスチャーのバインドを解除する。
update | 実画面に描画を行なう(2D/3D)。

Protected Instance Methods

Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |
setView | Overloaded. 視体積の設定(こちらは内部的に使用される)。

See Also

Screen Class | y4cs.draw Namespace


Screen.beginScreenTest Method

スクリーン解像度をテストする(2D/3D)。

public void beginScreenTest();

Remarks

ビデオボードがこちらの希望のスクリーン解像度、 bpp深度を持つとは限らない。 そこで、テストをする必要がある。

            beginScreenTest();	//	いまからテストする
            testVideoMode(640,480,32);	// フルスクリーン 640×480×32をテスト
            testVideoMode(640,480,16);	// フルスクリーン 640×480×16をテスト
            testVideoMode(640,480,24);	// フルスクリーン 640×480×24をテスト
            testVideoMode(640,480,0);	// ウィンドゥモード 640×480をテスト
            endScreenTest();	//	テスト終了
            //	結果として、最初にスクリーン変更に成功した解像度になる。
フルスクリーンモードは、成功するとは限らない。 ウィンドゥモードは、現在のディスプレイ解像度より小さなサイズならば メモリが足りている限りは成功する。

See Also

Screen Class | y4cs.draw Namespace


Screen.blendAddColor Method

ブレンドとしてaddColorを指定する。

public void blendAddColor();

Remarks

blt メソッド等で描画するときのblendを有効にする。 無効にするには disableBlend を呼び出すこと。 ブレンド方法としては、addColor(加色合成)を指定する。 すなわち、glBlendFunc(GL_ONE,GL_ONE);を行なっている。 α付きサーフェースでなくともaddColorは出来るので、 これを使って転送すると高速化を図れることがある。 光の表現をするときなどに使うと良い。 http://www.platz.or.jp/~moal/ablend.html" が詳しい。

See Also

Screen Class | y4cs.draw Namespace


Screen.blendAddColorAlpha Method

転送元がα付きサーフェースのときのaddcolor。

public void blendAddColorAlpha();

Remarks

blendAddColor の α付きサーフェースのとき用。

内部的には

            enableBlend();
            glBlendFunc(GL_SRC_ALPHA,GL_ONE);
を行なっている。

See Also

Screen Class | y4cs.draw Namespace


Screen.blendSrcAlpha Method

ブレンドとして、αブレンドを指定する。

public void blendSrcAlpha();

Remarks

blt メソッド等で描画するときのblendを有効にする。 ブレンド方法として、

glBlendFunc(GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA);
を指定している。 これにより、転送元のα値により、αブレンドが行なわれる。 テクスチャーのカラーキー付き転送も、実際はカラーキーの部分のα値を 0にすることにより実現しているので、この転送方式を用いないと、 カラーキー付き転送は実現できない。

See Also

Screen Class | y4cs.draw Namespace


Screen.blendSubColor Method

ブレンドとしてsubColorを指定する。

public void blendSubColor();

Remarks

blt メソッド等で描画するときのblendを有効にする。 これを使って転送すると高速化を図れることがある。 ブレンド方法としては、subColor(加色合成)を指定する。 すなわち、glBlendFunc(GL_ZERO,GL_ONE_MINUS_SRC_COLOR);を行なっている。 α付きサーフェースでなくともsubColorは出来るので、 これを使って転送すると高速化を図れることがある。 http://www.platz.or.jp/~moal/subtract.html が詳しい。

See Also

Screen Class | y4cs.draw Namespace


Screen.blendSubColorAlpha Method

転送元がα付きサーフェースのときのsubcolor

public void blendSubColorAlpha();

Remarks

blendSubColor の α付きサーフェースのとき用。

内部的には

            enableBlend();
            glBlendFunc(GL_ZERO,GL_ONE_MINUS_SRC_ALPHA);
を行なっている。

See Also

Screen Class | y4cs.draw Namespace


blt Method

Yaneurao Game Library 4th for C#

Screen.blt Method

画像の描画(2D)。

Overload List

画像の描画(2D)。

public void blt(ITextureBase,int,int);

画像の描画(2D)。

public void blt(ITextureBase,int,int,ref Rect);

画像の描画(2D)。

public void blt(ITextureBase,int,int,ref Rect,ref Size);

凸四角形→凸四角形への転送。

public void blt(ITextureBase,Point[],Point[]);

画像の描画(2D)

public void blt(ITextureBase,ref Rect,Point[]);

See Also

Screen Class | y4cs.draw Namespace


Screen.blt Method (ITextureBase, Int32, Int32)

画像の描画(2D)。

public void blt(
ITextureBase src,
int x,
int y
);

Remarks

テクスチャーを(x,y)に等倍で描画する。 テクスチャーの色には、直前のsetColorの値が乗算される。 色の変更　→　setColor(r,g,b)/setColor(a)/resetColor() ブレンド方法変更　→　blendなんちゃら関数 ※　テクスチャーを描画するとき、 glBindTextureを内部的に呼び出すので、これを設定している人は注意。 描画を転送先でclipしたいときは、 getDrawContext で 描画コンテクストを書き換えればok。

See Also

Screen Class | y4cs.draw Namespace | Screen.blt Overload List


Screen.blt Method (ITextureBase, Int32, Int32, Rect)

画像の描画(2D)。

public void blt(
ITextureBase src,
int x,
int y,
ref Rect srcRect
);

Remarks

bltの転送元矩形の指定できるバージョン。 srcRectがnullのときはソース全域。

高速化のため転送元矩形が転送元サーフェースからハミ出る場合の 処理はしていないので、何とかしる。

転送元矩形として、(right,top,left,bottom)を指定すれば 左右反転して表示される。(left,bottom,right,top)を指定すれば 上下反転して表示される。

See Also

Screen Class | y4cs.draw Namespace | Screen.blt Overload List


Screen.blt Method (ITextureBase, Int32, Int32, Rect, Size)

画像の描画(2D)。

public void blt(
ITextureBase src,
int x,
int y,
ref Rect srcRect,
ref Size dstSize
);

Remarks

bltの転送元矩形と転送先サイズの指定できるバージョン。 srcRectがnullのときはソース全域。 dstSizeがnullのときは転送先全域(のサイズ)。 転送元矩形として、(right,top,left,bottom)を指定すれば 左右反転して表示される。(left,bottom,right,top)を指定すれば 上下反転して表示される。

See Also

Screen Class | y4cs.draw Namespace | Screen.blt Overload List


Screen.blt Method (ITextureBase, Point[], Point[])

凸四角形→凸四角形への転送。

public void blt(
ITextureBase src,
Point[] srcPoint,
Point[] dstPoint
);

Parameters

src
srcPoint
dstPoint

See Also

Screen Class | y4cs.draw Namespace | Screen.blt Overload List


Screen.blt Method (ITextureBase, Rect, Point[])

画像の描画(2D)

public void blt(
ITextureBase src,
ref Rect srcRect,
Point[] point
);

Remarks

bltの転送元矩形と転送先4点の指定できるバージョン。 srcRectがnullのときはソース全域。 転送元矩形が、転送先として指定された4点に移動。 転送先は、 point[0]が左上、point[1]が右上、point[2]が右下、point[3]が左下 の点を指定しているものとする。

Example

            Screen screen = new Screen;
            screen.setVideoMode(640,480,0);
            Texture tex = new Texture;
            tex.load("title.png");

            while (GameFrame.pollEvent()==0){

                screen.clear();

                Point[4] points;
                points[0].setPoint(100,100);
                points[1].setPoint(400,100);
                points[2].setPoint(640,480);
                points[3].setPoint(0,480);
                screen.blt(tex2,0,0,null,points);	//	台形描画

                screen.update();
            }

See Also

Screen Class | y4cs.draw Namespace | Screen.blt Overload List


bltRotate Method

Yaneurao Game Library 4th for C#

Screen.bltRotate Method

bltの回転機能つき。

Overload List

bltの回転機能つき。

public void bltRotate(ITextureBase,int,int,int,float,int);

bltの回転機能つき。

public void bltRotate(ITextureBase,int,int,int,float,int,int);

bltの回転機能つき。

public void bltRotate(ITextureBase,int,int,ref Rect,int,float,int,int);

See Also

Screen Class | y4cs.draw Namespace


Screen.bltRotate Method (ITextureBase, Int32, Int32, Int32, Single, Int32)

bltの回転機能つき。

public void bltRotate(
ITextureBase src,
int x,
int y,
int rad,
float rate,
int base_
);

Parameters

src
x
y
rad
rate
base_

Remarks

指定のテクスチャを転送先の(x,y)にrad回して描画します。

radの単位は、0～512で一周(2π)となる角度。 回転の方向は、右まわり（時計まわり）。 rateは、拡大率。1.0ならば等倍。

baseは転送元画像どの点が(x,y)に来るかを指定します。 0 : 左上。 1 : 上辺の中点　2:右上 3 : 左辺の中点 4 : 画像中心 5:右辺の中点 6 : 左下。　 7 : 下辺の中点 8:右下

See Also

Screen Class | y4cs.draw Namespace | Screen.bltRotate Overload List


Screen.bltRotate Method (ITextureBase, Int32, Int32, Int32, Single, Int32, Int32)

bltの回転機能つき。

public void bltRotate(
ITextureBase src,
int x,
int y,
int rad,
float rate,
int bx,
int by
);

Parameters

src
x
y
rad
rate
bx
by

Remarks

指定のテクスチャを転送先の(x,y)にrad回して描画します。

radの単位は、0～512で一周(2π)となる角度。 回転の方向は、右まわり（時計まわり）。 rateは、拡大率。1.0ならば等倍。 (bx,by)は転送元の回転中心。(x,y)の地点が転送元の画像中心になるように したいならば、(x-bx*rate,y-by*rate)をこのメソッドのx,yに渡す必要がある。

See Also

Screen Class | y4cs.draw Namespace | Screen.bltRotate Overload List


Screen.bltRotate Method (ITextureBase, Int32, Int32, Rect, Int32, Single, Int32, Int32)

bltの回転機能つき。

public void bltRotate(
ITextureBase src,
int x,
int y,
ref Rect srcRect,
int rad,
float rate,
int bx,
int by
);

Parameters

src
x
y
srcRect
rad
rate
bx
by

Remarks

指定のテクスチャを転送先の(x,y)に半径rで描画します。

radの単位は、0～512で一周(2π)となる角度。 回転の方向は、右まわり（時計まわり）。 rateは、拡大率。1.0ならば等倍。 (bx,by)は転送元の画像の、回転中心。 srcRectは転送元矩形。nullならば転送元テクスチャ全体。

See Also

Screen Class | y4cs.draw Namespace | Screen.bltRotate Overload List


Screen.clear Method

画面のクリア(2D/3D)。

public void clear();

Remarks

画面をクリアする色は、 setClearColor で設定された色

See Also

Screen Class | y4cs.draw Namespace


Screen.disableBlend Method

ブレンドを無効化する。

public void disableBlend();

Remarks

blt メソッド等で描画するときのblendを無効化する。 (ディフォルトでは無効)

See Also

Screen Class | y4cs.draw Namespace


Screen.drawLine Method

直線を引く(2D)。

public void drawLine(
int x1,
int y1,
int x2,
int y2
);

Remarks

※描画は二次元的な描画なのであとから描画したものが前面に描画される。 DrawContext に基づくclipping、座標系の変換を行なう。

See Also

Screen Class | y4cs.draw Namespace


Screen.drawLines Method

public void drawLines(
int[] lines,
int count
);

Parameters

lines
count

See Also

Screen Class | y4cs.draw Namespace


drawPolygon Method

Yaneurao Game Library 4th for C#

Screen.drawPolygon Method

三角形ポリゴンを描く(2D)。

Overload List

三角形ポリゴンを描く(2D)。

public void drawPolygon(int,int,int,int,int,int);

長方形ポリゴンを描く(2D)。

public void drawPolygon(int,int,int,int,int,int,int,int);

凸5角形を描く。(2D)。

public void drawPolygon(int,int,int,int,int,int,int,int,int,int);

See Also

Screen Class | y4cs.draw Namespace


Screen.drawPolygon Method (Int32, Int32, Int32, Int32, Int32, Int32)

三角形ポリゴンを描く(2D)。

public void drawPolygon(
int x1,
int y1,
int x2,
int y2,
int x3,
int y3
);

Remarks

3点を繋ぐようにした四角形を描く。中は、塗りつぶし。 ※描画は二次元的な描画なのであとから描画したものが前面に描画される。 DrawContext に基づくclipping、座標系の変換を行なう。

See Also

Screen Class | y4cs.draw Namespace | Screen.drawPolygon Overload List


Screen.drawPolygon Method (Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32)

長方形ポリゴンを描く(2D)。

public void drawPolygon(
int x1,
int y1,
int x2,
int y2,
int x3,
int y3,
int x4,
int y4
);

Remarks

4点を繋ぐようにした四角形を描く。要するに凸4角形。中は、塗りつぶし。 ※描画は二次元的な描画なのであとから描画したものが前面に描画される。 DrawContext に基づくclipping、座標系の変換を行なう。

See Also

Screen Class | y4cs.draw Namespace | Screen.drawPolygon Overload List


Screen.drawPolygon Method (Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32)

凸5角形を描く。(2D)。

public void drawPolygon(
int x1,
int y1,
int x2,
int y2,
int x3,
int y3,
int x4,
int y4,
int x5,
int y5
);

Remarks

5点を繋ぐようにした四角形を描く。要するに凸5角形。中は、塗りつぶし。 ※描画は二次元的な描画なのであとから描画したものが前面に描画される。 DrawContext に基づくclipping、座標系の変換を行なう。

See Also

Screen Class | y4cs.draw Namespace | Screen.drawPolygon Overload List


Screen.drawString Method

openGLを用いた、簡単な文字列の描画。

public void drawString(
string txt,
int x,
int y,
int size
);

Remarks

対応しているのは、数字とアルファベットのみ。 openGLは初期化済みと仮定している。 文字列を描画していく。指定された座標(x,y)から、指定されたsizeで 右側に向かって描画していく。2D polygonを使用。 簡単なデバッグ用だと想定している。

            screen.setLineWidth(2);
            screen.drawString("0123456789",0,0,10);
もし必要ならば、変換行列を設定して、回転・移動を行なえば良い。

See Also

Screen Class | y4cs.draw Namespace


Screen.enableBlend Method

ブレンドを有効にする。

public void enableBlend();

Remarks

blt メソッド等で描画するときのblendを有効にする。 (ディフォルトでは無効) 無効にするには disableBlend を呼び出すこと。

glBlendFunc(srcFunc,dstFunc);
// 転送元に適用する関数 , 転送先に適応する関数

Example

例)

glBlendFunc(GL_DST_COLOR,GL_ZERO);
ならば、 転送先のピクセルの値 ＝　転送元のピクセル×転送先のピクセル　＋　０ となり、転送元ピクセルで抜いたような形になる。 指定できる定数は、以下の通り。 定数 (fR,fG,fB,fA)
                GL_ZERO (0,0,0,0)
                GL_ONE (1,1,1,1)
                GL_SRC_COLOR (Rs/kR ,Gs/kG,Bs/kB,As/kA)
                GL_ONE_MINUS_SRC_COLOR (1,1,1,1)-(Rs/kR,Gs/kG,Bs/kB,As/kA)
                GL_DST_COLOR (Rd/kR,Gd/kG,Bd/kB,Ad/kA)
                GL_ONE_MINUS_DST_COLOR (1,1,1,1)-(Rd/kR,Gd/kG,Bd/kB,Ad/kA)
                GL_SRC_ALPHA (As/kA,As/kA,As/kA,As/kA)
                GL_ONE_MINUS_SRC_ALPHA (1,1,1,1)-(As/kA,As/kA,As/kA,As/kA)
                GL_DST_ALPHA (Ad/kA,Ad/kA,Ad/kA,Ad/kA)
                GL_ONE_MINUS_DST_ALPHA (1,1,1,1)-(Ad/kA,Ad/kA,Ad/kA,Ad/kA)
                GL_SRC_ALPHA_SATURATE (i,i,i,1)
s : source(転送元) , d : destination(転送先) kR,kG,kB,kA : 255(RGBA8888のとき) i : min(As, kA-Ad) / kA
glBlendFunc(GL_SRC_ALPHA, GL_ONE_MINUS_SRC_ALPHA);
なら、 転送先　＝ 転送元の値×転送元のα　＋　転送先の値×（１－転送元のα） となり、いわゆる普通のαブレンドになる

See Also

Screen Class | y4cs.draw Namespace


Screen.endScreenTest Method

スクリーン解像度のテスト終了(2D/3D)。

public y4cs_result endScreenTest();

Remarks

beginScreenTest も参照すること。 スクリーン変更に成功していれば0,失敗していれば非0が返る。

See Also

Screen Class | y4cs.draw Namespace


getColor Method

Yaneurao Game Library 4th for C#

Screen.getColor Method

Overload List

public void getColor(out int,out int,out int);

public void getColor(out int,out int,out int,out int);

See Also

Screen Class | y4cs.draw Namespace


Screen.getColor Method (Int32, Int32, Int32)

public void getColor(
out int r_,
out int g_,
out int b_
);

See Also

Screen Class | y4cs.draw Namespace | Screen.getColor Overload List


Screen.getColor Method (Int32, Int32, Int32, Int32)

public void getColor(
out int r_,
out int g_,
out int b_,
out int a_
);

See Also

Screen Class | y4cs.draw Namespace | Screen.getColor Overload List


Screen.getDrawContext Method

描画用のコンテクストを取得。

public DrawContext getDrawContext();

Return Value

Remarks

値を変更すると、その変更した値に従って描画される。

See Also

Screen Class | y4cs.draw Namespace


Screen.getHeight Method

このサーフェースの高さを得る。

public uint getHeight();

Remarks

setVideoModeで指定したyがこれ。

See Also

Screen Class | y4cs.draw Namespace


Screen.getWidth Method

このサーフェースの幅を得る。

public uint getWidth();

Remarks

setVideoModeで指定したxがこれ。

See Also

Screen Class | y4cs.draw Namespace


Screen.resetColor Method

色をリセットする(2D/3D)。

public void resetColor();

Remarks

ラインやポリゴンの描画色を(255,255,255)に設定する。 テクスチャー貼り付けのときなど、setColorの値で乗算されるので、 そのままの画像を表示したいならば(255,255,255)に設定しておく 必要があるため。

See Also

Screen Class | y4cs.draw Namespace


Screen.setCaption Method

ウィンドゥキャプションの設定(2D/3D)。

public void setCaption(
string name
);

Remarks

画面の解像度変更前/後、どちらに実行しても良い。

See Also

Screen Class | y4cs.draw Namespace


setClearColor Method

Yaneurao Game Library 4th for C#

Screen.setClearColor Method

clearするときの色を設定する(2D/3D)。

Overload List

clearするときの色を設定する(2D/3D)。

public void setClearColor(int,int,int);

clearするときの色を設定する(2D/3D)。

public void setClearColor(int,int,int,int);

See Also

Screen Class | y4cs.draw Namespace


Screen.setClearColor Method (Int32, Int32, Int32)

clearするときの色を設定する(2D/3D)。

public void setClearColor(
int r,
int g,
int b
);

Remarks

rgbは各 0～255。 パラメータはbyteでいいのだが、intからbyteに暗黙で変換しないので かえって使いにくいので、intをとるようになっている。

See Also

Screen Class | y4cs.draw Namespace | Screen.setClearColor Overload List


Screen.setClearColor Method (Int32, Int32, Int32, Int32)

clearするときの色を設定する(2D/3D)。

public void setClearColor(
int r,
int g,
int b,
int a
);

Remarks

rgbaは各 0～255。 パラメータはbyteでいいのだが、intからbyteに暗黙で変換しないので かえって使いにくいので、intをとるようになっている。

See Also

Screen Class | y4cs.draw Namespace | Screen.setClearColor Overload List


setColor Method

Yaneurao Game Library 4th for C#

Screen.setColor Method

色をセットする(2D/3D)。

Overload List

色をセットする(2D/3D)。

public void setColor(int);

色を設定する(2D/3D)。

public void setColor(int,int,int);

色を設定する(2D/3D)。

public void setColor(int,int,int,int);

See Also

Screen Class | y4cs.draw Namespace


Screen.setColor Method (Int32)

色をセットする(2D/3D)。

public void setColor(
int a
);

Remarks

ラインやポリゴンの描画色を(a,a,a)に設定する。 aの範囲は0～255。 テクスチャー貼り付けのときなど、setColorの値で乗算されるので、 fade(薄く描画)したければ、(a,a,a)に設定する必要があるため。

See Also

Screen Class | y4cs.draw Namespace | Screen.setColor Overload List


Screen.setColor Method (Int32, Int32, Int32)

色を設定する(2D/3D)。

public void setColor(
int r_,
int g_,
int b_
);

Remarks

ラインやポリゴンの描画色を設定する。 rgbは各 0～255。 パラメータはbyteでいいのだが、intからbyteに暗黙で変換しないので かえって使いにくいので、intをとるようになっている。

See Also

Screen Class | y4cs.draw Namespace | Screen.setColor Overload List


Screen.setColor Method (Int32, Int32, Int32, Int32)

色を設定する(2D/3D)。

public void setColor(
int r_,
int g_,
int b_,
int a_
);

Remarks

ラインやポリゴンの描画色を設定する。 rgbは各 0～255。 パラメータはbyteでいいのだが、intからbyteに暗黙で変換しないので かえって使いにくいので、intをとるようになっている。

See Also

Screen Class | y4cs.draw Namespace | Screen.setColor Overload List


Screen.setDrawContext Method

描画用のコンテクストの設定。

public DrawContext setDrawContext(
DrawContext v
);

Parameters

v

Return Value

Remarks

この変更した値に従って描画される。 以前のsetDrawContextで設定されていた値を返す。 (いらなければ使う必要はない)

See Also

Screen Class | y4cs.draw Namespace


Screen.setLineWidth Method

drawLine,drawStringの線の太さをピクセル単位で指定する。

public void setLineWidth(
float u
);

See Also

Screen Class | y4cs.draw Namespace


Screen.setScreenOffset Method

画面にオフセットを加える(2D)。

public void setScreenOffset(
int ox,
int oy
);

Remarks

表示する視界に2次元オフセット(ox,oy)を加える。 (100,200)を設定すると、画面下が(100,200),画面右上が(100+640,200+480) の意味になる。画面を揺らしたりするときに使うと良い。

See Also

Screen Class | y4cs.draw Namespace


Screen.setVideoMode Method

画面解像度の変更(2D/3D)。

public y4cs_result setVideoMode(
int width,
int height,
int bpp
);

Remarks

引数の意味はtestVideoModeと同じ。 変更できなければ非0が返る。変更できるとは限らないので beginScreenTest～endScreenTestを用いるべき。

See Also

Screen Class | y4cs.draw Namespace


setView Method

Yaneurao Game Library 4th for C#

Screen.setView Method

視体積の設定(こちらは内部的に使用される)。

Overload List

視体積の設定(こちらは内部的に使用される)。

protected void setView();

視体積の設定(2D)。

public void setView(int,int,int,int);

See Also

Screen Class | y4cs.draw Namespace


Screen.setView Method ()

視体積の設定(こちらは内部的に使用される)。

protected void setView();

See Also

Screen Class | y4cs.draw Namespace | Screen.setView Overload List


Screen.setView Method (Int32, Int32, Int32, Int32)

視体積の設定(2D)。

public void setView(
int x1,
int y1,
int x2,
int y2
);

Remarks

ウィンドゥの左上が(x1,y1),右下が(x2,y2)になるように設定される。 setScreenOffset,setVideoMode等で内部的に呼び出される

See Also

Screen Class | y4cs.draw Namespace | Screen.setView Overload List


Screen.testVideoMode Method

スクリーン解像度のテスト(2D/3D)。

public y4cs_result testVideoMode(
int x,
int y,
int bpp
);

Remarks

スクリーン解像度のテストを行なう。 x,y はスクリーンサイズ。bpp はピクセル深度(bits per pixel) bpp として0を指定すれば、ウィンドゥモード。 (現在のモードから解像度切り替えを行なわないの意味) beginScreenTest～endScreenTestで用いる。 beginScreenTest も参照すること。 成功すれば0が返るが、この返し値を使うのではなく、 beginScreenTest～endScreenTestで用いること。

See Also

Screen Class | y4cs.draw Namespace


Screen.unbind Method

テクスチャーのバインドを解除する。

public void unbind();

Remarks

Texture.bind(); でバインドしていたテクスチャーをunbindする。

See Also

Screen Class | y4cs.draw Namespace


Screen.update Method

実画面に描画を行なう(2D/3D)。

public y4cs_result update();

See Also

Screen Class | y4cs.draw Namespace


Size Structure

サイズを表している構造体。

For a list of all members of this type, see Size Members.

System.Object
ValueType
Size

public struct Size

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Size Members | y4cs.draw Namespace


Size Members

Size overview

Public Instance Fields

cx | 幅。
cy | 高さ。

Public Instance Methods

Equals (inherited from ValueType) |
GetHashCode (inherited from ValueType) |
GetType (inherited from Object) |
setSize | 各データを設定する。
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Size Class | y4cs.draw Namespace


Size Fields

The fields of the Size structure are listed below. For a complete list of Size structure members, see the Size Members topic.

Public Instance Fields

cx | 幅。
cy | 高さ。

See Also

Size Class | y4cs.draw Namespace


Size.cx Field

幅。

public uint cx;

See Also

Size Class | y4cs.draw Namespace


Size.cy Field

高さ。

public uint cy;

See Also

Size Class | y4cs.draw Namespace


Size Methods

The methods of the Size structure are listed below. For a complete list of Size structure members, see the Size Members topic.

Public Instance Methods

Equals (inherited from ValueType) |
GetHashCode (inherited from ValueType) |
GetType (inherited from Object) |
setSize | 各データを設定する。
ToString (inherited from ValueType) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Size Class | y4cs.draw Namespace


Size.setSize Method

各データを設定する。

public void setSize(
uint cx_,
uint cy_
);

Parameters

cx_
cy_

See Also

Size Class | y4cs.draw Namespace


Surface Class

描画のためのサーフェース

For a list of all members of this type, see Surface Members.

System.Object
Surface

public class Surface : IDisposable

Remarks

2D描画、3D描画のときに用いられる、サーフェース。 bmp,png等の読み込み/書き出しをサポート。

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Surface Members | y4cs.draw Namespace


Surface Members

Surface overview

Public Static Methods

createDIBstatic

Public Instance Constructors

Surface Constructor Initializes a new instance of the Surface class.

Public Instance Methods

blt | 画像の転送。
checkARGB8888 |
checkRGB888 |
clear |
createDIB | RGB888 or RGBA8888のサーフェースを作成する。
Dispose | Overloaded.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getHeight |
getPixels |
getSize |
getSurface |
GetType (inherited from Object) |
getWidth |
load | サーフェースへの画像読み込みメソッド。
release |
saveBMP |
setSurface |
ToString (inherited from Object) |

Protected Instance Fields

disposed |
surface | サーフェースの実体。

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

Surface Class | y4cs.draw Namespace


Surface Constructor

Initializes a new instance of the Surface class.

public Surface();

See Also

Surface Class | y4cs.draw Namespace


Surface Fields

The fields of the Surface class are listed below. For a complete list of Surface class members, see the Surface Members topic.

Protected Instance Fields

disposed |
surface | サーフェースの実体。

See Also

Surface Class | y4cs.draw Namespace


Surface.disposed Field

protected bool disposed;

See Also

Surface Class | y4cs.draw Namespace


Surface.surface Field

サーフェースの実体。

protected IntPtr surface;

See Also

Surface Class | y4cs.draw Namespace


Surface Methods

The methods of the Surface class are listed below. For a complete list of Surface class members, see the Surface Members topic.

Public Static Methods

createDIBstatic

Public Instance Methods

blt | 画像の転送。
checkARGB8888 |
checkRGB888 |
clear |
createDIB | RGB888 or RGBA8888のサーフェースを作成する。
Dispose | Overloaded.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getHeight |
getPixels |
getSize |
getSurface |
GetType (inherited from Object) |
getWidth |
load | サーフェースへの画像読み込みメソッド。
release |
saveBMP |
setSurface |
ToString (inherited from Object) |

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

Surface Class | y4cs.draw Namespace


Surface.blt Method

画像の転送。

public y4cs_result blt(
Surface src,
int x,
int y
);

Parameters

src
転送元画像。
x
転送先x座標。
y
転送先y座標。

Return Value

Remarks

これ以上の転送を期待しているなら、SDL gfxをportingしてくるべき。

See Also

Surface Class | y4cs.draw Namespace


Surface.checkARGB8888 Method

public bool checkARGB8888();

See Also

Surface Class | y4cs.draw Namespace


Surface.checkRGB888 Method

public bool checkRGB888();

See Also

Surface Class | y4cs.draw Namespace


Surface.clear Method

public y4cs_result clear();

See Also

Surface Class | y4cs.draw Namespace


Surface.createDIB Method

RGB888 or RGBA8888のサーフェースを作成する。

public y4cs_result createDIB(
int x,
int y,
bool bAlpha
);

Parameters

x
サーフェースサイズ(x)
y
サーフェースサイズ(y)
bAlpha
bAlphaがtrueのときはRGBA8888(1pixelがR,G,B,A各8bitα付き32bit) bAlphaがfalseのときはRGB888(1pixelがRGB各8bit,24bit) のサーフェースを作成する。

Return Value

失敗時には非0が返る。

See Also

Surface Class | y4cs.draw Namespace


Surface.createDIBstatic Method

public static y4cs_result createDIBstatic(
out IntPtr surface,
int x,
int y,
bool bAlpha
);

See Also

Surface Class | y4cs.draw Namespace


Dispose Method

Yaneurao Game Library 4th for C#

Surface.Dispose Method

Overload List

public void Dispose();

protected void Dispose(bool);

See Also

Surface Class | y4cs.draw Namespace


Surface.Dispose Method ()

public void Dispose();

Implements

IDisposable.Dispose

See Also

Surface Class | y4cs.draw Namespace | Surface.Dispose Overload List


Surface.Dispose Method (Boolean)

protected void Dispose(
bool disposing
);

Parameters

disposing

See Also

Surface Class | y4cs.draw Namespace | Surface.Dispose Overload List


Surface.Finalize Method

protected override void Finalize();

See Also

Surface Class | y4cs.draw Namespace


Surface.getHeight Method

public int getHeight();

See Also

Surface Class | y4cs.draw Namespace


Surface.getPixels Method

public IntPtr getPixels();

See Also

Surface Class | y4cs.draw Namespace


Surface.getSize Method

public void getSize(
ref int x,
ref int y
);

See Also

Surface Class | y4cs.draw Namespace


Surface.getSurface Method

public IntPtr getSurface();

See Also

Surface Class | y4cs.draw Namespace


Surface.getWidth Method

public int getWidth();

See Also

Surface Class | y4cs.draw Namespace


Surface.load Method

サーフェースへの画像読み込みメソッド。

public y4cs_result load(
string filename
);

Parameters

filename

Return Value

読み込み失敗のときは非0が返る。

Remarks

bmp画像,png画像を読み込みサポート。

See Also

Surface Class | y4cs.draw Namespace


Surface.release Method

public void release();

See Also

Surface Class | y4cs.draw Namespace


Surface.saveBMP Method

public y4cs_result saveBMP(
string filename
);

See Also

Surface Class | y4cs.draw Namespace


Surface.setSurface Method

public void setSurface(
IntPtr surface_
);

See Also

Surface Class | y4cs.draw Namespace


Texture Class

Screen に画像を描画するためのサーフェース

For a list of all members of this type, see Texture Members.

System.Object
Texture

public class Texture : ICacheObject, ITextureBase, IDisposable

Remarks

openGLのテクスチャー。 bmp,png,etc..を読み込んで、画面に描画するときに使います。 サイズは 幅、高さがそれぞれ、2のべき乗でなければ、2のべき乗に なるようにテクスチャーサイズを内部で拡大します。

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Texture Members | y4cs.draw Namespace


Texture Members

Texture overview

Public Instance Constructors

Texture Constructor Initializes a new instance of the Texture class.

Public Instance Methods

bind |
blt | Overloaded.
disableAlpha | α転送を無効に
Dispose | Overloaded.
enableAlpha | α転送を有効に。
Equals (inherited from Object) |
getBufferSize |
GetHashCode (inherited from Object) |
getHeight |
getHeightRate |
getRHeight |
getRWidth |
GetType (inherited from Object) |
getWidth |
getWidthRate |
isLoad |
load | 指定されたファイル名の画像を読み込む。
release |
resetColorKey |
setColorKey | 抜き色の指定。
setSmooth | テクスチャを貼るときに線形補間する。
setSurface | Overloaded. SDL_Surafceを渡し、それをテクスチャーとする
ToString (inherited from Object) |
unbind | テクスチャーのバインドを解除する。

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

Texture Class | y4cs.draw Namespace


Texture Constructor

Initializes a new instance of the Texture class.

public Texture();

See Also

Texture Class | y4cs.draw Namespace


Texture Methods

The methods of the Texture class are listed below. For a complete list of Texture class members, see the Texture Members topic.

Public Instance Methods

bind |
blt | Overloaded.
disableAlpha | α転送を無効に
Dispose | Overloaded.
enableAlpha | α転送を有効に。
Equals (inherited from Object) |
getBufferSize |
GetHashCode (inherited from Object) |
getHeight |
getHeightRate |
getRHeight |
getRWidth |
GetType (inherited from Object) |
getWidth |
getWidthRate |
isLoad |
load | 指定されたファイル名の画像を読み込む。
release |
resetColorKey |
setColorKey | 抜き色の指定。
setSmooth | テクスチャを貼るときに線形補間する。
setSurface | Overloaded. SDL_Surafceを渡し、それをテクスチャーとする
ToString (inherited from Object) |
unbind | テクスチャーのバインドを解除する。

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

Texture Class | y4cs.draw Namespace


Texture.bind Method

public void bind();

See Also

Texture Class | y4cs.draw Namespace


blt Method

Yaneurao Game Library 4th for C#

Texture.blt Method

Overload List

public void blt(DrawContext,float,float);

public void blt(DrawContext,float,float,ref Rect);

public void blt(DrawContext,float,float,ref Rect,ref Size);

public void blt(DrawContext,Point[],Point[]);

public void blt(DrawContext,ref Rect,Point[]);

See Also

Texture Class | y4cs.draw Namespace


Texture.blt Method (DrawContext, Single, Single)

public void blt(
DrawContext context,
float x,
float y
);

Parameters

context
x
y

Implements

ITextureBase.blt

See Also

Texture Class | y4cs.draw Namespace | Texture.blt Overload List


Texture.blt Method (DrawContext, Single, Single, Rect)

public void blt(
DrawContext context,
float x,
float y,
ref Rect srcRect
);

Parameters

context
x
y
srcRect

Implements

ITextureBase.blt

See Also

Texture Class | y4cs.draw Namespace | Texture.blt Overload List


Texture.blt Method (DrawContext, Single, Single, Rect, Size)

public void blt(
DrawContext context,
float x,
float y,
ref Rect srcRect,
ref Size dstSize
);

Parameters

context
x
y
srcRect
dstSize

Implements

ITextureBase.blt

See Also

Texture Class | y4cs.draw Namespace | Texture.blt Overload List


Texture.blt Method (DrawContext, Point[], Point[])

public void blt(
DrawContext context,
Point[] srcPoint,
Point[] dstPoint
);

Parameters

context
srcPoint
dstPoint

Implements

ITextureBase.blt

See Also

Texture Class | y4cs.draw Namespace | Texture.blt Overload List


Texture.blt Method (DrawContext, Rect, Point[])

public void blt(
DrawContext context,
ref Rect srcRect,
Point[] dstPoint
);

Parameters

context
srcRect
dstPoint

Implements

ITextureBase.blt

See Also

Texture Class | y4cs.draw Namespace | Texture.blt Overload List


Texture.disableAlpha Method

α転送を無効に

public void disableAlpha();

Remarks

デフォルトではαは有効。 元情報にαが含まれていない場合で、α付きの転送を行なわないと わかっている場合(BGなど)は、無効化しておくことで、 転送時の高速化をはかれる。

抜き色の指定をする場合は、αサーフェースでなければならない。 (抜き色をαを書き換えて実現しているため)

See Also

Texture Class | y4cs.draw Namespace


Dispose Method

Yaneurao Game Library 4th for C#

Texture.Dispose Method

Overload List

public void Dispose();

protected void Dispose(bool);

See Also

Texture Class | y4cs.draw Namespace


Texture.Dispose Method ()

public void Dispose();

Implements

IDisposable.Dispose

See Also

Texture Class | y4cs.draw Namespace | Texture.Dispose Overload List


Texture.Dispose Method (Boolean)

protected void Dispose(
bool disposing
);

Parameters

disposing

See Also

Texture Class | y4cs.draw Namespace | Texture.Dispose Overload List


Texture.enableAlpha Method

α転送を有効に。

public void enableAlpha();

Remarks

ディフォルトではαは有効。 元情報にαが含まれていない場合で、α付きの転送を行なわないと わかっている場合(BGなど)は、無効化しておくことで、 転送時の高速化をはかれる。

抜き色の指定をする場合は、αサーフェースでなければならない。 (抜き色をαを書き換えて実現しているため)

また、画像を読み込む(load)するより以前に、この関数を 呼び出しておかなければならない。

See Also

Texture Class | y4cs.draw Namespace


Texture.Finalize Method

protected override void Finalize();

See Also

Texture Class | y4cs.draw Namespace


Texture.getBufferSize Method

public ulong getBufferSize();

Implements

ICacheObject.getBufferSize

See Also

Texture Class | y4cs.draw Namespace


Texture.getHeight Method

public float getHeight();

Implements

ITextureBase.getHeight

See Also

Texture Class | y4cs.draw Namespace


Texture.getHeightRate Method

public float getHeightRate();

See Also

Texture Class | y4cs.draw Namespace


Texture.getRHeight Method

public int getRHeight();

See Also

Texture Class | y4cs.draw Namespace


Texture.getRWidth Method

public int getRWidth();

See Also

Texture Class | y4cs.draw Namespace


Texture.getWidth Method

public float getWidth();

Implements

ITextureBase.getWidth

See Also

Texture Class | y4cs.draw Namespace


Texture.getWidthRate Method

public float getWidthRate();

See Also

Texture Class | y4cs.draw Namespace


Texture.isLoad Method

public bool isLoad();

See Also

Texture Class | y4cs.draw Namespace


Texture.load Method

指定されたファイル名の画像を読み込む。

public y4cs_result load(
string filename
);

Remarks

読み込みに失敗すれば非0が返る。

See Also

Texture Class | y4cs.draw Namespace


Texture.release Method

public void release();

See Also

Texture Class | y4cs.draw Namespace


Texture.resetColorKey Method

public void resetColorKey();

See Also

Texture Class | y4cs.draw Namespace


Texture.setColorKey Method

抜き色の指定。

public void setColorKey(
int r_,
int g_,
int b_
);

Parameters

r_
g_
b_

Remarks

転送時の転送元カラーキー(抜き色)を指定します。 これを指定して、loadを行なうと、そのサーフェースの該当色の部分の α値が0(透過)になる。(ただしαサーフェース作成時のみ)

r,g,bはそれぞれ0～255。

また、画像を読み込む(load)するより以前に、この関数を 呼び出しておかなければならない。(loadするときに抜き色部分の α値を0に書き換えるので)

See Also

Texture Class | y4cs.draw Namespace


Texture.setSmooth Method

テクスチャを貼るときに線形補間する。

public void setSmooth(
bool b
);

Parameters

b

Remarks

テクスチャを GL_LINEAR で貼る。 線形補間されるので拡大・縮小時に綺麗に貼れる。 むかしのビデオカードだとハードで対応していないので遅くなる。 デフォルトではtrue。

この関数を設定するなら、loadを行なう前に設定しておくこと。

BG用の画像等は、(拡大縮小しないならば) setSmooth(false);　しておけば 良いと思われる。

See Also

Texture Class | y4cs.draw Namespace


setSurface Method

Yaneurao Game Library 4th for C#

Texture.setSurface Method

SDL_Surafceを渡し、それをテクスチャーとする

Overload List

SDL_Surafceを渡し、それをテクスチャーとする

public y4cs_result setSurface(IntPtr);

SDL_Surafceを渡し、それをテクスチャーとする。

public y4cs_result setSurface(Surface);

See Also

Texture Class | y4cs.draw Namespace


Texture.setSurface Method (IntPtr)

SDL_Surafceを渡し、それをテクスチャーとする

public y4cs_result setSurface(
IntPtr surface
);

Parameters

surface

Return Value

See Also

Texture Class | y4cs.draw Namespace | Texture.setSurface Overload List


Texture.setSurface Method (Surface)

SDL_Surafceを渡し、それをテクスチャーとする。

public y4cs_result setSurface(
Surface surface
);

Parameters

surface

Return Value

See Also

Texture Class | y4cs.draw Namespace | Texture.setSurface Overload List


Texture.unbind Method

テクスチャーのバインドを解除する。

public void unbind();

Remarks

bind();でバインドしていたテクスチャーをunbindする。

See Also

Texture Class | y4cs.draw Namespace


TextureLoader Class

Texture の cacheメカニズムを実現する。

For a list of all members of this type, see TextureLoader Members.

System.Object
Iter
CacheLoader
TextureLoader

public class TextureLoader : CacheLoader

Remarks

Sound に対する SoundLoader と同じく、 Texture に対するキャッシュメカニズムを実現します。

cacheの単位はbyte。ディフォルトでは32MB。

640×480のテクスチャは、2^nに拡張されるので、 1024×512×4(ARGB) = 2MB にもなる。

CacheLoader の説明も読んでください。

int	loadDefFile(char[] filename);
で読み込む定義ファイルは、 a.bmp , 2 , -1 b.bmp ,,-1 のように書き、ひとつ目は、ファイル名、二つ目は、読み込む番号、3つ目は optionである。optionは現在、未使用である。

Example

使用例)

            int main(){
                Screen screen = new Screen;
                screen.setVideoMode(640,480,0);

                TextureLoader tl = new TextureLoader;
                tl.loadDefRW("title.png \n 4.png \n 3.png \n 4.bmp");

                //	事前に設定したいなら、ここで設定する
                tl.getObj(3).setColorKey(255,255,255);
                tl.getObj(3).disableAlpha();

                int x,y;
                while (GameFrame.pollEvent()==0){
                    //	1フレーム分の処理

                    screen.resetColor();
                    screen.clear();

                    screen.blt(tl.get(0),0,0);

                    //	これは半透明画像なので転送元αを有効にして転送
                    screen.blendSrcAlpha();
                    screen.blt(tl.get(1),70,70);

                    //	(100,100,200)にfadeして描画
                    screen.disableBlend();
                    screen.setColor(100,100,200);
                    screen.blt(tl.get(2),250,250);

                    screen.update();
                }
                return 0;
            }

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

TextureLoader Members | y4cs.draw Namespace


TextureLoader Members

TextureLoader overview

Public Instance Constructors

TextureLoader Constructor Initializes a new instance of the TextureLoader class.

Public Instance Properties

Current (inherited from CacheLoader)
IsRunning (inherited from y4cs.native.iterator.Iter)
IsStarted (inherited from y4cs.native.iterator.Iter)

Public Instance Methods

bind | 指定した番号のテクスチャーにbindする。
checkRelease (inherited from CacheLoader) | 解放妥当性のチェック。
createInstance | Textureのcloneメソッド。
Dispose (inherited from y4cs.native.iterator.Iter) |
Equals (inherited from Object) |
get | 指定された番号のオブジェクトを構築して返す。
getCacheFiles (inherited from CacheLoader) | cacheしているファイル数を返す。
getCacheSize (inherited from CacheLoader) | cacheするバッファの上限を取得。
GetEnumerator (inherited from CacheLoader) |
GetHashCode (inherited from Object) |
getInfoList (inherited from CacheLoader) | ファイルリストの取得。
getObj | 指定された番号のオブジェクトを構築して返す。
GetType (inherited from Object) |
isin (inherited from CacheLoader) | オブジェクトが生成されているかを調べる。
loadDefFile (inherited from CacheLoader) | 定義ファイルを読み込む。
loadDefRW (inherited from CacheLoader) | キャッシュリストを手渡しするための関数。
MoveNext (inherited from CacheLoader) |
print (inherited from CacheLoader) | 保持しているファイルリストの表示(デバッグ用)。
releaseAll (inherited from CacheLoader) | 保持していたキャッシュを解放する(ファイルリストは解放しない)。
releaseFileList (inherited from CacheLoader) | 保持していたファイルリスト、キャッシュを解放する。
releaseOldObject (inherited from CacheLoader) | 一番昔の時刻にアクセスされたファイルを解放するメソッド。
Reset (inherited from CacheLoader) |
Resume (inherited from y4cs.native.iterator.Iter) |
setCacheSize (inherited from CacheLoader) | cacheするバッファの上限を決める。
setUpdateCacheDelegate (inherited from CacheLoader) | 古いキャッシュの破棄メソッドの登録。
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
ToString (inherited from Object) |
updateFileList (inherited from CacheLoader) | ファイルリストを反映させる。

Protected Instance Fields

bStarted_ (inherited from y4cs.native.iterator.Iter) |
cachefiles (inherited from CacheLoader) | 実体を読み込んでいるファイルの数
cacheSize (inherited from CacheLoader) | cacheするサウンドバッファの上限(-1ならば無制限)。
filelist (inherited from CacheLoader) | ファイルリスト。
iterStart (inherited from y4cs.native.iterator.Iter) |
nowtime (inherited from CacheLoader) |
readPath (inherited from CacheLoader) | 実ファイル読み込みフォルダ。
state (inherited from y4cs.native.iterator.Iter) |
updateCacheDelegate (inherited from CacheLoader) | updateCacheで呼び出すdelegate。

Protected Instance Methods

checkCache (inherited from CacheLoader) | キャッシュがあふれたかを判定する。
createInfo (inherited from CacheLoader) | キャッシュ構造体のfactory。
Finalize (inherited from CacheLoader) |
getHelpper (inherited from CacheLoader) | 番号に対応するオブジェクトを読み込み、loadメソッドを呼び出す。
getHelpperObj (inherited from CacheLoader) | 番号に対応するオブジェクトを返す。
loadFile | テクスチャーを読み込むための関数。LoadCacheからのオーバーライド。
MemberwiseClone (inherited from Object) |
releaseFile | テクスチャーを解放するための関数。LoadCacheからのオーバーライド。
yield (inherited from y4cs.native.iterator.Iter) |

See Also

TextureLoader Class | y4cs.draw Namespace


TextureLoader Constructor

Initializes a new instance of the TextureLoader class.

public TextureLoader();

See Also

TextureLoader Class | y4cs.draw Namespace


TextureLoader Methods

The methods of the TextureLoader class are listed below. For a complete list of TextureLoader class members, see the TextureLoader Members topic.

Public Instance Methods

bind | 指定した番号のテクスチャーにbindする。
checkRelease (inherited from CacheLoader) | 解放妥当性のチェック。
createInstance | Textureのcloneメソッド。
Dispose (inherited from y4cs.native.iterator.Iter) |
Equals (inherited from Object) |
get | 指定された番号のオブジェクトを構築して返す。
getCacheFiles (inherited from CacheLoader) | cacheしているファイル数を返す。
getCacheSize (inherited from CacheLoader) | cacheするバッファの上限を取得。
GetEnumerator (inherited from CacheLoader) |
GetHashCode (inherited from Object) |
getInfoList (inherited from CacheLoader) | ファイルリストの取得。
getObj | 指定された番号のオブジェクトを構築して返す。
GetType (inherited from Object) |
isin (inherited from CacheLoader) | オブジェクトが生成されているかを調べる。
loadDefFile (inherited from CacheLoader) | 定義ファイルを読み込む。
loadDefRW (inherited from CacheLoader) | キャッシュリストを手渡しするための関数。
MoveNext (inherited from CacheLoader) |
print (inherited from CacheLoader) | 保持しているファイルリストの表示(デバッグ用)。
releaseAll (inherited from CacheLoader) | 保持していたキャッシュを解放する(ファイルリストは解放しない)。
releaseFileList (inherited from CacheLoader) | 保持していたファイルリスト、キャッシュを解放する。
releaseOldObject (inherited from CacheLoader) | 一番昔の時刻にアクセスされたファイルを解放するメソッド。
Reset (inherited from CacheLoader) |
Resume (inherited from y4cs.native.iterator.Iter) |
setCacheSize (inherited from CacheLoader) | cacheするバッファの上限を決める。
setUpdateCacheDelegate (inherited from CacheLoader) | 古いキャッシュの破棄メソッドの登録。
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
ToString (inherited from Object) |
updateFileList (inherited from CacheLoader) | ファイルリストを反映させる。

Protected Instance Methods

checkCache (inherited from CacheLoader) | キャッシュがあふれたかを判定する。
createInfo (inherited from CacheLoader) | キャッシュ構造体のfactory。
Finalize (inherited from CacheLoader) |
getHelpper (inherited from CacheLoader) | 番号に対応するオブジェクトを読み込み、loadメソッドを呼び出す。
getHelpperObj (inherited from CacheLoader) | 番号に対応するオブジェクトを返す。
loadFile | テクスチャーを読み込むための関数。LoadCacheからのオーバーライド。
MemberwiseClone (inherited from Object) |
releaseFile | テクスチャーを解放するための関数。LoadCacheからのオーバーライド。
yield (inherited from y4cs.native.iterator.Iter) |

See Also

TextureLoader Class | y4cs.draw Namespace


TextureLoader.bind Method

指定した番号のテクスチャーにbindする。

public y4cs_result bind(
int no
);

Remarks

指定した番号のテクスチャーが存在しなければ非0。

See Also

TextureLoader Class | y4cs.draw Namespace


TextureLoader.createInstance Method

Textureのcloneメソッド。

public override object createInstance();

See Also

TextureLoader Class | y4cs.draw Namespace


TextureLoader.get Method

指定された番号のオブジェクトを構築して返す。

public override object get(
int no
);

Remarks

暗黙のうちにオブジェクトは構築され、loadされる。 定義ファイル上に存在しない番号を指定した場合はnullが返る ファイルの読み込みに失敗した場合は、nullは返らない。 定義ファイル上に存在しない番号のものを再生することは 考慮しなくてもいいと思われる．．。

See Also

TextureLoader Class | y4cs.draw Namespace


TextureLoader.getObj Method

指定された番号のオブジェクトを構築して返す。

public override object getObj(
int no
);

Remarks

暗黙のうちにオブジェクトは構築されるが、loadはされない。 (この点、 get とは異なる)

See Also

TextureLoader Class | y4cs.draw Namespace


TextureLoader.loadFile Method

テクスチャーを読み込むための関数。LoadCacheからのオーバーライド。

protected override y4cs_result loadFile(
string filename,
ref object obj,
int option1,
int option2
);

See Also

TextureLoader Class | y4cs.draw Namespace


TextureLoader.releaseFile Method

テクスチャーを解放するための関数。LoadCacheからのオーバーライド。

protected override y4cs_result releaseFile(
ref object obj
);

See Also

TextureLoader Class | y4cs.draw Namespace


TextureVector Class

テクスチャーのvector。

For a list of all members of this type, see TextureVector Members.

System.Object
TextureVector

public class TextureVector : ITextureBase

Remarks

ひとつの文字がひとつのテクスチャーであるとき、 文字列は、textureのvectorとなる。これを管理するのがこのクラスである。

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

TextureVector Members | y4cs.draw Namespace


TextureVector Members

TextureVector overview

Public Instance Constructors

TextureVector Constructor コンストラクタ。

Public Instance Methods

add | テクスチャを連結する
blt | Overloaded. これ、めちゃくちゃ面倒くさいですなぁ．．（´Д｀）
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getHeight | テスクチャの高さを得る。
getRate | 倍率を取得する。
getTextureInfo | 内部的に保持しているテクスチャを返す。
GetType (inherited from Object) |
getWidth | テクスチャの幅を得る。
reset | リセット。
setRate | 倍率を設定する(default:1.0)。
ToString (inherited from Object) |
update | テクスチャーの構造体(TextureInfo)を更新する。

Protected Instance Fields

height | このテクスチャベクター全体でのサイズ。
infos | テクスチャーの情報(updateを呼び出した時に更新される)。
rate | このテクスチャの倍率を設定する。
width | このテクスチャベクター全体でのサイズ。

Protected Instance Methods

calcUV | 左上がd[0],右上がd[1],右下がd[2],左下がd[3]のとき、 u,vをpに返す。
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector Constructor

コンストラクタ。

public TextureVector();

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector Fields

The fields of the TextureVector class are listed below. For a complete list of TextureVector class members, see the TextureVector Members topic.

Protected Instance Fields

height | このテクスチャベクター全体でのサイズ。
infos | テクスチャーの情報(updateを呼び出した時に更新される)。
rate | このテクスチャの倍率を設定する。
width | このテクスチャベクター全体でのサイズ。

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.height Field

このテクスチャベクター全体でのサイズ。

protected float height;

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.infos Field

テクスチャーの情報(updateを呼び出した時に更新される)。

protected vector infos;

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.rate Field

このテクスチャの倍率を設定する。

protected float rate;

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.width Field

このテクスチャベクター全体でのサイズ。

protected float width;

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector Methods

The methods of the TextureVector class are listed below. For a complete list of TextureVector class members, see the TextureVector Members topic.

Public Instance Methods

add | テクスチャを連結する
blt | Overloaded. これ、めちゃくちゃ面倒くさいですなぁ．．（´Д｀）
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getHeight | テスクチャの高さを得る。
getRate | 倍率を取得する。
getTextureInfo | 内部的に保持しているテクスチャを返す。
GetType (inherited from Object) |
getWidth | テクスチャの幅を得る。
reset | リセット。
setRate | 倍率を設定する(default:1.0)。
ToString (inherited from Object) |
update | テクスチャーの構造体(TextureInfo)を更新する。

Protected Instance Methods

calcUV | 左上がd[0],右上がd[1],右下がd[2],左下がd[3]のとき、 u,vをpに返す。
Finalize (inherited from Object) |
MemberwiseClone (inherited from Object) |

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.add Method

テクスチャを連結する

public void add(
ITextureBase texture,
int x,
int y
);

Parameters

texture
x
y

Remarks

他のテクスチャを (x,y) の位置に連結する 連結後の TextureVector のサイズは、被覆部分を考慮しての最大矩形。

Example

例) 横50×縦30のTextureVectorに、横100×縦200のTextureVectorを (0,20)の位置の連結した場合、連結後のTextureVectorは、 横100×縦220のサイズ。 ITextureBase は、Texture , TextureVector の元となるクラスなので、 通常のTexture でも TextureVector でも連結できることを意味する。 x,yは負を指定しても良いが、その場合はwidth,heightには反映されない。

See Also

TextureVector Class | y4cs.draw Namespace


blt Method

Yaneurao Game Library 4th for C#

TextureVector.blt Method

Overload List

public void blt(DrawContext,float,float);

public void blt(DrawContext,float,float,ref Rect);

public void blt(DrawContext,float,float,ref Rect,ref Size);

これ、めちゃくちゃ面倒くさいですなぁ．．（´Д｀）

public void blt(DrawContext,Point[],Point[]);

public void blt(DrawContext,ref Rect,Point[]);

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.blt Method (DrawContext, Single, Single)

public void blt(
DrawContext drawContext,
float x,
float y
);

Parameters

drawContext
x
y

Implements

ITextureBase.blt

See Also

TextureVector Class | y4cs.draw Namespace | TextureVector.blt Overload List


TextureVector.blt Method (DrawContext, Single, Single, Rect)

public void blt(
DrawContext drawContext,
float x,
float y,
ref Rect srcRect
);

Parameters

drawContext
x
y
srcRect

Implements

ITextureBase.blt

See Also

TextureVector Class | y4cs.draw Namespace | TextureVector.blt Overload List


TextureVector.blt Method (DrawContext, Single, Single, Rect, Size)

public void blt(
DrawContext drawContext,
float x,
float y,
ref Rect srcRect,
ref Size dstSize
);

Parameters

drawContext
x
y
srcRect
dstSize

Implements

ITextureBase.blt

See Also

TextureVector Class | y4cs.draw Namespace | TextureVector.blt Overload List


TextureVector.blt Method (DrawContext, Point[], Point[])

これ、めちゃくちゃ面倒くさいですなぁ．．（´Д｀）

public void blt(
DrawContext src,
Point[] srcRect,
Point[] dstPoint
);

Parameters

src
srcRect
dstPoint

Implements

ITextureBase.blt

Remarks

未実装だ！　実装する予定は無い！

See Also

TextureVector Class | y4cs.draw Namespace | TextureVector.blt Overload List


TextureVector.blt Method (DrawContext, Rect, Point[])

public void blt(
DrawContext drawContext,
ref Rect srcRect,
Point[] dstPoint
);

Parameters

drawContext
srcRect
dstPoint

Implements

ITextureBase.blt

See Also

TextureVector Class | y4cs.draw Namespace | TextureVector.blt Overload List


TextureVector.calcUV Method

左上がd[0],右上がd[1],右下がd[2],左下がd[3]のとき、 u,vをpに返す。

protected void calcUV(
Point[] d,
float u,
float v,
ref Point p
);

Parameters

d
u
v
p

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.getHeight Method

テスクチャの高さを得る。

public float getHeight();

Return Value

Implements

ITextureBase.getHeight

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.getRate Method

倍率を取得する。

public float getRate();

Return Value

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.getTextureInfo Method

内部的に保持しているテクスチャを返す。

public vector getTextureInfo();

Return Value

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.getWidth Method

テクスチャの幅を得る。

public float getWidth();

Return Value

Implements

ITextureBase.getWidth

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.reset Method

リセット。

public void reset();

Remarks

内部的に保持しているテクスチャをリセットする。

            width = 0 , height = 0;
            rate = 1.0;
            infos = null;

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.setRate Method

倍率を設定する(default:1.0)。

public void setRate(
float rate_
);

Parameters

rate_

Remarks

getWidth / getHeight で返される値は、 setWidth / setHeihgt や 連結等によって得られたテクスチャサイズ から、ここで設定した倍率の掛かった値になる。 結果として描画するときにこの倍率の掛かったサイズで描画される。 連結時には、ここで設定された倍率は考慮されない。 ※　よって連結後、update前までにsetRateを呼び出して使うと良いだろう。

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.update Method

テクスチャーの構造体(TextureInfo)を更新する。

public void update();

Remarks

このメソッドを呼び出さない限り、情報は更新されないので 正しく表示されない。Texture情報を書き換えた場合、必ず最後に 呼び出すようにしてください。

See Also

TextureVector Class | y4cs.draw Namespace


TextureVector.TextureInfo Class

それぞれのテクスチャーの存在する位置を表す構造体。

For a list of all members of this type, see TextureVector.TextureInfo Members.

System.Object
TextureVector.TextureInfo

public class TextureVector.TextureInfo

Remarks

(left,top),(right,bottom)は、あるひとつのテクスチャの 存在する位置(矩形)を(sizeX,sizeY)との比率で表したもの。

なお、leftR = 1-leftである。

例) 矩形(x1,y1)-(x2,y2)に、bltしたい場合、 矩形(left*x1 + leftR*x2 , top*y1 + topR*y2) - (right*x1 + rightR*x2 , bottom*y1 + bottomR*y2) で求まる。

Requirements

Namespace: y4cs.draw

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

TextureVector.TextureInfo Members | y4cs.draw Namespace


TextureVector.TextureInfo Members

TextureVector.TextureInfo overview

Public Instance Constructors

TextureVector.TextureInfo Constructor Initializes a new instance of the TextureInfo class.

Public Instance Fields

bottom |
bottomR |
height | このテクスチャの幅。
left |
leftR |
posX | 描画位置。
posY | 描画位置。
right |
rightR |
texture | 描画すべきテクスチャー。
top |
topR |
width | このテクスチャの幅。

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo Constructor

Initializes a new instance of the TextureInfo class.

public TextureVector.TextureInfo();

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo Fields

The fields of the TextureVector.TextureInfo class are listed below. For a complete list of TextureVector.TextureInfo class members, see the TextureVector.TextureInfo Members topic.

Public Instance Fields

bottom |
bottomR |
height | このテクスチャの幅。
left |
leftR |
posX | 描画位置。
posY | 描画位置。
right |
rightR |
texture | 描画すべきテクスチャー。
top |
topR |
width | このテクスチャの幅。

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.bottom Field

public float bottom;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.bottomR Field

public float bottomR;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.height Field

このテクスチャの幅。

public float height;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.left Field

public float left;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.leftR Field

public float leftR;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.posX Field

描画位置。

public float posX;

Remarks

TextureVector.updateでは、このwidth,height,posX,posYと TextureVector.widthとheightから left,leftR,top,topR,right,rightR,bottom,bottomRを算出します。

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.posY Field

描画位置。

public float posY;

Remarks

TextureVector.updateでは、このwidth,height,posX,posYと TextureVector.widthとheightから left,leftR,top,topR,right,rightR,bottom,bottomRを算出します。

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.right Field

public float right;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.rightR Field

public float rightR;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.texture Field

描画すべきテクスチャー。

public ITextureBase texture;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.top Field

public float top;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.topR Field

public float topR;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


TextureVector.TextureInfo.width Field

このテクスチャの幅。

public float width;

See Also

TextureVector.TextureInfo Class | y4cs.draw Namespace


y4cs.input

Yaneurao Game Library 4th for C#

y4cs.input Namespace

Classes

Class | Description
Key1 | キーデバイス登録済み、仮想キー設定済みのクラスです。
Key2 | ＫｅｙＢｏａｒｄ ＋ ＪｏｙＳｔｉｃｋ判定。 → Key1も参照のこと。
Key3 | Key1 から、ジョイスティックサポートを取り除いたもの。
Key4 | Key2 から、ジョイスティックサポートを取り除いたもの。
KeyInputNullDevice | 入力系のnull device。

Interfaces

Interface | Description
KeyInputBase | 入力用の基底クラス。


Key1 Class

キーデバイス登録済み、仮想キー設定済みのクラスです。

For a list of all members of this type, see Key1 Members.

System.Object
VirtualKey
Key1

public class Key1 : VirtualKey

Remarks

ＫｅｙＢｏａｒｄ　＋　ＪｏｙＳｔｉｃｋ判定。 上下左右＋２ボタンのゲーム用。

ボタン番号 ０：ＥＳＣキー １：テンキー８，↑キー，ジョイスティック↑ ２：テンキー２，↓キー，ジョイスティック↓ ３：テンキー４，←キー，ジョイスティック← ４：テンキー２，→キー，ジョイスティック→ ５：スペースキー，ジョイスティック　ボタン１ ６：テンキーEnter,リターンキー，左シフト，右シフト。ジョイスティック　ボタン２

Example

使用例)

            //	(メインとしてSDLのフレームを用いる場合)
            int main(){
                if(SDL_Init(SDL_INIT_VIDEO)<0) {
                    printf("failed to initialize SDL.\n");
                    return -1;
                }

                SDL_SetVideoMode(640,480,16,SDL_SWSURFACE);

                Key1 key = new Key1;

                while(1){
                    SDL_Event event;
                    while(SDL_PollEvent(&event))
                    if(event.type==SDL_QUIT) {
                          SDL_Quit(); return 0; }
                    // ゲームならここで何か処理する

                    key.update();

                    for(int i=0;i<7;++i){
                        printf("%d ",key.isPress(i));
                    }
                    printf("\n");
                }
            }

Requirements

Namespace: y4cs.input

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Key1 Members | y4cs.input Namespace


Key1 Members

Key1 overview

Public Instance Constructors

Key1 Constructor Initializes a new instance of the Key1 class.

Public Instance Methods

addDevice (inherited from VirtualKey) | キーデバイスの登録。
addKey (inherited from VirtualKey) | 仮想キーの追加。
clearDevice (inherited from VirtualKey) | デバイスのクリア。
clearKeyList (inherited from VirtualKey) | 仮想キーのリセット。
delDevice (inherited from VirtualKey) |
delKey (inherited from VirtualKey) | 仮想キーの削除。
Equals (inherited from Object) |
getButtonNum (inherited from VirtualKey) |
getDevice (inherited from VirtualKey) | ｎ番目に登録したデバイスの取得。
getDeviceName (inherited from VirtualKey) |
GetHashCode (inherited from Object) |
getInfo (inherited from VirtualKey) |
GetType (inherited from Object) |
isPress (inherited from VirtualKey) |
isPush (inherited from VirtualKey) |
ToString (inherited from Object) |
update (inherited from VirtualKey) | 登録しておいたすべてのデバイスのupdateを呼び出す。

Protected Instance Fields

aDevice (inherited from VirtualKey) | 入力キーデバイスリスト。
keylist (inherited from VirtualKey) | 入力リスト。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Key1 Class | y4cs.input Namespace


Key1 Constructor

Initializes a new instance of the Key1 class.

public Key1();

See Also

Key1 Class | y4cs.input Namespace


Key2 Class

ＫｅｙＢｏａｒｄ　＋　ＪｏｙＳｔｉｃｋ判定。 →　Key1も参照のこと。

For a list of all members of this type, see Key2 Members.

System.Object
VirtualKey
Key2

public class Key2 : VirtualKey

Remarks

こちらは、上下左右＋６ボタンのゲーム用。

ボタン配置： ０：ＥＳＣキー,ジョイスティック　ボタン７，８，９ １：テンキー８，↑キー，ジョイスティック↑ ２：テンキー２，↓キー，ジョイスティック↓ ３：テンキー４，←キー，ジョイスティック← ４：テンキー２，→キー，ジョイスティック→ ５：スペースキー，Ｚキー，ジョイスティック　ボタン１ ６：テンキーEnter,リターンキー，Ｘキー，ジョイスティック　ボタン２ ７：Ｃキー，ジョイスティック　ボタン３ ８：Ａキー，ジョイスティック　ボタン４ ９：Ｓキー，ジョイスティック　ボタン５ １０：Ｄキー，ジョイスティック　ボタン６

Requirements

Namespace: y4cs.input

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Key2 Members | y4cs.input Namespace


Key2 Members

Key2 overview

Public Instance Constructors

Key2 Constructor Initializes a new instance of the Key2 class.

Public Instance Methods

addDevice (inherited from VirtualKey) | キーデバイスの登録。
addKey (inherited from VirtualKey) | 仮想キーの追加。
clearDevice (inherited from VirtualKey) | デバイスのクリア。
clearKeyList (inherited from VirtualKey) | 仮想キーのリセット。
delDevice (inherited from VirtualKey) |
delKey (inherited from VirtualKey) | 仮想キーの削除。
Equals (inherited from Object) |
getButtonNum (inherited from VirtualKey) |
getDevice (inherited from VirtualKey) | ｎ番目に登録したデバイスの取得。
getDeviceName (inherited from VirtualKey) |
GetHashCode (inherited from Object) |
getInfo (inherited from VirtualKey) |
GetType (inherited from Object) |
isPress (inherited from VirtualKey) |
isPush (inherited from VirtualKey) |
ToString (inherited from Object) |
update (inherited from VirtualKey) | 登録しておいたすべてのデバイスのupdateを呼び出す。

Protected Instance Fields

aDevice (inherited from VirtualKey) | 入力キーデバイスリスト。
keylist (inherited from VirtualKey) | 入力リスト。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Key2 Class | y4cs.input Namespace


Key2 Constructor

Initializes a new instance of the Key2 class.

public Key2();

See Also

Key2 Class | y4cs.input Namespace


Key3 Class

Key1 から、ジョイスティックサポートを取り除いたもの。

For a list of all members of this type, see Key3 Members.

System.Object
VirtualKey
Key3

public class Key3 : VirtualKey

Requirements

Namespace: y4cs.input

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Key3 Members | y4cs.input Namespace


Key3 Members

Key3 overview

Public Instance Fields

keyboard

Public Instance Methods

addDevice (inherited from VirtualKey) | キーデバイスの登録。
addKey (inherited from VirtualKey) | 仮想キーの追加。
clearDevice (inherited from VirtualKey) | デバイスのクリア。
clearKeyList (inherited from VirtualKey) | 仮想キーのリセット。
delDevice (inherited from VirtualKey) |
delKey (inherited from VirtualKey) | 仮想キーの削除。
Equals (inherited from Object) |
getButtonNum (inherited from VirtualKey) |
getDevice (inherited from VirtualKey) | ｎ番目に登録したデバイスの取得。
getDeviceName (inherited from VirtualKey) |
GetHashCode (inherited from Object) |
getInfo (inherited from VirtualKey) |
GetType (inherited from Object) |
isPress (inherited from VirtualKey) |
isPush (inherited from VirtualKey) |
ToString (inherited from Object) |
update (inherited from VirtualKey) | 登録しておいたすべてのデバイスのupdateを呼び出す。

Protected Instance Fields

aDevice (inherited from VirtualKey) | 入力キーデバイスリスト。
keylist (inherited from VirtualKey) | 入力リスト。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Key3 Class | y4cs.input Namespace


Key3 Fields

The fields of the Key3 class are listed below. For a complete list of Key3 class members, see the Key3 Members topic.

Public Instance Fields

keyboard

Protected Instance Fields

aDevice (inherited from VirtualKey) | 入力キーデバイスリスト。
keylist (inherited from VirtualKey) | 入力リスト。

See Also

Key3 Class | y4cs.input Namespace


Key3.keyboard Field

public KeyBoardInput keyboard;

See Also

Key3 Class | y4cs.input Namespace


Key4 Class

Key2 から、ジョイスティックサポートを取り除いたもの。

For a list of all members of this type, see Key4 Members.

System.Object
VirtualKey
Key4

public class Key4 : VirtualKey

Requirements

Namespace: y4cs.input

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Key4 Members | y4cs.input Namespace


Key4 Members

Key4 overview

Public Instance Constructors

Key4 Constructor Initializes a new instance of the Key4 class.

Public Instance Methods

addDevice (inherited from VirtualKey) | キーデバイスの登録。
addKey (inherited from VirtualKey) | 仮想キーの追加。
clearDevice (inherited from VirtualKey) | デバイスのクリア。
clearKeyList (inherited from VirtualKey) | 仮想キーのリセット。
delDevice (inherited from VirtualKey) |
delKey (inherited from VirtualKey) | 仮想キーの削除。
Equals (inherited from Object) |
getButtonNum (inherited from VirtualKey) |
getDevice (inherited from VirtualKey) | ｎ番目に登録したデバイスの取得。
getDeviceName (inherited from VirtualKey) |
GetHashCode (inherited from Object) |
getInfo (inherited from VirtualKey) |
GetType (inherited from Object) |
isPress (inherited from VirtualKey) |
isPush (inherited from VirtualKey) |
ToString (inherited from Object) |
update (inherited from VirtualKey) | 登録しておいたすべてのデバイスのupdateを呼び出す。

Protected Instance Fields

aDevice (inherited from VirtualKey) | 入力キーデバイスリスト。
keylist (inherited from VirtualKey) | 入力リスト。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Key4 Class | y4cs.input Namespace


Key4 Constructor

Initializes a new instance of the Key4 class.

public Key4();

See Also

Key4 Class | y4cs.input Namespace


KeyInputBase Interface

入力用の基底クラス。

For a list of all members of this type, see KeyInputBase Members.

public interface KeyInputBase

Remarks

軸入力もボタンとして扱う。 ↑:0　↓:1　←:2　→:3 1つ目のボタン:4 2つ目のボタン:5 3つ目のボタン:6..

Requirements

Namespace: y4cs.input

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

KeyInputBase Members | y4cs.input Namespace


KeyInputBase Members

KeyInputBase overview

Public Instance Methods

getButtonNum | デバイスのボタンの数。
getDeviceName | デバイス名の取得。
getInfo | デバイスの固有情報を返す。
isPress | 現在押されているか(状態はupdate関数を呼び出さないと更新されない)
isPush | 前回のupdateのときに押されていなくて、今回のupdateで押されたか。
update | 前回のupdateのときに押されていなくて、今回のupdateで押されたか。

See Also

KeyInputBase Interface | y4cs.input Namespace


KeyInputBase Methods

The methods of the KeyInputBase interface are listed below. For a complete list of KeyInputBase interface members, see the KeyInputBase Members topic.

Public Instance Methods

getButtonNum | デバイスのボタンの数。
getDeviceName | デバイス名の取得。
getInfo | デバイスの固有情報を返す。
isPress | 現在押されているか(状態はupdate関数を呼び出さないと更新されない)
isPush | 前回のupdateのときに押されていなくて、今回のupdateで押されたか。
update | 前回のupdateのときに押されていなくて、今回のupdateで押されたか。

See Also

KeyInputBase Interface | y4cs.input Namespace


KeyInputBase.getButtonNum Method

デバイスのボタンの数。

int getButtonNum();

Return Value

See Also

KeyInputBase Interface | y4cs.input Namespace


KeyInputBase.getDeviceName Method

デバイス名の取得。

string getDeviceName();

Return Value

See Also

KeyInputBase Interface | y4cs.input Namespace


KeyInputBase.getInfo Method

デバイスの固有情報を返す。

IntPtr getInfo();

Return Value

Remarks

JoyStickならば、SDL_Joystick* (SDLのJoyStickのAPIを直接呼びたいときに) KeyInputNullDeviceならばならば、null

See Also

KeyInputBase Interface | y4cs.input Namespace


KeyInputBase.isPress Method

現在押されているか(状態はupdate関数を呼び出さないと更新されない)

bool isPress(
int nButtonNo
);

Parameters

nButtonNo

Return Value

See Also

KeyInputBase Interface | y4cs.input Namespace


KeyInputBase.isPush Method

前回のupdateのときに押されていなくて、今回のupdateで押されたか。

bool isPush(
int nButtonNo
);

Parameters

nButtonNo

Return Value

See Also

KeyInputBase Interface | y4cs.input Namespace


KeyInputBase.update Method

前回のupdateのときに押されていなくて、今回のupdateで押されたか。

void update();

See Also

KeyInputBase Interface | y4cs.input Namespace


KeyInputNullDevice Class

入力系のnull device。

For a list of all members of this type, see KeyInputNullDevice Members.

System.Object
KeyInputNullDevice

public class KeyInputNullDevice : KeyInputBase

Requirements

Namespace: y4cs.input

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

KeyInputNullDevice Members | y4cs.input Namespace


KeyInputNullDevice Members

KeyInputNullDevice overview

Public Instance Constructors

KeyInputNullDevice Constructor Initializes a new instance of the KeyInputNullDevice class.

Public Instance Methods

Equals (inherited from Object)
getButtonNum
getDeviceName
GetHashCode (inherited from Object)
getInfo
GetType (inherited from Object)
isPress
isPush
ToString (inherited from Object)
update

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

KeyInputNullDevice Class | y4cs.input Namespace


KeyInputNullDevice Constructor

Initializes a new instance of the KeyInputNullDevice class.

public KeyInputNullDevice();

See Also

KeyInputNullDevice Class | y4cs.input Namespace


KeyInputNullDevice Methods

The methods of the KeyInputNullDevice class are listed below. For a complete list of KeyInputNullDevice class members, see the KeyInputNullDevice Members topic.

Public Instance Methods

Equals (inherited from Object)
getButtonNum
getDeviceName
GetHashCode (inherited from Object)
getInfo
GetType (inherited from Object)
isPress
isPush
ToString (inherited from Object)
update

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

KeyInputNullDevice Class | y4cs.input Namespace


KeyInputNullDevice.getButtonNum Method

public int getButtonNum();

Return Value

Implements

KeyInputBase.getButtonNum

See Also

KeyInputNullDevice Class | y4cs.input Namespace


KeyInputNullDevice.getDeviceName Method

public string getDeviceName();

Return Value

Implements

KeyInputBase.getDeviceName

See Also

KeyInputNullDevice Class | y4cs.input Namespace


KeyInputNullDevice.getInfo Method

public IntPtr getInfo();

Return Value

Implements

KeyInputBase.getInfo

See Also

KeyInputNullDevice Class | y4cs.input Namespace


KeyInputNullDevice.isPress Method

public bool isPress(
int nButtonNo
);

Parameters

nButtonNo

Return Value

Implements

KeyInputBase.isPress

See Also

KeyInputNullDevice Class | y4cs.input Namespace


KeyInputNullDevice.isPush Method

public bool isPush(
int nButtonNo
);

Parameters

nButtonNo

Return Value

Implements

KeyInputBase.isPush

See Also

KeyInputNullDevice Class | y4cs.input Namespace


KeyInputNullDevice.update Method

public void update();

Implements

KeyInputBase.update

See Also

KeyInputNullDevice Class | y4cs.input Namespace


y4cs.input.joystick

Yaneurao Game Library 4th for C#

y4cs.input.joystick Namespace

Classes

Class | Description
JoyStick | ジョイスティック入力クラス。


JoyStick Class

ジョイスティック入力クラス。

For a list of all members of this type, see JoyStick Members.

System.Object
JoyStick

public class JoyStick : KeyInputBase

Remarks

Joystick joy = new Joystick(0); とすれば、0番に接続されているジョイスティックにattachします。 番号は0番から始まります。ジョイスティックが接続されていない場合、 このjoy.isPush() や joy.isPress 等の入力判定関数はすべてfalseを 返すようになります。(NullDeviceとattachされる) すなわちユーザーはjoystickの有無について考える必要は、(普通は) ありません。

Requirements

Namespace: y4cs.input.joystick

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

JoyStick Members | y4cs.input.joystick Namespace


JoyStick Members

JoyStick overview

Public Static Methods

countJoyStick 接続されているjoyStickの数を返す。

Public Instance Constructors

JoyStick Constructor attachしたいJoyStickのナンバーを指定してやる。

Public Instance Methods

Equals (inherited from Object) |
getButtonNum | ボタンの数を返します。
getDeviceName | 接続されているJoyStickのdevice nameを返す。
GetHashCode (inherited from Object) |
getInfo |
GetType (inherited from Object) |
isPress | 前回のupdateのときに押されていなくて、今回のupdateで押されたか。
isPush | ボタンの入力判定。
ToString (inherited from Object) |
update | JoyStickならば、獲得したSDL_Joystick* を返す。 (SDLのJoyStickのAPIを直接呼びたいとき用)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

JoyStick Class | y4cs.input.joystick Namespace


JoyStick Constructor

attachしたいJoyStickのナンバーを指定してやる。

public JoyStick(
int nDeviceNo
);

Parameters

nDeviceNo
0～countJoyStick-1までの数

Remarks

不正な値を渡した場合は、NullDeviceが生成される (エラーにはならない)

See Also

JoyStick Class | y4cs.input.joystick Namespace


JoyStick Methods

The methods of the JoyStick class are listed below. For a complete list of JoyStick class members, see the JoyStick Members topic.

Public Static Methods

countJoyStick 接続されているjoyStickの数を返す。

Public Instance Methods

Equals (inherited from Object) |
getButtonNum | ボタンの数を返します。
getDeviceName | 接続されているJoyStickのdevice nameを返す。
GetHashCode (inherited from Object) |
getInfo |
GetType (inherited from Object) |
isPress | 前回のupdateのときに押されていなくて、今回のupdateで押されたか。
isPush | ボタンの入力判定。
ToString (inherited from Object) |
update | JoyStickならば、獲得したSDL_Joystick* を返す。 (SDLのJoyStickのAPIを直接呼びたいとき用)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

JoyStick Class | y4cs.input.joystick Namespace


JoyStick.countJoyStick Method

接続されているjoyStickの数を返す。

public static int countJoyStick();

Return Value

接続されているjoyStickの数。0 = 接続なし。

See Also

JoyStick Class | y4cs.input.joystick Namespace


JoyStick.getButtonNum Method

ボタンの数を返します。

public int getButtonNum();

Return Value

Implements

KeyInputBase.getButtonNum

Remarks

軸入力も4つのボタンと扱われているので、 戻り値は ボタンの数+4になります。

See Also

JoyStick Class | y4cs.input.joystick Namespace


JoyStick.getDeviceName Method

接続されているJoyStickのdevice nameを返す。

public string getDeviceName();

Return Value

Implements

KeyInputBase.getDeviceName

Remarks

未接続のJoyStickの場合、getDeviceName()で "KeyInputNullDevice" が返ります。

See Also

JoyStick Class | y4cs.input.joystick Namespace


JoyStick.getInfo Method

public IntPtr getInfo();

Return Value

Implements

KeyInputBase.getInfo

See Also

JoyStick Class | y4cs.input.joystick Namespace


JoyStick.isPress Method

前回のupdateのときに押されていなくて、今回のupdateで押されたか。

public bool isPress(
int nButtonNo
);

Parameters

nButtonNo

Return Value

Implements

KeyInputBase.isPress

See Also

JoyStick Class | y4cs.input.joystick Namespace


JoyStick.isPush Method

ボタンの入力判定。

public bool isPush(
int nButtonNo
);

Parameters

nButtonNo

Return Value

isPushは前回押されていなくて今回押されていればtrue。 isPressは前回の状態は関係なく、今回押されていればtrue。

Implements

KeyInputBase.isPush

Remarks

軸入力もボタンとして扱う。 ↑:0　↓:1　←:2　→:3 1つ目のボタン:4 2つ目のボタン:5 ...(以下ボタンのついている限り) これ以上の情報が欲しいならSDL_joystickを利用すべき

See Also

JoyStick Class | y4cs.input.joystick Namespace


JoyStick.update Method

JoyStickならば、獲得したSDL_Joystick* を返す。 (SDLのJoyStickのAPIを直接呼びたいとき用)

public void update();

Implements

KeyInputBase.update

Remarks

NullDeviceならば、nullを返す

See Also

JoyStick Class | y4cs.input.joystick Namespace


y4cs.input.keyboard

Yaneurao Game Library 4th for C#

y4cs.input.keyboard Namespace

Classes

Class | Description
KeyBoardInput | キー入力クラス。
VirtualKey | VirtualKey
VirtualKey.KeyInfo |

Enumerations

Enumeration | Description
KeyCode | KeyBoardInputで用いるキースキャンコード


KeyBoardInput Class

キー入力クラス。

For a list of all members of this type, see KeyBoardInput Members.

System.Object
KeyBoardInput

public class KeyBoardInput : KeyInputBase

Remarks

キーのスキャンコードはSDLのものと同等 →SDL/SDL_keysym.dを参照のこと。 →SDLのimportをしたくない場合、 このヘッダのなかにあるKeyCodeというenumを用いても良い。

関数仕様についてはJoyStickと同じなのでそちらを参照のこと。

Requirements

Namespace: y4cs.input.keyboard

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

KeyBoardInput Members | y4cs.input.keyboard Namespace


KeyBoardInput Members

KeyBoardInput overview

Public Instance Constructors

KeyBoardInput Constructor Initializes a new instance of the KeyBoardInput class.

Public Instance Methods

Equals (inherited from Object)
getButtonNum
getDeviceName
GetHashCode (inherited from Object)
getInfo
GetType (inherited from Object)
isPress
isPush
ToString (inherited from Object)
update

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

KeyBoardInput Class | y4cs.input.keyboard Namespace


KeyBoardInput Constructor

Initializes a new instance of the KeyBoardInput class.

public KeyBoardInput();

See Also

KeyBoardInput Class | y4cs.input.keyboard Namespace


KeyBoardInput Methods

The methods of the KeyBoardInput class are listed below. For a complete list of KeyBoardInput class members, see the KeyBoardInput Members topic.

Public Instance Methods

Equals (inherited from Object)
getButtonNum
getDeviceName
GetHashCode (inherited from Object)
getInfo
GetType (inherited from Object)
isPress
isPush
ToString (inherited from Object)
update

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

KeyBoardInput Class | y4cs.input.keyboard Namespace


KeyBoardInput.getButtonNum Method

public int getButtonNum();

Return Value

Implements

KeyInputBase.getButtonNum

See Also

KeyBoardInput Class | y4cs.input.keyboard Namespace


KeyBoardInput.getDeviceName Method

public string getDeviceName();

Return Value

Implements

KeyInputBase.getDeviceName

See Also

KeyBoardInput Class | y4cs.input.keyboard Namespace


KeyBoardInput.getInfo Method

public IntPtr getInfo();

Return Value

Implements

KeyInputBase.getInfo

See Also

KeyBoardInput Class | y4cs.input.keyboard Namespace


KeyBoardInput.isPress Method

public bool isPress(
int nButtonNo
);

Parameters

nButtonNo

Return Value

Implements

KeyInputBase.isPress

See Also

KeyBoardInput Class | y4cs.input.keyboard Namespace


KeyBoardInput.isPush Method

public bool isPush(
int nButtonNo
);

Parameters

nButtonNo

Return Value

Implements

KeyInputBase.isPush

See Also

KeyBoardInput Class | y4cs.input.keyboard Namespace


KeyBoardInput.update Method

public void update();

Implements

KeyInputBase.update

Remarks

SDLのSDL_PumpEventsを定期的に呼び出していることを前提とする。 ここで得られるのは前回のSDL_PumpEventsを呼び出してからの 入力情報である。

また、キー入力には、 SDL_SetVideoMode(640,480,16,SDL_SWSURFACE); に相当する命令で、SDLのウィンドゥを初期化してある必要がある。 (キー入力は、ウィンドゥに付帯するものなので)

See Also

KeyBoardInput Class | y4cs.input.keyboard Namespace


KeyCode Enumeration

KeyBoardInputで用いるキースキャンコード

public enum KeyCode

Members

Member Name | Description
UNKNOWN |
FIRST |
BACKSPACE |
TAB |
CLEAR |
RETURN |
PAUSE |
ESCAPE |
SPACE |
EXCLAIM |
QUOTEDBL |
HASH |
DOLLAR |
AMPERSAND |
QUOTE |
LEFTPAREN |
RIGHTPAREN |
ASTERISK |
PLUS |
COMMA |
MINUS |
PERIOD |
SLASH |
KEY0 |
KEY1 |
KEY2 |
KEY3 |
KEY4 |
KEY5 |
KEY6 |
KEY7 |
KEY8 |
KEY9 |
COLON |
SEMICOLON |
LESS |
EQUALS |
GREATER |
QUESTION |
AT |
LEFTBRACKET |
BACKSLASH |
RIGHTBRACKET |
CARET |
UNDERSCORE |
BACKQUOTE |
a |
b |
c |
d |
e |
f |
g |
h |
i |
j |
k |
l |
m |
n |
o |
p |
q |
r |
s |
t |
u |
v |
w |
x |
y |
z |
DELETE |
WORLD_0 |
WORLD_1 |
WORLD_2 |
WORLD_3 |
WORLD_4 |
WORLD_5 |
WORLD_6 |
WORLD_7 |
WORLD_8 |
WORLD_9 |
WORLD_10 |
WORLD_11 |
WORLD_12 |
WORLD_13 |
WORLD_14 |
WORLD_15 |
WORLD_16 |
WORLD_17 |
WORLD_18 |
WORLD_19 |
WORLD_20 |
WORLD_21 |
WORLD_22 |
WORLD_23 |
WORLD_24 |
WORLD_25 |
WORLD_26 |
WORLD_27 |
WORLD_28 |
WORLD_29 |
WORLD_30 |
WORLD_31 |
WORLD_32 |
WORLD_33 |
WORLD_34 |
WORLD_35 |
WORLD_36 |
WORLD_37 |
WORLD_38 |
WORLD_39 |
WORLD_40 |
WORLD_41 |
WORLD_42 |
WORLD_43 |
WORLD_44 |
WORLD_45 |
WORLD_46 |
WORLD_47 |
WORLD_48 |
WORLD_49 |
WORLD_50 |
WORLD_51 |
WORLD_52 |
WORLD_53 |
WORLD_54 |
WORLD_55 |
WORLD_56 |
WORLD_57 |
WORLD_58 |
WORLD_59 |
WORLD_60 |
WORLD_61 |
WORLD_62 |
WORLD_63 |
WORLD_64 |
WORLD_65 |
WORLD_66 |
WORLD_67 |
WORLD_68 |
WORLD_69 |
WORLD_70 |
WORLD_71 |
WORLD_72 |
WORLD_73 |
WORLD_74 |
WORLD_75 |
WORLD_76 |
WORLD_77 |
WORLD_78 |
WORLD_79 |
WORLD_80 |
WORLD_81 |
WORLD_82 |
WORLD_83 |
WORLD_84 |
WORLD_85 |
WORLD_86 |
WORLD_87 |
WORLD_88 |
WORLD_89 |
WORLD_90 |
WORLD_91 |
WORLD_92 |
WORLD_93 |
WORLD_94 |
WORLD_95 |
KP0 |
KP1 |
KP2 |
KP3 |
KP4 |
KP5 |
KP6 |
KP7 |
KP8 |
KP9 |
KP_PERIOD |
KP_DIVIDE |
KP_MULTIPLY |
KP_MINUS |
KP_PLUS |
KP_ENTER |
KP_EQUALS |
UP |
DOWN |
RIGHT |
LEFT |
INSERT |
HOME |
END |
PAGEUP |
PAGEDOWN |
F1 |
F2 |
F3 |
F4 |
F5 |
F6 |
F7 |
F8 |
F9 |
F10 |
F11 |
F12 |
F13 |
F14 |
F15 |
NUMLOCK |
CAPSLOCK |
SCROLLOCK |
RSHIFT |
LSHIFT |
RCTRL |
LCTRL |
RALT |
LALT |
RMETA |
LMETA |
LSUPER | Left "Windows" key
RSUPER | Right "Windows" key
MODE | "Alt Gr" key
COMPOSE | Multi-key compose key
HELP |
PRINT |
SYSREQ |
BREAK |
MENU |
POWER | Power Macintosh power key
EURO | Some european keyboards
UNDO | Atari keyboard has Undo
LAST |

Requirements

Namespace: y4cs.input.keyboard

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

y4cs.input.keyboard Namespace


VirtualKey Class

VirtualKey

For a list of all members of this type, see VirtualKey Members.

System.Object
VirtualKey

public class VirtualKey : KeyInputBase

Remarks

統合キー入力クラス。CKeyBaseの派生クラスを利用して、 それらをひとまとめにして管理できる。

たとえば、キーボードの↑キーと、テンキーの８キー、 ジョイスティックの↑入力を、一つの仮想キーとして登録することによって、 それらのどれか一つが入力されているかを、関数をひとつ呼び出すだけで 判定できるようになる。

実際にKey1,Key2,Key3,Key4は、 このクラスの応用事例なので、そちらも参照すること。

全体的な流れは、キーデバイスの登録→仮想キーの設定としておいて、 InputしたのちisPress/isPushで判定します。

Requirements

Namespace: y4cs.input.keyboard

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

VirtualKey Members | y4cs.input.keyboard Namespace


VirtualKey Members

VirtualKey overview

Public Static Fields

VIRTUAL_KEY_MAX 仮想キーの最大個数。88鍵（＾＾；

Public Instance Constructors

VirtualKey Constructor Initializes a new instance of the VirtualKey class.

Public Instance Methods

addDevice | キーデバイスの登録。
addKey | 仮想キーの追加。
clearDevice | デバイスのクリア。
clearKeyList | 仮想キーのリセット。
delDevice |
delKey | 仮想キーの削除。
Equals (inherited from Object) |
getButtonNum |
getDevice | ｎ番目に登録したデバイスの取得。
getDeviceName |
GetHashCode (inherited from Object) |
getInfo |
GetType (inherited from Object) |
isPress |
isPush |
ToString (inherited from Object) |
update | 登録しておいたすべてのデバイスのupdateを呼び出す。

Protected Instance Fields

aDevice | 入力キーデバイスリスト。
keylist | 入力リスト。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey Constructor

Initializes a new instance of the VirtualKey class.

public VirtualKey();

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey Fields

The fields of the VirtualKey class are listed below. For a complete list of VirtualKey class members, see the VirtualKey Members topic.

Public Static Fields

VIRTUAL_KEY_MAX 仮想キーの最大個数。88鍵（＾＾；

Protected Instance Fields

aDevice | 入力キーデバイスリスト。
keylist | 入力リスト。

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.aDevice Field

入力キーデバイスリスト。

protected vector aDevice;

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.keylist Field

入力リスト。

protected vector[] keylist;

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.VIRTUAL_KEY_MAX Field

仮想キーの最大個数。88鍵（＾＾；

public const int VIRTUAL_KEY_MAX;

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey Methods

The methods of the VirtualKey class are listed below. For a complete list of VirtualKey class members, see the VirtualKey Members topic.

Public Instance Methods

addDevice | キーデバイスの登録。
addKey | 仮想キーの追加。
clearDevice | デバイスのクリア。
clearKeyList | 仮想キーのリセット。
delDevice |
delKey | 仮想キーの削除。
Equals (inherited from Object) |
getButtonNum |
getDevice | ｎ番目に登録したデバイスの取得。
getDeviceName |
GetHashCode (inherited from Object) |
getInfo |
GetType (inherited from Object) |
isPress |
isPush |
ToString (inherited from Object) |
update | 登録しておいたすべてのデバイスのupdateを呼び出す。

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.addDevice Method

キーデバイスの登録。

public void addDevice(
KeyInputBase device
);

Parameters

device

Remarks

キーデバイスとは、KeyInputBaseの派生クラスのインスタンス。 具体的にはKeyInput,JoyStick,MidiInputのインスタンスが 挙げられる。入力したいキーデバイスをまず登録する。 そしてInputを呼び出すことによって、それらのGetStateが呼び出される。

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.addKey Method

仮想キーの追加。

public void addKey(
int vkey,
int nDeviceNo,
int key
);

Parameters

vkey
nDeviceNo
key

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.clearDevice Method

デバイスのクリア。

public void clearDevice();

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.clearKeyList Method

仮想キーのリセット。

public void clearKeyList();

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.delDevice Method

public void delDevice(
KeyInputBase device
);

Parameters

device

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.delKey Method

仮想キーの削除。

public void delKey(
int vkey,
int nDeviceNo,
int key
);

Parameters

vkey
nDeviceNo
key

Remarks

vkeyは、仮想キー番号。これは0～VIRTUAL_KEY_MAX-1 (現在88とdefineされている)番まで登録可能。 キーデバイスnDeviceNoは、GetDeviceで指定するナンバーと同じもの。 keyは、そのキーデバイスのkeyナンバー。

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.getButtonNum Method

public int getButtonNum();

Return Value

Implements

KeyInputBase.getButtonNum

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.getDevice Method

ｎ番目に登録したデバイスの取得。

public KeyInputBase getDevice(
int n
);

Parameters

n

Return Value

Remarks

この関数を使えばｎ番目（０から始まる）のaddDeviceしたデバイスを 取得できる。）

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.getDeviceName Method

public string getDeviceName();

Return Value

Implements

KeyInputBase.getDeviceName

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.getInfo Method

public IntPtr getInfo();

Return Value

Implements

KeyInputBase.getInfo

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.isPress Method

public bool isPress(
int nKey
);

Parameters

nKey

Return Value

Implements

KeyInputBase.isPress

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.isPush Method

public bool isPush(
int nKey
);

Parameters

nKey

Return Value

Implements

KeyInputBase.isPush

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.update Method

登録しておいたすべてのデバイスのupdateを呼び出す。

public void update();

Implements

KeyInputBase.update

See Also

VirtualKey Class | y4cs.input.keyboard Namespace


VirtualKey.KeyInfo Class

For a list of all members of this type, see VirtualKey.KeyInfo Members.

System.Object
VirtualKey.KeyInfo

protected class VirtualKey.KeyInfo

Requirements

Namespace: y4cs.input.keyboard

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

VirtualKey.KeyInfo Members | y4cs.input.keyboard Namespace


VirtualKey.KeyInfo Members

VirtualKey.KeyInfo overview

Public Instance Constructors

VirtualKey.KeyInfo Constructor

Public Instance Fields

deviceNo_
keyNo_

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

VirtualKey.KeyInfo Class | y4cs.input.keyboard Namespace


VirtualKey.KeyInfo Constructor

public VirtualKey.KeyInfo(
int deviceNo,
int keyNo
);

Parameters

deviceNo
keyNo

See Also

VirtualKey.KeyInfo Class | y4cs.input.keyboard Namespace


VirtualKey.KeyInfo Fields

The fields of the VirtualKey.KeyInfo class are listed below. For a complete list of VirtualKey.KeyInfo class members, see the VirtualKey.KeyInfo Members topic.

Public Instance Fields

deviceNo_
keyNo_

See Also

VirtualKey.KeyInfo Class | y4cs.input.keyboard Namespace


VirtualKey.KeyInfo.deviceNo_ Field

public int deviceNo_;

See Also

VirtualKey.KeyInfo Class | y4cs.input.keyboard Namespace


VirtualKey.KeyInfo.keyNo_ Field

public int keyNo_;

See Also

VirtualKey.KeyInfo Class | y4cs.input.keyboard Namespace


y4cs.math

Yaneurao Game Library 4th for C#

y4cs.math Namespace

Classes

Class | Description
Rand | Rand
Round | Round の概要の説明です。
SinTable | SinTable

Structures

Structure | Description
vector2D | 2次元vectorライブラリ
vector3D | 3次元vectorライブラリ


Rand Class

Rand

For a list of all members of this type, see Rand Members.

System.Object
Rand

public class Rand

Remarks

Mersenne Twister法による高精度の乱数発生ルーチンです。 2^19937-1という天文学的な大きさの周期性を持った乱数を高速に生成します。

Requirements

Namespace: y4cs.math

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Rand Members | y4cs.math Namespace


Rand Members

Rand overview

Public Instance Constructors

Rand Overloaded. Initializes a new instance of the Rand class.

Public Instance Methods

Equals (inherited from Object) |
get | Overloaded. 乱数の取得。前者はDWORD全域の乱数を取得。 後者は、0～n-1までの乱数を取得。 n==0の場合は0が返る(このほうが使いやすいので)
get1 |
get2 |
get3 |
get4 |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
randomize | 乱数の種として、現在時刻を与えます。
setSeed | 乱数の種の設定。必ず一度呼び出す必要がある。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Rand Class | y4cs.math Namespace


Rand Constructor

コンストラクタ。

Overload List

コンストラクタ。

public Rand();

コンストラクタ。

public Rand(uint);

See Also

Rand Class | y4cs.math Namespace


Rand Constructor ()

コンストラクタ。

public Rand();

See Also

Rand Class | y4cs.math Namespace | Rand Constructor Overload List


Rand Constructor (UInt32)

コンストラクタ。

public Rand(
uint dwSeed
);

Parameters

dwSeed

Remarks

コンストラクタは、２種類あり、パラメータ無しのほうは、 乱数の初期化を行ないません。パラメータ有りのほうは、 乱数の種を引数として取り、それに基づいた乱数を生成します。 （内部的にSetSeedを行なうということです。 よって、SetSeedをこのあと行なう必要はありません） 前回と同じ乱数系列を再現したい場合などにこれを使います。

See Also

Rand Class | y4cs.math Namespace | Rand Constructor Overload List


Rand Methods

The methods of the Rand class are listed below. For a complete list of Rand class members, see the Rand Members topic.

Public Instance Methods

Equals (inherited from Object) |
get | Overloaded. 乱数の取得。前者はDWORD全域の乱数を取得。 後者は、0～n-1までの乱数を取得。 n==0の場合は0が返る(このほうが使いやすいので)
get1 |
get2 |
get3 |
get4 |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
randomize | 乱数の種として、現在時刻を与えます。
setSeed | 乱数の種の設定。必ず一度呼び出す必要がある。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Rand Class | y4cs.math Namespace


get Method

Yaneurao Game Library 4th for C#

Rand.get Method

Overload List

public uint get();

乱数の取得。前者はDWORD全域の乱数を取得。 後者は、0～n-1までの乱数を取得。 n==0の場合は0が返る(このほうが使いやすいので)

public uint get(uint);

See Also

Rand Class | y4cs.math Namespace


Rand.get Method ()

public uint get();

Return Value

See Also

Rand Class | y4cs.math Namespace | Rand.get Overload List


Rand.get Method (UInt32)

乱数の取得。前者はDWORD全域の乱数を取得。 後者は、0～n-1までの乱数を取得。 n==0の場合は0が返る(このほうが使いやすいので)

public uint get(
uint n
);

Parameters

n

Return Value

See Also

Rand Class | y4cs.math Namespace | Rand.get Overload List


Rand.get1 Method

public double get1();

Return Value

See Also

Rand Class | y4cs.math Namespace


Rand.get2 Method

public double get2();

Return Value

See Also

Rand Class | y4cs.math Namespace


Rand.get3 Method

public double get3();

Return Value

See Also

Rand Class | y4cs.math Namespace


Rand.get4 Method

public double get4();

Return Value

See Also

Rand Class | y4cs.math Namespace


Rand.randomize Method

乱数の種として、現在時刻を与えます。

public void randomize();

Remarks

要するに、再現性の無い乱数が出来ます。 setSeed(タイマーの値)とやっているので、 setSeedを呼び出す必要はありません。

See Also

Rand Class | y4cs.math Namespace


Rand.setSeed Method

乱数の種の設定。必ず一度呼び出す必要がある。

public void setSeed(
uint dwSeed
);

Parameters

dwSeed

Remarks

乱数の種を設定します。設定された種に従って、乱数は生成されていきます。 必ず一度は呼び出す必要があります。 呼び出さないときは、 SetSeed(4357); が、一番最初の乱数取得のときに実行されます。

See Also

Rand Class | y4cs.math Namespace


Round Class

Round の概要の説明です。

For a list of all members of this type, see Round Members.

System.Object
Round

public abstract class Round

Requirements

Namespace: y4cs.math

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Round Members | y4cs.math Namespace


Round Members

Round overview

Public Static Methods

Div | Overloaded. 丸め(四捨五入)つきの割り算。
RShift | Overloaded. 丸め(四捨五入)つきの右シフト。tをnRShiftCountだけ右シフトして返す。

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

Round Constructor Initializes a new instance of the Round class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Round Class | y4cs.math Namespace


Round Constructor

Initializes a new instance of the Round class.

protected Round();

See Also

Round Class | y4cs.math Namespace


Round Methods

The methods of the Round class are listed below. For a complete list of Round class members, see the Round Members topic.

Public Static Methods

Div | Overloaded. 丸め(四捨五入)つきの割り算。
RShift | Overloaded. 丸め(四捨五入)つきの右シフト。tをnRShiftCountだけ右シフトして返す。

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Round Class | y4cs.math Namespace


Div Method

Yaneurao Game Library 4th for C#

Round.Div Method

Overload List

public static byte Div(byte,byte);

public static short Div(short,short);

丸め(四捨五入)つきの割り算。

public static int Div(int,int);

public static long Div(long,long);

See Also

Round Class | y4cs.math Namespace


Round.Div Method (Byte, Byte)

public static byte Div(
byte x,
byte y
);

Parameters

x
y

Return Value

See Also

Round Class | y4cs.math Namespace | Round.Div Overload List


Round.Div Method (Int16, Int16)

public static short Div(
short x,
short y
);

Parameters

x
y

Return Value

See Also

Round Class | y4cs.math Namespace | Round.Div Overload List


Round.Div Method (Int32, Int32)

丸め(四捨五入)つきの割り算。

public static int Div(
int x,
int y
);

Parameters

x
y

Return Value

Remarks

r = x/yを返す。xが負数のときも正しく答えが返る。
round.Div(4/3) = 1 , round.Div(-4,3) = -1
round.Div(3/2) = 2 , round.Div(-3,2) = -2(-1ではないことに注意)

See Also

Round Class | y4cs.math Namespace | Round.Div Overload List


Round.Div Method (Int64, Int64)

public static long Div(
long x,
long y
);

Parameters

x
y

Return Value

See Also

Round Class | y4cs.math Namespace | Round.Div Overload List


RShift Method

Yaneurao Game Library 4th for C#

Round.RShift Method

Overload List

public static byte RShift(byte,int);

public static short RShift(short,int);

丸め(四捨五入)つきの右シフト。tをnRShiftCountだけ右シフトして返す。

public static int RShift(int,int);

public static long RShift(long,int);

See Also

Round Class | y4cs.math Namespace


Round.RShift Method (Byte, Int32)

public static byte RShift(
byte t,
int nRShiftCount
);

Parameters

t
nRShiftCount

Return Value

See Also

Round Class | y4cs.math Namespace | Round.RShift Overload List


Round.RShift Method (Int16, Int32)

public static short RShift(
short t,
int nRShiftCount
);

Parameters

t
nRShiftCount

Return Value

See Also

Round Class | y4cs.math Namespace | Round.RShift Overload List


Round.RShift Method (Int32, Int32)

丸め(四捨五入)つきの右シフト。tをnRShiftCountだけ右シフトして返す。

public static int RShift(
int t,
int nRShiftCount
);

Parameters

t
nRShiftCount

Return Value

Remarks

正と負の対称性を考えると、負数に関しては四捨五入の“入” の場合は 0から遠い方の整数に行って欲しい気がします。 負数の四捨五入について議論されるのをほとんど見たことが 無いのですが、そのほうが自然でしょう。ここで四捨五入 と言うとき、この定義に基づくものとします。また、 この定義に基づくと、-3.5は四捨五入されて-4になるべきで しょうし、-3.4ならば四捨五入の“捨”で、-3になるべきです。

逆にこうならなければ、sin,cosで円を描くときに非対称(3.5は 4になるのに-3.5は-4になる)ので歪んだものになる可能性があります。

See Also

Round Class | y4cs.math Namespace | Round.RShift Overload List


Round.RShift Method (Int64, Int32)

public static long RShift(
long t,
int nRShiftCount
);

Parameters

t
nRShiftCount

Return Value

See Also

Round Class | y4cs.math Namespace | Round.RShift Overload List


SinTable Class

SinTable

For a list of all members of this type, see SinTable Members.

System.Object
SinTable

public class SinTable

Requirements

Namespace: y4cs.math

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SinTable Members | y4cs.math Namespace


SinTable Members

SinTable overview

Public Static Methods

get

Public Instance Constructors

SinTable Constructor Initializes a new instance of the SinTable class.

Public Instance Methods

atan | arctanを求める。C言語のatan2と同じ。結果は0-65535(1周が65536)。
cos | Overloaded. cosを求める。n:0-511で一周。結果は<16されて返る。
cos_d | cos(n)を浮動小数で返す。n:0-511で一周。
cos0_1 | 1.0-cos1_0を返す関数。
cos1_0 | 0.5+cos(n)*0.5を浮動小数で返す。n:0-511で一周。
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
sin | Overloaded. sinを求める。n:0-511で一周。結果は<<16されて返る。
sin_d | sin(n)を浮動小数で返す。n:0-511で一周。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SinTable Class | y4cs.math Namespace


SinTable Constructor

Initializes a new instance of the SinTable class.

public SinTable();

See Also

SinTable Class | y4cs.math Namespace


SinTable Methods

The methods of the SinTable class are listed below. For a complete list of SinTable class members, see the SinTable Members topic.

Public Static Methods

get

Public Instance Methods

atan | arctanを求める。C言語のatan2と同じ。結果は0-65535(1周が65536)。
cos | Overloaded. cosを求める。n:0-511で一周。結果は<16されて返る。
cos_d | cos(n)を浮動小数で返す。n:0-511で一周。
cos0_1 | 1.0-cos1_0を返す関数。
cos1_0 | 0.5+cos(n)*0.5を浮動小数で返す。n:0-511で一周。
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
sin | Overloaded. sinを求める。n:0-511で一周。結果は<<16されて返る。
sin_d | sin(n)を浮動小数で返す。n:0-511で一周。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SinTable Class | y4cs.math Namespace


SinTable.atan Method

arctanを求める。C言語のatan2と同じ。結果は0-65535(1周が65536)。

public ushort atan(
int x,
int y
);

Parameters

x
y

Return Value

Remarks

高速なArcTanを提供。C言語のatan2と同じ。 結果は0-65535(1周が65536) (x,y)が(0,0)のときは Y4D_Error が throwされる throwされて嫌なら、事前にチェックしる！

See Also

SinTable Class | y4cs.math Namespace


cos Method

Yaneurao Game Library 4th for C#

SinTable.cos Method

cosを求める。n:0-511で一周。結果は<16されて返る。

Overload List

cosを求める。n:0-511で一周。結果は<16されて返る。

public int cos(int);

cos(n)*r の整数部を返す。n:0-511で一周。(小数部丸めあり)。

public int cos(int,int);

See Also

SinTable Class | y4cs.math Namespace


SinTable.cos Method (Int32)

cosを求める。n:0-511で一周。結果は<16されて返る。

public int cos(
int n
);

Parameters

n

Return Value

See Also

SinTable Class | y4cs.math Namespace | SinTable.cos Overload List


SinTable.cos Method (Int32, Int32)

cos(n)*r の整数部を返す。n:0-511で一周。(小数部丸めあり)。

public int cos(
int n,
int r
);

Parameters

n
r

Return Value

See Also

SinTable Class | y4cs.math Namespace | SinTable.cos Overload List


SinTable.cos_d Method

cos(n)を浮動小数で返す。n:0-511で一周。

public double cos_d(
int n
);

Parameters

n

Return Value

See Also

SinTable Class | y4cs.math Namespace


SinTable.cos0_1 Method

1.0-cos1_0を返す関数。

public double cos0_1(
int n
);

Parameters

n

Return Value

Remarks

0からはじまり1との間をいったりきたりするのに使うと便利。

See Also

SinTable Class | y4cs.math Namespace


SinTable.cos1_0 Method

0.5+cos(n)*0.5を浮動小数で返す。n:0-511で一周。

public double cos1_0(
int n
);

Parameters

n

Return Value

Remarks

1からはじまり0との間をいったりきたりするのに便利。

See Also

SinTable Class | y4cs.math Namespace


SinTable.get Method

public static SinTable get();

Return Value

See Also

SinTable Class | y4cs.math Namespace


sin Method

Yaneurao Game Library 4th for C#

SinTable.sin Method

sinを求める。n:0-511で一周。結果は<<16されて返る。

Overload List

sinを求める。n:0-511で一周。結果は<<16されて返る。

public int sin(int);

sin(n)*r の整数部を返す。n:0-511で一周。(小数部丸めあり)。

public int sin(int,int);

See Also

SinTable Class | y4cs.math Namespace


SinTable.sin Method (Int32)

sinを求める。n:0-511で一周。結果は<<16されて返る。

public int sin(
int n
);

Parameters

n

Return Value

See Also

SinTable Class | y4cs.math Namespace | SinTable.sin Overload List


SinTable.sin Method (Int32, Int32)

sin(n)*r の整数部を返す。n:0-511で一周。(小数部丸めあり)。

public int sin(
int n,
int r
);

Parameters

n
r

Return Value

See Also

SinTable Class | y4cs.math Namespace | SinTable.sin Overload List


SinTable.sin_d Method

sin(n)を浮動小数で返す。n:0-511で一周。

public double sin_d(
int n
);

Parameters

n

Return Value

See Also

SinTable Class | y4cs.math Namespace


vector2D Structure

2次元vectorライブラリ

For a list of all members of this type, see vector2D Members.

System.Object
ValueType
vector2D

public struct vector2D

Requirements

Namespace: y4cs.math

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

vector2D Members | y4cs.math Namespace


vector2D Members

vector2D overview

Public Static Operators

Addition Operator |
Division Operator | Overloaded.
Equality Operator | operator ==
Inequality Operator | operator !=
Multiplication Operator | Overloaded.
Subtraction Operator |

Public Instance Constructors

vector2D Overloaded. Initializes a new instance of the vector2D class.

Public Instance Fields

x
y

Public Instance Methods

add
dist
div
Equals
GetHashCode
GetType (inherited from Object)
innerProduct
mul
outerProduct
set
size
size2
sub
ToString

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

vector2D Class | y4cs.math Namespace


vector2D Constructor

Overload List

public vector2D(double,double);

public vector2D(vector2D);

See Also

vector2D Class | y4cs.math Namespace


vector2D Constructor (Double, Double)

public vector2D(
double x_,
double y_
);

See Also

vector2D Class | y4cs.math Namespace | vector2D Constructor Overload List


vector2D Constructor (vector2D)

public vector2D(
vector2D v
);

See Also

vector2D Class | y4cs.math Namespace | vector2D Constructor Overload List


vector2D Fields

The fields of the vector2D structure are listed below. For a complete list of vector2D structure members, see the vector2D Members topic.

Public Instance Fields

x
y

See Also

vector2D Class | y4cs.math Namespace


vector2D.x Field

public double x;

See Also

vector2D Class | y4cs.math Namespace


vector2D.y Field

public double y;

See Also

vector2D Class | y4cs.math Namespace


vector2D Methods

The methods of the vector2D structure are listed below. For a complete list of vector2D structure members, see the vector2D Members topic.

Public Instance Methods

add
dist
div
Equals
GetHashCode
GetType (inherited from Object)
innerProduct
mul
outerProduct
set
size
size2
sub
ToString

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

vector2D Class | y4cs.math Namespace


vector2D.add Method

public void add(
vector2D v
);

See Also

vector2D Class | y4cs.math Namespace


vector2D.dist Method

public double dist(
vector2D v
);

See Also

vector2D Class | y4cs.math Namespace


vector2D.div Method

public void div(
double a
);

See Also

vector2D Class | y4cs.math Namespace


vector2D.Equals Method

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

vector2D Class | y4cs.math Namespace


vector2D.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

vector2D Class | y4cs.math Namespace


vector2D.innerProduct Method

public double innerProduct(
vector2D v
);

See Also

vector2D Class | y4cs.math Namespace


vector2D.mul Method

public void mul(
double a
);

See Also

vector2D Class | y4cs.math Namespace


vector2D.outerProduct Method

public double outerProduct(
vector2D v
);

See Also

vector2D Class | y4cs.math Namespace


vector2D.set Method

public void set(
double x_,
double y_
);

See Also

vector2D Class | y4cs.math Namespace


vector2D.size Method

public double size();

See Also

vector2D Class | y4cs.math Namespace


vector2D.size2 Method

public double size2();

See Also

vector2D Class | y4cs.math Namespace


vector2D.sub Method

public void sub(
vector2D v
);

See Also

vector2D Class | y4cs.math Namespace


vector2D.ToString Method

public override string ToString();

Return Value

Remarks

「(5,10)」のようにベクトルを文字列化して返す↓この関数が無いのよ.. char[] toString() { return "(" ~ atof(x) ~ "," ~ atof(y) ~ ")"; }

See Also

vector2D Class | y4cs.math Namespace


vector2D Operators

The operators of the vector2D structure are listed below. For a complete list of vector2D structure members, see the vector2D Members topic.

Public Static Operators

Addition Operator |
Division Operator | Overloaded.
Equality Operator | operator ==
Inequality Operator | operator !=
Multiplication Operator | Overloaded.
Subtraction Operator |

See Also

vector2D Class | vector2D Members | y4cs.math Namespace


vector2D Addition Operator

public static vector2D operator +(
vector2D a,
vector2D b
);

See Also

vector2D Class | y4cs.math Namespace


vector2D Division Operator

Overload List

public static vector2D Division Operator(vector2D,double);

public static double Division Operator(vector2D,vector2D);

See Also

vector2D Class | y4cs.math Namespace


vector2D Division Operator

public static vector2D operator /(
vector2D a,
double b
);

See Also

vector2D Class | y4cs.math Namespace | vector2D Division Operator Overload List


vector2D Division Operator

public static double operator /(
vector2D a,
vector2D b
);

See Also

vector2D Class | y4cs.math Namespace | vector2D Division Operator Overload List


vector2D Equality Operator

operator ==

public static bool operator ==(
vector2D a,
vector2D b
);

Parameters

a
b

Return Value

See Also

vector2D Class | y4cs.math Namespace


vector2D Inequality Operator

operator !=

public static bool operator !=(
vector2D a,
vector2D b
);

Parameters

a
b

Return Value

See Also

vector2D Class | y4cs.math Namespace


vector2D Multiplication Operator

Overload List

public static vector2D Multiplication Operator(vector2D,double);

public static double Multiplication Operator(vector2D,vector2D);

See Also

vector2D Class | y4cs.math Namespace


vector2D Multiplication Operator

public static vector2D operator *(
vector2D a,
double b
);

See Also

vector2D Class | y4cs.math Namespace | vector2D Multiplication Operator Overload List


vector2D Multiplication Operator

public static double operator *(
vector2D a,
vector2D b
);

See Also

vector2D Class | y4cs.math Namespace | vector2D Multiplication Operator Overload List


vector2D Subtraction Operator

public static vector2D operator -(
vector2D a,
vector2D b
);

See Also

vector2D Class | y4cs.math Namespace


vector3D Structure

3次元vectorライブラリ

For a list of all members of this type, see vector3D Members.

System.Object
ValueType
vector3D

public struct vector3D

Remarks

注意：このクラスは高速化のため、将来、structにするかも知れない。

Requirements

Namespace: y4cs.math

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

vector3D Members | y4cs.math Namespace


vector3D Members

vector3D overview

Public Static Operators

Addition Operator | + 和。
Division Operator | Overloaded. / 外積。
Equality Operator | operator ==
Inequality Operator | operator !=
Multiplication Operator | Overloaded. * 内積。
Subtraction Operator | - 差。

Public Instance Constructors

vector3D Overloaded. Initializes a new instance of the vector3D class.

Public Instance Fields

x | 保持しているベクター(x,y,z)。
y | 保持しているベクター(x,y,z)。
z | 保持しているベクター(x,y,z)。

Public Instance Methods

add | 他のベクトルを加算する。
dist | 近似による距離(絶対値)の算出。sqrtを使っていない分だけ速い。
div | スカラー値で除算する。
Equals |
GetHashCode |
GetType (inherited from Object) |
innerProduct | 内積を求める。
mul | スカラー値を乗算する。
outerProduct | 外積を求める(3次元の外積の結果はベクトル)。
set | (x,y,z)を設定するsetter。
size | 絶対値を求める(sqrtが入るので遅い)。
size2 | 絶対値の二乗を求める(大小比較をする目的ならこちらで十分)。
sub | 他のベクトルを減算する。
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

vector3D Class | y4cs.math Namespace


vector3D Constructor

変数x,yを初期化するコンストラクタ。

Overload List

変数x,yを初期化するコンストラクタ。

public vector3D(double,double,double);

他のvectorで初期化するためのコンストラクタ。

public vector3D(vector3D);

See Also

vector3D Class | y4cs.math Namespace


vector3D Constructor (Double, Double, Double)

変数x,yを初期化するコンストラクタ。

public vector3D(
double x_,
double y_,
double z_
);

Parameters

x_
y_
z_

See Also

vector3D Class | y4cs.math Namespace | vector3D Constructor Overload List


vector3D Constructor (vector3D)

他のvectorで初期化するためのコンストラクタ。

public vector3D(
vector3D v
);

Parameters

v

See Also

vector3D Class | y4cs.math Namespace | vector3D Constructor Overload List


vector3D Fields

The fields of the vector3D structure are listed below. For a complete list of vector3D structure members, see the vector3D Members topic.

Public Instance Fields

x | 保持しているベクター(x,y,z)。
y | 保持しているベクター(x,y,z)。
z | 保持しているベクター(x,y,z)。

See Also

vector3D Class | y4cs.math Namespace


vector3D.x Field

保持しているベクター(x,y,z)。

public double x;

See Also

vector3D Class | y4cs.math Namespace


vector3D.y Field

保持しているベクター(x,y,z)。

public double y;

See Also

vector3D Class | y4cs.math Namespace


vector3D.z Field

保持しているベクター(x,y,z)。

public double z;

See Also

vector3D Class | y4cs.math Namespace


vector3D Methods

The methods of the vector3D structure are listed below. For a complete list of vector3D structure members, see the vector3D Members topic.

Public Instance Methods

add | 他のベクトルを加算する。
dist | 近似による距離(絶対値)の算出。sqrtを使っていない分だけ速い。
div | スカラー値で除算する。
Equals |
GetHashCode |
GetType (inherited from Object) |
innerProduct | 内積を求める。
mul | スカラー値を乗算する。
outerProduct | 外積を求める(3次元の外積の結果はベクトル)。
set | (x,y,z)を設定するsetter。
size | 絶対値を求める(sqrtが入るので遅い)。
size2 | 絶対値の二乗を求める(大小比較をする目的ならこちらで十分)。
sub | 他のベクトルを減算する。
ToString |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

vector3D Class | y4cs.math Namespace


vector3D.add Method

他のベクトルを加算する。

public void add(
vector3D v
);

Parameters

v

See Also

vector3D Class | y4cs.math Namespace


vector3D.dist Method

近似による距離(絶対値)の算出。sqrtを使っていない分だけ速い。

public double dist(
vector3D v
);

Parameters

v

Return Value

See Also

vector3D Class | y4cs.math Namespace


vector3D.div Method

スカラー値で除算する。

public void div(
double a
);

Parameters

a

See Also

vector3D Class | y4cs.math Namespace


vector3D.Equals Method

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

vector3D Class | y4cs.math Namespace


vector3D.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

vector3D Class | y4cs.math Namespace


vector3D.innerProduct Method

内積を求める。

public double innerProduct(
vector3D v
);

Parameters

v

Return Value

See Also

vector3D Class | y4cs.math Namespace


vector3D.mul Method

スカラー値を乗算する。

public void mul(
double a
);

Parameters

a

See Also

vector3D Class | y4cs.math Namespace


vector3D.outerProduct Method

外積を求める(3次元の外積の結果はベクトル)。

public void outerProduct(
vector3D v
);

Parameters

v

See Also

vector3D Class | y4cs.math Namespace


vector3D.set Method

(x,y,z)を設定するsetter。

public void set(
double x_,
double y_,
double z_
);

Parameters

x_
y_
z_

See Also

vector3D Class | y4cs.math Namespace


vector3D.size Method

絶対値を求める(sqrtが入るので遅い)。

public double size();

Return Value

See Also

vector3D Class | y4cs.math Namespace


vector3D.size2 Method

絶対値の二乗を求める(大小比較をする目的ならこちらで十分)。

public double size2();

Return Value

See Also

vector3D Class | y4cs.math Namespace


vector3D.sub Method

他のベクトルを減算する。

public void sub(
vector3D v
);

Parameters

v

See Also

vector3D Class | y4cs.math Namespace


vector3D.ToString Method

public override string ToString();

Return Value

See Also

vector3D Class | y4cs.math Namespace


vector3D Operators

The operators of the vector3D structure are listed below. For a complete list of vector3D structure members, see the vector3D Members topic.

Public Static Operators

Addition Operator | + 和。
Division Operator | Overloaded. / 外積。
Equality Operator | operator ==
Inequality Operator | operator !=
Multiplication Operator | Overloaded. * 内積。
Subtraction Operator | - 差。

See Also

vector3D Class | vector3D Members | y4cs.math Namespace


vector3D Addition Operator

+ 和。

public static vector3D operator +(
vector3D a,
vector3D b
);

Parameters

a
b

Return Value

See Also

vector3D Class | y4cs.math Namespace


vector3D Division Operator

/ 定数割。

Overload List

/ 定数割。

public static vector3D Division Operator(vector3D,double);

/ 外積。

public static vector3D Division Operator(vector3D,vector3D);

See Also

vector3D Class | y4cs.math Namespace


vector3D Division Operator

/ 定数割。

public static vector3D operator /(
vector3D a,
double b
);

Parameters

a
b

Return Value

See Also

vector3D Class | y4cs.math Namespace | vector3D Division Operator Overload List


vector3D Division Operator

/ 外積。

public static vector3D operator /(
vector3D a,
vector3D b
);

Parameters

a
b

Return Value

See Also

vector3D Class | y4cs.math Namespace | vector3D Division Operator Overload List


vector3D Equality Operator

operator ==

public static bool operator ==(
vector3D a,
vector3D b
);

Parameters

a
b

Return Value

See Also

vector3D Class | y4cs.math Namespace


vector3D Inequality Operator

operator !=

public static bool operator !=(
vector3D a,
vector3D b
);

Parameters

a
b

Return Value

See Also

vector3D Class | y4cs.math Namespace


vector3D Multiplication Operator

* 定数倍。

Overload List

* 定数倍。

public static vector3D Multiplication Operator(vector3D,double);

* 内積。

public static double Multiplication Operator(vector3D,vector3D);

See Also

vector3D Class | y4cs.math Namespace


vector3D Multiplication Operator

* 定数倍。

public static vector3D operator *(
vector3D a,
double b
);

Parameters

a
b

Return Value

See Also

vector3D Class | y4cs.math Namespace | vector3D Multiplication Operator Overload List


vector3D Multiplication Operator

* 内積。

public static double operator *(
vector3D a,
vector3D b
);

Parameters

a
b

Return Value

See Also

vector3D Class | y4cs.math Namespace | vector3D Multiplication Operator Overload List


vector3D Subtraction Operator

- 差。

public static vector3D operator -(
vector3D a,
vector3D b
);

Parameters

a
b

Return Value

See Also

vector3D Class | y4cs.math Namespace


y4cs.sdl

Yaneurao Game Library 4th for C#

y4cs.sdl Namespace

Classes

Class | Description
SDL | SDL の概要の説明です。
SDL_RWops |
SDL_RWopsHandle |

Structures

Structure | Description
SDL_ActiveEvent |
SDL_Event |
SDL_ExposeEvent |
SDL_JoyAxisEvent |
SDL_JoyBallEvent |
SDL_JoyButtonEvent |
SDL_JoyHatEvent |
SDL_KeyboardEvent |
SDL_keysym |
SDL_MouseButtonEvent |
SDL_MouseMotionEvent |
SDL_QuitEvent |
SDL_ResizeEvent |
SDL_RWopsHandle.SDL_RWops_hidden |
SDL_RWopsHandle.SDL_RWops_mem |
SDL_RWopsHandle.SDL_RWops_stdio |
SDL_RWopsHandle.SDL_RWops_unknown |
SDL_SysWMEvent |
SDL_SysWMEvnet |
SDL_UserEvent |

Enumerations

Enumeration | Description
SDL_EVENTS |
SDL_INIT |
SDL_SURFACE |


SDL Class

SDL の概要の説明です。

For a list of all members of this type, see SDL Members.

System.Object
SDL

public abstract class SDL

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL Members | y4cs.sdl Namespace


SDL Members

SDL overview

Public Static Methods

GetTicks
InitSubSystem
PollEvent
QuitSubSystem
WM_SetCaption

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

SDL Constructor Initializes a new instance of the SDL class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL Class | y4cs.sdl Namespace


SDL Constructor

Initializes a new instance of the SDL class.

protected SDL();

See Also

SDL Class | y4cs.sdl Namespace


SDL Methods

The methods of the SDL class are listed below. For a complete list of SDL class members, see the SDL Members topic.

Public Static Methods

GetTicks
InitSubSystem
PollEvent
QuitSubSystem
WM_SetCaption

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL Class | y4cs.sdl Namespace


SDL.GetTicks Method

public static uint GetTicks();

Return Value

See Also

SDL Class | y4cs.sdl Namespace


SDL.InitSubSystem Method

public static int InitSubSystem(
SDL_INIT flags
);

Parameters

flags

Return Value

See Also

SDL Class | y4cs.sdl Namespace


SDL.PollEvent Method

public static int PollEvent(
IntPtr evt
);

Parameters

evt

Return Value

See Also

SDL Class | y4cs.sdl Namespace


SDL.QuitSubSystem Method

public static void QuitSubSystem(
SDL_INIT flags
);

Parameters

flags

See Also

SDL Class | y4cs.sdl Namespace


SDL.WM_SetCaption Method

public static void WM_SetCaption(
string title,
string icon
);

Parameters

title
icon

See Also

SDL Class | y4cs.sdl Namespace


SDL_ActiveEvent Structure

For a list of all members of this type, see SDL_ActiveEvent Members.

System.Object
ValueType
SDL_ActiveEvent

public struct SDL_ActiveEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_ActiveEvent Members | y4cs.sdl Namespace


SDL_ActiveEvent Members

SDL_ActiveEvent overview

Public Instance Fields

gain
state
type

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_ActiveEvent Class | y4cs.sdl Namespace


SDL_ActiveEvent Fields

The fields of the SDL_ActiveEvent structure are listed below. For a complete list of SDL_ActiveEvent structure members, see the SDL_ActiveEvent Members topic.

Public Instance Fields

gain
state
type

See Also

SDL_ActiveEvent Class | y4cs.sdl Namespace


SDL_ActiveEvent.gain Field

public byte gain;

See Also

SDL_ActiveEvent Class | y4cs.sdl Namespace


SDL_ActiveEvent.state Field

public byte state;

See Also

SDL_ActiveEvent Class | y4cs.sdl Namespace


SDL_ActiveEvent.type Field

public SDL_EVENTS type;

See Also

SDL_ActiveEvent Class | y4cs.sdl Namespace


SDL_Event Structure

For a list of all members of this type, see SDL_Event Members.

System.Object
ValueType
SDL_Event

public struct SDL_Event

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_Event Members | y4cs.sdl Namespace


SDL_Event Members

SDL_Event overview

Public Instance Fields

active
button
expose
jaxis
jball
jbutton
jhat
key
motion
quit
resize
syswm
type
user

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event Fields

The fields of the SDL_Event structure are listed below. For a complete list of SDL_Event structure members, see the SDL_Event Members topic.

Public Instance Fields

active
button
expose
jaxis
jball
jbutton
jhat
key
motion
quit
resize
syswm
type
user

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.active Field

public SDL_ActiveEvent active;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.button Field

public SDL_MouseButtonEvent button;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.expose Field

public SDL_ExposeEvent expose;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.jaxis Field

public SDL_JoyAxisEvent jaxis;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.jball Field

public SDL_JoyBallEvent jball;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.jbutton Field

public SDL_JoyButtonEvent jbutton;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.jhat Field

public SDL_JoyHatEvent jhat;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.key Field

public SDL_KeyboardEvent key;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.motion Field

public SDL_MouseMotionEvent motion;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.quit Field

public SDL_QuitEvent quit;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.resize Field

public SDL_ResizeEvent resize;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.syswm Field

public SDL_SysWMEvent syswm;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.type Field

public SDL_EVENTS type;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_Event.user Field

public SDL_UserEvent user;

See Also

SDL_Event Class | y4cs.sdl Namespace


SDL_EVENTS Enumeration

public enum SDL_EVENTS

Members

Member Name | Description
NOEVENT | Unused (do not remove)
ACTIVEEVENT | Application loses/gains visibility
KEYDOWN | Keys pressed
KEYUP | Keys released
MOUSEMOTION | Mouse moved
MOUSEBUTTONDOWN | Mouse button pressed
MOUSEBUTTONUP | Mouse button released
JOYAXISMOTION | Joystick axis motion
JOYBALLMOTION | Joystick trackball motion
JOYHATMOTION | Joystick hat position change
JOYBUTTONDOWN | Joystick button pressed
JOYBUTTONUP | Joystick button released
QUIT | User-requested quit
SYSWMEVENT | System specific event
EVENT_RESERVEDA | Reserved for future use..
EVENT_RESERVEDB | Reserved for future use..
VIDEORESIZE | User resized video mode
VIDEOEXPOSE | Screen needs to be redrawn
EVENT_RESERVED2 | Reserved for future use..
EVENT_RESERVED3 | Reserved for future use..
EVENT_RESERVED4 | Reserved for future use..
EVENT_RESERVED5 | Reserved for future use..
EVENT_RESERVED6 | Reserved for future use..
EVENT_RESERVED7 | Reserved for future use..
USEREVENT | Events SDL_USEREVENT through SDL_MAXEVENTS-1 are for your use
NUMEVENTS | This last event is only for bounding internal arrays It is the number of bits in the event mask datatype -- Uint32

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

y4cs.sdl Namespace


SDL_ExposeEvent Structure

For a list of all members of this type, see SDL_ExposeEvent Members.

System.Object
ValueType
SDL_ExposeEvent

public struct SDL_ExposeEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_ExposeEvent Members | y4cs.sdl Namespace


SDL_ExposeEvent Members

SDL_ExposeEvent overview

Public Instance Fields

type

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_ExposeEvent Class | y4cs.sdl Namespace


SDL_ExposeEvent Fields

The fields of the SDL_ExposeEvent structure are listed below. For a complete list of SDL_ExposeEvent structure members, see the SDL_ExposeEvent Members topic.

Public Instance Fields

type

See Also

SDL_ExposeEvent Class | y4cs.sdl Namespace


SDL_ExposeEvent.type Field

public SDL_EVENTS type;

See Also

SDL_ExposeEvent Class | y4cs.sdl Namespace


SDL_INIT Enumeration

public enum SDL_INIT

Members

Member Name | Description
TIMER |
AUDIO |
VIDEO |
CDROM |
JOYSTICK |
NOPARACHUTE |
EVENTTHREAD |
EVERYTHING |

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

y4cs.sdl Namespace


SDL_JoyAxisEvent Structure

For a list of all members of this type, see SDL_JoyAxisEvent Members.

System.Object
ValueType
SDL_JoyAxisEvent

public struct SDL_JoyAxisEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_JoyAxisEvent Members | y4cs.sdl Namespace


SDL_JoyAxisEvent Members

SDL_JoyAxisEvent overview

Public Instance Fields

axis
type
value
which

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_JoyAxisEvent Class | y4cs.sdl Namespace


SDL_JoyAxisEvent Fields

The fields of the SDL_JoyAxisEvent structure are listed below. For a complete list of SDL_JoyAxisEvent structure members, see the SDL_JoyAxisEvent Members topic.

Public Instance Fields

axis
type
value
which

See Also

SDL_JoyAxisEvent Class | y4cs.sdl Namespace


SDL_JoyAxisEvent.axis Field

public byte axis;

See Also

SDL_JoyAxisEvent Class | y4cs.sdl Namespace


SDL_JoyAxisEvent.type Field

public SDL_EVENTS type;

See Also

SDL_JoyAxisEvent Class | y4cs.sdl Namespace


SDL_JoyAxisEvent.value Field

public short value;

See Also

SDL_JoyAxisEvent Class | y4cs.sdl Namespace


SDL_JoyAxisEvent.which Field

public byte which;

See Also

SDL_JoyAxisEvent Class | y4cs.sdl Namespace


SDL_JoyBallEvent Structure

For a list of all members of this type, see SDL_JoyBallEvent Members.

System.Object
ValueType
SDL_JoyBallEvent

public struct SDL_JoyBallEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_JoyBallEvent Members | y4cs.sdl Namespace


SDL_JoyBallEvent Members

SDL_JoyBallEvent overview

Public Instance Fields

ball
type
which
xrel
yrel

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_JoyBallEvent Class | y4cs.sdl Namespace


SDL_JoyBallEvent Fields

The fields of the SDL_JoyBallEvent structure are listed below. For a complete list of SDL_JoyBallEvent structure members, see the SDL_JoyBallEvent Members topic.

Public Instance Fields

ball
type
which
xrel
yrel

See Also

SDL_JoyBallEvent Class | y4cs.sdl Namespace


SDL_JoyBallEvent.ball Field

public byte ball;

See Also

SDL_JoyBallEvent Class | y4cs.sdl Namespace


SDL_JoyBallEvent.type Field

public SDL_EVENTS type;

See Also

SDL_JoyBallEvent Class | y4cs.sdl Namespace


SDL_JoyBallEvent.which Field

public byte which;

See Also

SDL_JoyBallEvent Class | y4cs.sdl Namespace


SDL_JoyBallEvent.xrel Field

public short xrel;

See Also

SDL_JoyBallEvent Class | y4cs.sdl Namespace


SDL_JoyBallEvent.yrel Field

public short yrel;

See Also

SDL_JoyBallEvent Class | y4cs.sdl Namespace


SDL_JoyButtonEvent Structure

For a list of all members of this type, see SDL_JoyButtonEvent Members.

System.Object
ValueType
SDL_JoyButtonEvent

public struct SDL_JoyButtonEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_JoyButtonEvent Members | y4cs.sdl Namespace


SDL_JoyButtonEvent Members

SDL_JoyButtonEvent overview

Public Instance Fields

button
state
type
which

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_JoyButtonEvent Class | y4cs.sdl Namespace


SDL_JoyButtonEvent Fields

The fields of the SDL_JoyButtonEvent structure are listed below. For a complete list of SDL_JoyButtonEvent structure members, see the SDL_JoyButtonEvent Members topic.

Public Instance Fields

button
state
type
which

See Also

SDL_JoyButtonEvent Class | y4cs.sdl Namespace


SDL_JoyButtonEvent.button Field

public byte button;

See Also

SDL_JoyButtonEvent Class | y4cs.sdl Namespace


SDL_JoyButtonEvent.state Field

public byte state;

See Also

SDL_JoyButtonEvent Class | y4cs.sdl Namespace


SDL_JoyButtonEvent.type Field

public SDL_EVENTS type;

See Also

SDL_JoyButtonEvent Class | y4cs.sdl Namespace


SDL_JoyButtonEvent.which Field

public byte which;

See Also

SDL_JoyButtonEvent Class | y4cs.sdl Namespace


SDL_JoyHatEvent Structure

For a list of all members of this type, see SDL_JoyHatEvent Members.

System.Object
ValueType
SDL_JoyHatEvent

public struct SDL_JoyHatEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_JoyHatEvent Members | y4cs.sdl Namespace


SDL_JoyHatEvent Members

SDL_JoyHatEvent overview

Public Instance Fields

hat
type
value
which

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_JoyHatEvent Class | y4cs.sdl Namespace


SDL_JoyHatEvent Fields

The fields of the SDL_JoyHatEvent structure are listed below. For a complete list of SDL_JoyHatEvent structure members, see the SDL_JoyHatEvent Members topic.

Public Instance Fields

hat
type
value
which

See Also

SDL_JoyHatEvent Class | y4cs.sdl Namespace


SDL_JoyHatEvent.hat Field

public byte hat;

See Also

SDL_JoyHatEvent Class | y4cs.sdl Namespace


SDL_JoyHatEvent.type Field

public SDL_EVENTS type;

See Also

SDL_JoyHatEvent Class | y4cs.sdl Namespace


SDL_JoyHatEvent.value Field

public byte value;

See Also

SDL_JoyHatEvent Class | y4cs.sdl Namespace


SDL_JoyHatEvent.which Field

public byte which;

See Also

SDL_JoyHatEvent Class | y4cs.sdl Namespace


SDL_KeyboardEvent Structure

For a list of all members of this type, see SDL_KeyboardEvent Members.

System.Object
ValueType
SDL_KeyboardEvent

public struct SDL_KeyboardEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_KeyboardEvent Members | y4cs.sdl Namespace


SDL_KeyboardEvent Members

SDL_KeyboardEvent overview

Public Instance Fields

keysym
state
type
which

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_KeyboardEvent Class | y4cs.sdl Namespace


SDL_KeyboardEvent Fields

The fields of the SDL_KeyboardEvent structure are listed below. For a complete list of SDL_KeyboardEvent structure members, see the SDL_KeyboardEvent Members topic.

Public Instance Fields

keysym
state
type
which

See Also

SDL_KeyboardEvent Class | y4cs.sdl Namespace


SDL_KeyboardEvent.keysym Field

public SDL_keysym keysym;

See Also

SDL_KeyboardEvent Class | y4cs.sdl Namespace


SDL_KeyboardEvent.state Field

public byte state;

See Also

SDL_KeyboardEvent Class | y4cs.sdl Namespace


SDL_KeyboardEvent.type Field

public SDL_EVENTS type;

See Also

SDL_KeyboardEvent Class | y4cs.sdl Namespace


SDL_KeyboardEvent.which Field

public byte which;

See Also

SDL_KeyboardEvent Class | y4cs.sdl Namespace


SDL_keysym Structure

For a list of all members of this type, see SDL_keysym Members.

System.Object
ValueType
SDL_keysym

public struct SDL_keysym

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_keysym Members | y4cs.sdl Namespace


SDL_keysym Members

SDL_keysym overview

Public Instance Fields

mod
scancode
sym
unicode

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_keysym Class | y4cs.sdl Namespace


SDL_keysym Fields

The fields of the SDL_keysym structure are listed below. For a complete list of SDL_keysym structure members, see the SDL_keysym Members topic.

Public Instance Fields

mod
scancode
sym
unicode

See Also

SDL_keysym Class | y4cs.sdl Namespace


SDL_keysym.mod Field

public int mod;

See Also

SDL_keysym Class | y4cs.sdl Namespace


SDL_keysym.scancode Field

public byte scancode;

See Also

SDL_keysym Class | y4cs.sdl Namespace


SDL_keysym.sym Field

public int sym;

See Also

SDL_keysym Class | y4cs.sdl Namespace


SDL_keysym.unicode Field

public ushort unicode;

See Also

SDL_keysym Class | y4cs.sdl Namespace


SDL_MouseButtonEvent Structure

For a list of all members of this type, see SDL_MouseButtonEvent Members.

System.Object
ValueType
SDL_MouseButtonEvent

public struct SDL_MouseButtonEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_MouseButtonEvent Members | y4cs.sdl Namespace


SDL_MouseButtonEvent Members

SDL_MouseButtonEvent overview

Public Instance Fields

button
state
type
which
x
y

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_MouseButtonEvent Class | y4cs.sdl Namespace


SDL_MouseButtonEvent Fields

The fields of the SDL_MouseButtonEvent structure are listed below. For a complete list of SDL_MouseButtonEvent structure members, see the SDL_MouseButtonEvent Members topic.

Public Instance Fields

button
state
type
which
x
y

See Also

SDL_MouseButtonEvent Class | y4cs.sdl Namespace


SDL_MouseButtonEvent.button Field

public byte button;

See Also

SDL_MouseButtonEvent Class | y4cs.sdl Namespace


SDL_MouseButtonEvent.state Field

public byte state;

See Also

SDL_MouseButtonEvent Class | y4cs.sdl Namespace


SDL_MouseButtonEvent.type Field

public SDL_EVENTS type;

See Also

SDL_MouseButtonEvent Class | y4cs.sdl Namespace


SDL_MouseButtonEvent.which Field

public byte which;

See Also

SDL_MouseButtonEvent Class | y4cs.sdl Namespace


SDL_MouseButtonEvent.x Field

public ushort x;

See Also

SDL_MouseButtonEvent Class | y4cs.sdl Namespace


SDL_MouseButtonEvent.y Field

public ushort y;

See Also

SDL_MouseButtonEvent Class | y4cs.sdl Namespace


SDL_MouseMotionEvent Structure

For a list of all members of this type, see SDL_MouseMotionEvent Members.

System.Object
ValueType
SDL_MouseMotionEvent

public struct SDL_MouseMotionEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_MouseMotionEvent Members | y4cs.sdl Namespace


SDL_MouseMotionEvent Members

SDL_MouseMotionEvent overview

Public Instance Fields

state
type
which
x
xrel
y
yrel

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_MouseMotionEvent Class | y4cs.sdl Namespace


SDL_MouseMotionEvent Fields

The fields of the SDL_MouseMotionEvent structure are listed below. For a complete list of SDL_MouseMotionEvent structure members, see the SDL_MouseMotionEvent Members topic.

Public Instance Fields

state
type
which
x
xrel
y
yrel

See Also

SDL_MouseMotionEvent Class | y4cs.sdl Namespace


SDL_MouseMotionEvent.state Field

public byte state;

See Also

SDL_MouseMotionEvent Class | y4cs.sdl Namespace


SDL_MouseMotionEvent.type Field

public SDL_EVENTS type;

See Also

SDL_MouseMotionEvent Class | y4cs.sdl Namespace


SDL_MouseMotionEvent.which Field

public byte which;

See Also

SDL_MouseMotionEvent Class | y4cs.sdl Namespace


SDL_MouseMotionEvent.x Field

public ushort x;

See Also

SDL_MouseMotionEvent Class | y4cs.sdl Namespace


SDL_MouseMotionEvent.xrel Field

public short xrel;

See Also

SDL_MouseMotionEvent Class | y4cs.sdl Namespace


SDL_MouseMotionEvent.y Field

public ushort y;

See Also

SDL_MouseMotionEvent Class | y4cs.sdl Namespace


SDL_MouseMotionEvent.yrel Field

public short yrel;

See Also

SDL_MouseMotionEvent Class | y4cs.sdl Namespace


SDL_QuitEvent Structure

For a list of all members of this type, see SDL_QuitEvent Members.

System.Object
ValueType
SDL_QuitEvent

public struct SDL_QuitEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_QuitEvent Members | y4cs.sdl Namespace


SDL_QuitEvent Members

SDL_QuitEvent overview

Public Instance Fields

type

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_QuitEvent Class | y4cs.sdl Namespace


SDL_QuitEvent Fields

The fields of the SDL_QuitEvent structure are listed below. For a complete list of SDL_QuitEvent structure members, see the SDL_QuitEvent Members topic.

Public Instance Fields

type

See Also

SDL_QuitEvent Class | y4cs.sdl Namespace


SDL_QuitEvent.type Field

public SDL_EVENTS type;

See Also

SDL_QuitEvent Class | y4cs.sdl Namespace


SDL_ResizeEvent Structure

For a list of all members of this type, see SDL_ResizeEvent Members.

System.Object
ValueType
SDL_ResizeEvent

public struct SDL_ResizeEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_ResizeEvent Members | y4cs.sdl Namespace


SDL_ResizeEvent Members

SDL_ResizeEvent overview

Public Instance Fields

h
type
w

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_ResizeEvent Class | y4cs.sdl Namespace


SDL_ResizeEvent Fields

The fields of the SDL_ResizeEvent structure are listed below. For a complete list of SDL_ResizeEvent structure members, see the SDL_ResizeEvent Members topic.

Public Instance Fields

h
type
w

See Also

SDL_ResizeEvent Class | y4cs.sdl Namespace


SDL_ResizeEvent.h Field

public int h;

See Also

SDL_ResizeEvent Class | y4cs.sdl Namespace


SDL_ResizeEvent.type Field

public SDL_EVENTS type;

See Also

SDL_ResizeEvent Class | y4cs.sdl Namespace


SDL_ResizeEvent.w Field

public int w;

See Also

SDL_ResizeEvent Class | y4cs.sdl Namespace


SDL_RWops Class

For a list of all members of this type, see SDL_RWops Members.

System.Object
SDL_RWops

public class SDL_RWops : IDisposable

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_RWops Members | y4cs.sdl Namespace


SDL_RWops Members

SDL_RWops overview

Public Static Methods

FreeRW
RWFromMem

Public Instance Constructors

SDL_RWops Constructor Initializes a new instance of the SDL_RWops class.

Public Instance Properties

Handle
Length

Public Instance Methods

Create |
Dispose | Overloaded.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

SDL_RWops Class | y4cs.sdl Namespace


SDL_RWops Constructor

Initializes a new instance of the SDL_RWops class.

public SDL_RWops();

See Also

SDL_RWops Class | y4cs.sdl Namespace


SDL_RWops Properties

The properties of the SDL_RWops class are listed below. For a complete list of SDL_RWops class members, see the SDL_RWops Members topic.

Public Instance Properties

Handle
Length

See Also

SDL_RWops Class | y4cs.sdl Namespace


SDL_RWops.Handle Property

public System.IntPtr Handle {get;}

See Also

SDL_RWops Class | y4cs.sdl Namespace


SDL_RWops.Length Property

public ulong Length {get;}

See Also

SDL_RWops Class | y4cs.sdl Namespace


SDL_RWops Methods

The methods of the SDL_RWops class are listed below. For a complete list of SDL_RWops class members, see the SDL_RWops Members topic.

Public Static Methods

FreeRW
RWFromMem

Public Instance Methods

Create |
Dispose | Overloaded.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

SDL_RWops Class | y4cs.sdl Namespace


SDL_RWops.Create Method

public void Create(
byte[] data
);

Parameters

data

See Also

SDL_RWops Class | y4cs.sdl Namespace


Dispose Method

Yaneurao Game Library 4th for C#

SDL_RWops.Dispose Method

Overload List

public void Dispose();

protected void Dispose(bool);

See Also

SDL_RWops Class | y4cs.sdl Namespace


SDL_RWops.Dispose Method ()

public void Dispose();

Implements

IDisposable.Dispose

See Also

SDL_RWops Class | y4cs.sdl Namespace | SDL_RWops.Dispose Overload List


SDL_RWops.Dispose Method (Boolean)

protected void Dispose(
bool disposing
);

Parameters

disposing

See Also

SDL_RWops Class | y4cs.sdl Namespace | SDL_RWops.Dispose Overload List


SDL_RWops.Finalize Method

protected override void Finalize();

See Also

SDL_RWops Class | y4cs.sdl Namespace


SDL_RWops.FreeRW Method

public static void FreeRW(
IntPtr RWops
);

Parameters

RWops

See Also

SDL_RWops Class | y4cs.sdl Namespace


SDL_RWops.RWFromMem Method

public static IntPtr RWFromMem(
IntPtr mem,
int size
);

Parameters

mem
size

Return Value

See Also

SDL_RWops Class | y4cs.sdl Namespace


SDL_RWopsHandle Class

For a list of all members of this type, see SDL_RWopsHandle Members.

System.Object
SDL_RWopsHandle

public class SDL_RWopsHandle

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_RWopsHandle Members | y4cs.sdl Namespace


SDL_RWopsHandle Members

SDL_RWopsHandle overview

Public Instance Constructors

SDL_RWopsHandle Constructor Initializes a new instance of the SDL_RWopsHandle class.

Public Instance Fields

close
hidden
read
seek
type
write

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_RWopsHandle Class | y4cs.sdl Namespace


SDL_RWopsHandle Constructor

Initializes a new instance of the SDL_RWopsHandle class.

public SDL_RWopsHandle();

See Also

SDL_RWopsHandle Class | y4cs.sdl Namespace


SDL_RWopsHandle Fields

The fields of the SDL_RWopsHandle class are listed below. For a complete list of SDL_RWopsHandle class members, see the SDL_RWopsHandle Members topic.

Public Instance Fields

close
hidden
read
seek
type
write

See Also

SDL_RWopsHandle Class | y4cs.sdl Namespace


SDL_RWopsHandle.close Field

public IntPtr close;

See Also

SDL_RWopsHandle Class | y4cs.sdl Namespace


SDL_RWopsHandle.hidden Field

public SDL_RWops_hidden hidden;

See Also

SDL_RWopsHandle Class | y4cs.sdl Namespace


SDL_RWopsHandle.read Field

public IntPtr read;

See Also

SDL_RWopsHandle Class | y4cs.sdl Namespace


SDL_RWopsHandle.seek Field

public IntPtr seek;

See Also

SDL_RWopsHandle Class | y4cs.sdl Namespace


SDL_RWopsHandle.type Field

public uint type;

See Also

SDL_RWopsHandle Class | y4cs.sdl Namespace


SDL_RWopsHandle.write Field

public IntPtr write;

See Also

SDL_RWopsHandle Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_hidden Structure

For a list of all members of this type, see SDL_RWopsHandle.SDL_RWops_hidden Members.

System.Object
ValueType
SDL_RWopsHandle.SDL_RWops_hidden

public struct SDL_RWopsHandle.SDL_RWops_hidden

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_RWopsHandle.SDL_RWops_hidden Members | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_hidden Members

SDL_RWopsHandle.SDL_RWops_hidden overview

Public Instance Fields

mem
stdio
unknown

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_RWopsHandle.SDL_RWops_hidden Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_hidden Fields

The fields of the SDL_RWopsHandle.SDL_RWops_hidden structure are listed below. For a complete list of SDL_RWopsHandle.SDL_RWops_hidden structure members, see the SDL_RWopsHandle.SDL_RWops_hidden Members topic.

Public Instance Fields

mem
stdio
unknown

See Also

SDL_RWopsHandle.SDL_RWops_hidden Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_hidden.mem Field

public SDL_RWops_mem mem;

See Also

SDL_RWopsHandle.SDL_RWops_hidden Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_hidden.stdio Field

public SDL_RWops_stdio stdio;

See Also

SDL_RWopsHandle.SDL_RWops_hidden Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_hidden.unknown Field

public SDL_RWops_unknown unknown;

See Also

SDL_RWopsHandle.SDL_RWops_hidden Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_mem Structure

For a list of all members of this type, see SDL_RWopsHandle.SDL_RWops_mem Members.

System.Object
ValueType
SDL_RWopsHandle.SDL_RWops_mem

public struct SDL_RWopsHandle.SDL_RWops_mem

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_RWopsHandle.SDL_RWops_mem Members | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_mem Members

SDL_RWopsHandle.SDL_RWops_mem overview

Public Instance Fields

base_
here
stop

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_RWopsHandle.SDL_RWops_mem Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_mem Fields

The fields of the SDL_RWopsHandle.SDL_RWops_mem structure are listed below. For a complete list of SDL_RWopsHandle.SDL_RWops_mem structure members, see the SDL_RWopsHandle.SDL_RWops_mem Members topic.

Public Instance Fields

base_
here
stop

See Also

SDL_RWopsHandle.SDL_RWops_mem Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_mem.base_ Field

public IntPtr base_;

See Also

SDL_RWopsHandle.SDL_RWops_mem Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_mem.here Field

public IntPtr here;

See Also

SDL_RWopsHandle.SDL_RWops_mem Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_mem.stop Field

public IntPtr stop;

See Also

SDL_RWopsHandle.SDL_RWops_mem Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_stdio Structure

For a list of all members of this type, see SDL_RWopsHandle.SDL_RWops_stdio Members.

System.Object
ValueType
SDL_RWopsHandle.SDL_RWops_stdio

public struct SDL_RWopsHandle.SDL_RWops_stdio

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_RWopsHandle.SDL_RWops_stdio Members | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_stdio Members

SDL_RWopsHandle.SDL_RWops_stdio overview

Public Instance Fields

autoclose
fp

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_RWopsHandle.SDL_RWops_stdio Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_stdio Fields

The fields of the SDL_RWopsHandle.SDL_RWops_stdio structure are listed below. For a complete list of SDL_RWopsHandle.SDL_RWops_stdio structure members, see the SDL_RWopsHandle.SDL_RWops_stdio Members topic.

Public Instance Fields

autoclose
fp

See Also

SDL_RWopsHandle.SDL_RWops_stdio Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_stdio.autoclose Field

public int autoclose;

See Also

SDL_RWopsHandle.SDL_RWops_stdio Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_stdio.fp Field

public IntPtr fp;

See Also

SDL_RWopsHandle.SDL_RWops_stdio Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_unknown Structure

For a list of all members of this type, see SDL_RWopsHandle.SDL_RWops_unknown Members.

System.Object
ValueType
SDL_RWopsHandle.SDL_RWops_unknown

public struct SDL_RWopsHandle.SDL_RWops_unknown

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_RWopsHandle.SDL_RWops_unknown Members | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_unknown Members

SDL_RWopsHandle.SDL_RWops_unknown overview

Public Instance Fields

data1

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_RWopsHandle.SDL_RWops_unknown Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_unknown Fields

The fields of the SDL_RWopsHandle.SDL_RWops_unknown structure are listed below. For a complete list of SDL_RWopsHandle.SDL_RWops_unknown structure members, see the SDL_RWopsHandle.SDL_RWops_unknown Members topic.

Public Instance Fields

data1

See Also

SDL_RWopsHandle.SDL_RWops_unknown Class | y4cs.sdl Namespace


SDL_RWopsHandle.SDL_RWops_unknown.data1 Field

public IntPtr data1;

See Also

SDL_RWopsHandle.SDL_RWops_unknown Class | y4cs.sdl Namespace


SDL_SURFACE Enumeration

public enum SDL_SURFACE

Members

Member Name | Description
SWSURFACE | Surface is in system memory
HWSURFACE | Surface is in video memory
ASYNCBLIT | Use asynchronous blits if possible
ANYFORMAT | Allow any video depth/pixel-format
HWPALETTE | Surface has exclusive palette
DOUBLEBUF | Set up double-buffered video mode
FULLSCREEN | Surface is a full screen display
OPENGL | Create an OpenGL rendering context
OPENGLBLIT | Create an OpenGL rendering context and use it for blitting
RESIZABLE | This video mode may be resized
NOFRAME | No window caption or edge frame
HWACCEL | Blit uses hardware acceleration
SRCCOLORKEY | Blit uses a source color key
RLEACCELOK | Private flag
RLEACCEL | Surface is RLE encoded
SRCALPHA | Blit uses source alpha blending
PREALLOC | Surface uses preallocated memory

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

y4cs.sdl Namespace


SDL_SysWMEvent Structure

For a list of all members of this type, see SDL_SysWMEvent Members.

System.Object
ValueType
SDL_SysWMEvent

public struct SDL_SysWMEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_SysWMEvent Members | y4cs.sdl Namespace


SDL_SysWMEvent Members

SDL_SysWMEvent overview

Public Instance Fields

msg
type

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_SysWMEvent Class | y4cs.sdl Namespace


SDL_SysWMEvent Fields

The fields of the SDL_SysWMEvent structure are listed below. For a complete list of SDL_SysWMEvent structure members, see the SDL_SysWMEvent Members topic.

Public Instance Fields

msg
type

See Also

SDL_SysWMEvent Class | y4cs.sdl Namespace


SDL_SysWMEvent.msg Field

public IntPtr msg;

See Also

SDL_SysWMEvent Class | y4cs.sdl Namespace


SDL_SysWMEvent.type Field

public SDL_EVENTS type;

See Also

SDL_SysWMEvent Class | y4cs.sdl Namespace


SDL_SysWMEvnet Structure

For a list of all members of this type, see SDL_SysWMEvnet Members.

System.Object
ValueType
SDL_SysWMEvnet

public struct SDL_SysWMEvnet

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_SysWMEvnet Members | y4cs.sdl Namespace


SDL_SysWMEvnet Members

SDL_SysWMEvnet overview

Public Instance Fields

type

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_SysWMEvnet Class | y4cs.sdl Namespace


SDL_SysWMEvnet Fields

The fields of the SDL_SysWMEvnet structure are listed below. For a complete list of SDL_SysWMEvnet structure members, see the SDL_SysWMEvnet Members topic.

Public Instance Fields

type

See Also

SDL_SysWMEvnet Class | y4cs.sdl Namespace


SDL_SysWMEvnet.type Field

public SDL_EVENTS type;

See Also

SDL_SysWMEvnet Class | y4cs.sdl Namespace


SDL_UserEvent Structure

For a list of all members of this type, see SDL_UserEvent Members.

System.Object
ValueType
SDL_UserEvent

public struct SDL_UserEvent

Requirements

Namespace: y4cs.sdl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_UserEvent Members | y4cs.sdl Namespace


SDL_UserEvent Members

SDL_UserEvent overview

Public Instance Fields

code
data1
data2
type

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_UserEvent Class | y4cs.sdl Namespace


SDL_UserEvent Fields

The fields of the SDL_UserEvent structure are listed below. For a complete list of SDL_UserEvent structure members, see the SDL_UserEvent Members topic.

Public Instance Fields

code
data1
data2
type

See Also

SDL_UserEvent Class | y4cs.sdl Namespace


SDL_UserEvent.code Field

public int code;

See Also

SDL_UserEvent Class | y4cs.sdl Namespace


SDL_UserEvent.data1 Field

public IntPtr data1;

See Also

SDL_UserEvent Class | y4cs.sdl Namespace


SDL_UserEvent.data2 Field

public IntPtr data2;

See Also

SDL_UserEvent Class | y4cs.sdl Namespace


SDL_UserEvent.type Field

public SDL_EVENTS type;

See Also

SDL_UserEvent Class | y4cs.sdl Namespace


y4cs.sdl.audio

Yaneurao Game Library 4th for C#

y4cs.sdl.audio Namespace

Enumerations

Enumeration | Description
AUDIO |


AUDIO Enumeration

public enum AUDIO

Members

Member Name | Description
U8 |
S8 |
U16LSB |
S16LSB |
U16MSB |
S16MSB |
U16 |
S16 |

Requirements

Namespace: y4cs.sdl.audio

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

y4cs.sdl.audio Namespace


y4cs.sdl.cdrom

Yaneurao Game Library 4th for C#

y4cs.sdl.cdrom Namespace

Classes

Class | Description
CD |

Enumerations

Enumeration | Description
CDstatus |


CD Class

For a list of all members of this type, see CD Members.

System.Object
CD

public abstract class CD

Requirements

Namespace: y4cs.sdl.cdrom

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

CD Members | y4cs.sdl.cdrom Namespace


CD Members

CD overview

Public Static Methods

Close
INDRIVE
NumDrives
Open
PlayTracks
Status

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

CD Constructor Initializes a new instance of the CD class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

CD Class | y4cs.sdl.cdrom Namespace


CD Constructor

Initializes a new instance of the CD class.

protected CD();

See Also

CD Class | y4cs.sdl.cdrom Namespace


CD Methods

The methods of the CD class are listed below. For a complete list of CD class members, see the CD Members topic.

Public Static Methods

Close
INDRIVE
NumDrives
Open
PlayTracks
Status

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

CD Class | y4cs.sdl.cdrom Namespace


CD.Close Method

public static void Close(
IntPtr cdrom
);

Parameters

cdrom

See Also

CD Class | y4cs.sdl.cdrom Namespace


CD.INDRIVE Method

public static bool INDRIVE(
CDstatus status
);

Parameters

status

Return Value

See Also

CD Class | y4cs.sdl.cdrom Namespace


CD.NumDrives Method

public static int NumDrives();

Return Value

See Also

CD Class | y4cs.sdl.cdrom Namespace


CD.Open Method

public static IntPtr Open(
int drive
);

Parameters

drive

Return Value

See Also

CD Class | y4cs.sdl.cdrom Namespace


CD.PlayTracks Method

public static int PlayTracks(
IntPtr cdrom,
int start_track,
int start_frame,
int ntracks,
int nframes
);

Parameters

cdrom
start_track
start_frame
ntracks
nframes

Return Value

See Also

CD Class | y4cs.sdl.cdrom Namespace


CD.Status Method

public static CDstatus Status(
IntPtr cdrom
);

Parameters

cdrom

Return Value

See Also

CD Class | y4cs.sdl.cdrom Namespace


CDstatus Enumeration

public enum CDstatus

Members

Member Name | Description
TRAYEMPTY |
STOPPED |
PLAYING |
PAUSED |
ERROR |

Requirements

Namespace: y4cs.sdl.cdrom

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

y4cs.sdl.cdrom Namespace


y4cs.sdl.font

Yaneurao Game Library 4th for C#

y4cs.sdl.font Namespace

Classes

Class | Description
TTF |


TTF Class

For a list of all members of this type, see TTF Members.

System.Object
TTF

public class TTF

Requirements

Namespace: y4cs.sdl.font

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

TTF Members | y4cs.sdl.font Namespace


TTF Members

TTF overview

Public Static Methods

CloseFont
Init
OpenFontIndex
OpenFontIndexRW
Quit
RenderText_Blended
RenderText_Solid
RenderUNICODE_Blended
RenderUNICODE_Solid
RenderUTF8_Blended
RenderUTF8_Solid

Public Instance Constructors

TTF Constructor Initializes a new instance of the TTF class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TTF Class | y4cs.sdl.font Namespace


TTF Constructor

Initializes a new instance of the TTF class.

public TTF();

See Also

TTF Class | y4cs.sdl.font Namespace


TTF Methods

The methods of the TTF class are listed below. For a complete list of TTF class members, see the TTF Members topic.

Public Static Methods

CloseFont
Init
OpenFontIndex
OpenFontIndexRW
Quit
RenderText_Blended
RenderText_Solid
RenderUNICODE_Blended
RenderUNICODE_Solid
RenderUTF8_Blended
RenderUTF8_Solid

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.CloseFont Method

public static void CloseFont(
IntPtr font
);

Parameters

font

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.Init Method

public static void Init();

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.OpenFontIndex Method

public static IntPtr OpenFontIndex(
string file,
int ptsize,
long index
);

Parameters

file
ptsize
index

Return Value

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.OpenFontIndexRW Method

public static IntPtr OpenFontIndexRW(
IntPtr src,
int freesrc,
int ptsize,
long index
);

Parameters

src
freesrc
ptsize
index

Return Value

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.Quit Method

public static void Quit();

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.RenderText_Blended Method

public static IntPtr RenderText_Blended(
IntPtr font,
string text,
SDL_Color fg
);

Parameters

font
text
fg

Return Value

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.RenderText_Solid Method

public static IntPtr RenderText_Solid(
IntPtr font,
string text,
SDL_Color fg
);

Parameters

font
text
fg

Return Value

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.RenderUNICODE_Blended Method

public static IntPtr RenderUNICODE_Blended(
IntPtr font,
string text,
SDL_Color fg
);

Parameters

font
text
fg

Return Value

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.RenderUNICODE_Solid Method

public static IntPtr RenderUNICODE_Solid(
IntPtr font,
string text,
SDL_Color fg
);

Parameters

font
text
fg

Return Value

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.RenderUTF8_Blended Method

public static IntPtr RenderUTF8_Blended(
IntPtr font,
IntPtr text,
SDL_Color fg
);

Parameters

font
text
fg

Return Value

See Also

TTF Class | y4cs.sdl.font Namespace


TTF.RenderUTF8_Solid Method

public static IntPtr RenderUTF8_Solid(
IntPtr font,
IntPtr text,
SDL_Color fg
);

Parameters

font
text
fg

Return Value

See Also

TTF Class | y4cs.sdl.font Namespace


y4cs.sdl.image

Yaneurao Game Library 4th for C#

y4cs.sdl.image Namespace

Classes

Class | Description
IMG |


IMG Class

For a list of all members of this type, see IMG Members.

System.Object
IMG

public abstract class IMG

Requirements

Namespace: y4cs.sdl.image

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

IMG Members | y4cs.sdl.image Namespace


IMG Members

IMG overview

Public Static Methods

Load
Load_RW

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

IMG Constructor Initializes a new instance of the IMG class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

IMG Class | y4cs.sdl.image Namespace


IMG Constructor

Initializes a new instance of the IMG class.

protected IMG();

See Also

IMG Class | y4cs.sdl.image Namespace


IMG Methods

The methods of the IMG class are listed below. For a complete list of IMG class members, see the IMG Members topic.

Public Static Methods

Load
Load_RW

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

IMG Class | y4cs.sdl.image Namespace


IMG.Load Method

public static IntPtr Load(
string src
);

Parameters

src

Return Value

See Also

IMG Class | y4cs.sdl.image Namespace


IMG.Load_RW Method

public static IntPtr Load_RW(
IntPtr src,
int freesrc
);

Parameters

src
freesrc

Return Value

See Also

IMG Class | y4cs.sdl.image Namespace


y4cs.sdl.joystick

Yaneurao Game Library 4th for C#

y4cs.sdl.joystick Namespace

Classes

Class | Description
Joystick |


Joystick Class

For a list of all members of this type, see Joystick Members.

System.Object
Joystick

public abstract class Joystick

Requirements

Namespace: y4cs.sdl.joystick

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Joystick Members | y4cs.sdl.joystick Namespace


Joystick Members

Joystick overview

Public Static Methods

Close
GetAxis
GetButton
Index
Name
NumAxes
NumButtons
NumJoysticks
Open
Update

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

Joystick Constructor Initializes a new instance of the Joystick class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick Constructor

Initializes a new instance of the Joystick class.

protected Joystick();

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick Methods

The methods of the Joystick class are listed below. For a complete list of Joystick class members, see the Joystick Members topic.

Public Static Methods

Close
GetAxis
GetButton
Index
Name
NumAxes
NumButtons
NumJoysticks
Open
Update

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick.Close Method

public static void Close(
IntPtr joystick
);

Parameters

joystick

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick.GetAxis Method

public static short GetAxis(
IntPtr joystick,
int axis
);

Parameters

joystick
axis

Return Value

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick.GetButton Method

public static byte GetButton(
IntPtr joystick,
int button
);

Parameters

joystick
button

Return Value

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick.Index Method

public static int Index(
IntPtr joystick
);

Parameters

joystick

Return Value

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick.Name Method

public static string Name(
int index
);

Parameters

index

Return Value

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick.NumAxes Method

public static int NumAxes(
IntPtr joystick
);

Parameters

joystick

Return Value

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick.NumButtons Method

public static int NumButtons(
IntPtr joystick
);

Parameters

joystick

Return Value

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick.NumJoysticks Method

public static int NumJoysticks();

Return Value

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick.Open Method

public static IntPtr Open(
int index
);

Parameters

index

Return Value

See Also

Joystick Class | y4cs.sdl.joystick Namespace


Joystick.Update Method

public static void Update();

See Also

Joystick Class | y4cs.sdl.joystick Namespace


y4cs.sdl.keyboard

Yaneurao Game Library 4th for C#

y4cs.sdl.keyboard Namespace

Classes

Class | Description
Keyboard |


Keyboard Class

For a list of all members of this type, see Keyboard Members.

System.Object
Keyboard

public abstract class Keyboard

Requirements

Namespace: y4cs.sdl.keyboard

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Keyboard Members | y4cs.sdl.keyboard Namespace


Keyboard Members

Keyboard overview

Public Static Methods

GetKeyState

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

Keyboard Constructor Initializes a new instance of the Keyboard class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Keyboard Class | y4cs.sdl.keyboard Namespace


Keyboard Constructor

Initializes a new instance of the Keyboard class.

protected Keyboard();

See Also

Keyboard Class | y4cs.sdl.keyboard Namespace


Keyboard Methods

The methods of the Keyboard class are listed below. For a complete list of Keyboard class members, see the Keyboard Members topic.

Public Static Methods

GetKeyState

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Keyboard Class | y4cs.sdl.keyboard Namespace


Keyboard.GetKeyState Method

public static IntPtr GetKeyState(
IntPtr pkey
);

Parameters

pkey

Return Value

See Also

Keyboard Class | y4cs.sdl.keyboard Namespace


y4cs.sdl.mixer

Yaneurao Game Library 4th for C#

y4cs.sdl.mixer Namespace

Classes

Class | Description
Mix |

Structures

Structure | Description
Mix_Chunk |


Mix Class

For a list of all members of this type, see Mix Members.

System.Object
Mix

public abstract class Mix

Requirements

Namespace: y4cs.sdl.mixer

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Mix Members | y4cs.sdl.mixer Namespace


Mix Members

Mix overview

Public Static Methods

CloseAudio
FadeInChannel
FadeInChannelTimed
FadeInMusic
FadeOutChannel
FadeOutMusic
FreeChunk
FreeMusic
HaltChannel
HaltMusic
LoadMUS
LoadWAV_RW
OpenAudio
Pause
PauseMusic
PlayChannel
PlayChannelTimed
Playing
PlayingMusic
PlayMusic

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

Mix Constructor Initializes a new instance of the Mix class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix Constructor

Initializes a new instance of the Mix class.

protected Mix();

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix Methods

The methods of the Mix class are listed below. For a complete list of Mix class members, see the Mix Members topic.

Public Static Methods

CloseAudio
FadeInChannel
FadeInChannelTimed
FadeInMusic
FadeOutChannel
FadeOutMusic
FreeChunk
FreeMusic
HaltChannel
HaltMusic
LoadMUS
LoadWAV_RW
OpenAudio
Pause
PauseMusic
PlayChannel
PlayChannelTimed
Playing
PlayingMusic
PlayMusic

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.CloseAudio Method

public static void CloseAudio();

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.FadeInChannel Method

public static int FadeInChannel(
int channel,
IntPtr chunk,
int loops,
int ms
);

Parameters

channel
chunk
loops
ms

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.FadeInChannelTimed Method

public static int FadeInChannelTimed(
int channel,
IntPtr chunk,
int loops,
int ms,
int ticks
);

Parameters

channel
chunk
loops
ms
ticks

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.FadeInMusic Method

public static int FadeInMusic(
IntPtr music,
int loops,
int ms
);

Parameters

music
loops
ms

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.FadeOutChannel Method

public static int FadeOutChannel(
int channel,
int ms
);

Parameters

channel
ms

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.FadeOutMusic Method

public static int FadeOutMusic(
int ms
);

Parameters

ms

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.FreeChunk Method

public static void FreeChunk(
IntPtr chunk
);

Parameters

chunk

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.FreeMusic Method

public static void FreeMusic(
IntPtr music
);

Parameters

music

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.HaltChannel Method

public static int HaltChannel(
int channel
);

Parameters

channel

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.HaltMusic Method

public static int HaltMusic();

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.LoadMUS Method

public static IntPtr LoadMUS(
string file
);

Parameters

file

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.LoadWAV_RW Method

public static IntPtr LoadWAV_RW(
IntPtr src,
int freesrc
);

Parameters

src
freesrc

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.OpenAudio Method

public static int OpenAudio(
int frequency,
AUDIO format,
int channels,
int chunksize
);

Parameters

frequency
format
channels
chunksize

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.Pause Method

public static void Pause(
int channel
);

Parameters

channel

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.PauseMusic Method

public static void PauseMusic();

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.PlayChannel Method

public static int PlayChannel(
int channel,
IntPtr chunk,
int loops
);

Parameters

channel
chunk
loops

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.PlayChannelTimed Method

public static int PlayChannelTimed(
int channel,
IntPtr chunk,
int loops,
int ticks
);

Parameters

channel
chunk
loops
ticks

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.Playing Method

public static int Playing(
int channel
);

Parameters

channel

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.PlayingMusic Method

public static int PlayingMusic();

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix.PlayMusic Method

public static int PlayMusic(
IntPtr music,
int loops
);

Parameters

music
loops

Return Value

See Also

Mix Class | y4cs.sdl.mixer Namespace


Mix_Chunk Structure

For a list of all members of this type, see Mix_Chunk Members.

System.Object
ValueType
Mix_Chunk

public struct Mix_Chunk

Requirements

Namespace: y4cs.sdl.mixer

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Mix_Chunk Members | y4cs.sdl.mixer Namespace


Mix_Chunk Members

Mix_Chunk overview

Public Instance Fields

abuf
alen
allocated
volume

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Mix_Chunk Class | y4cs.sdl.mixer Namespace


Mix_Chunk Fields

The fields of the Mix_Chunk structure are listed below. For a complete list of Mix_Chunk structure members, see the Mix_Chunk Members topic.

Public Instance Fields

abuf
alen
allocated
volume

See Also

Mix_Chunk Class | y4cs.sdl.mixer Namespace


Mix_Chunk.abuf Field

public IntPtr abuf;

See Also

Mix_Chunk Class | y4cs.sdl.mixer Namespace


Mix_Chunk.alen Field

public uint alen;

See Also

Mix_Chunk Class | y4cs.sdl.mixer Namespace


Mix_Chunk.allocated Field

public int allocated;

See Also

Mix_Chunk Class | y4cs.sdl.mixer Namespace


Mix_Chunk.volume Field

public byte volume;

See Also

Mix_Chunk Class | y4cs.sdl.mixer Namespace


y4cs.sdl.video

Yaneurao Game Library 4th for C#

y4cs.sdl.video Namespace

Classes

Class | Description
Video |

Structures

Structure | Description
SDL_Color |
SDL_Palette |
SDL_PixelFormat |
SDL_Rect |
SDL_Surface |


SDL_Color Structure

For a list of all members of this type, see SDL_Color Members.

System.Object
ValueType
SDL_Color

public struct SDL_Color

Requirements

Namespace: y4cs.sdl.video

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_Color Members | y4cs.sdl.video Namespace


SDL_Color Members

SDL_Color overview

Public Instance Fields

b
g
r
unused

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_Color Class | y4cs.sdl.video Namespace


SDL_Color Fields

The fields of the SDL_Color structure are listed below. For a complete list of SDL_Color structure members, see the SDL_Color Members topic.

Public Instance Fields

b
g
r
unused

See Also

SDL_Color Class | y4cs.sdl.video Namespace


SDL_Color.b Field

public byte b;

See Also

SDL_Color Class | y4cs.sdl.video Namespace


SDL_Color.g Field

public byte g;

See Also

SDL_Color Class | y4cs.sdl.video Namespace


SDL_Color.r Field

public byte r;

See Also

SDL_Color Class | y4cs.sdl.video Namespace


SDL_Color.unused Field

public byte unused;

See Also

SDL_Color Class | y4cs.sdl.video Namespace


SDL_Palette Structure

For a list of all members of this type, see SDL_Palette Members.

System.Object
ValueType
SDL_Palette

public struct SDL_Palette

Requirements

Namespace: y4cs.sdl.video

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_Palette Members | y4cs.sdl.video Namespace


SDL_Palette Members

SDL_Palette overview

Public Instance Fields

colors
ncolors

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_Palette Class | y4cs.sdl.video Namespace


SDL_Palette Fields

The fields of the SDL_Palette structure are listed below. For a complete list of SDL_Palette structure members, see the SDL_Palette Members topic.

Public Instance Fields

colors
ncolors

See Also

SDL_Palette Class | y4cs.sdl.video Namespace


SDL_Palette.colors Field

public SDL_Color* colors;

See Also

SDL_Palette Class | y4cs.sdl.video Namespace


SDL_Palette.ncolors Field

public int ncolors;

See Also

SDL_Palette Class | y4cs.sdl.video Namespace


SDL_PixelFormat Structure

For a list of all members of this type, see SDL_PixelFormat Members.

System.Object
ValueType
SDL_PixelFormat

public struct SDL_PixelFormat

Requirements

Namespace: y4cs.sdl.video

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_PixelFormat Members | y4cs.sdl.video Namespace


SDL_PixelFormat Members

SDL_PixelFormat overview

Public Instance Fields

Aloss
alpha
Amask
Ashift
BitsPerPixel
Bloss
Bmask
Bshift
BytesPerPixel
colorkey
Gloss
Gmask
Gshift
palette
Rloss
Rmask
Rshift

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat Fields

The fields of the SDL_PixelFormat structure are listed below. For a complete list of SDL_PixelFormat structure members, see the SDL_PixelFormat Members topic.

Public Instance Fields

Aloss
alpha
Amask
Ashift
BitsPerPixel
Bloss
Bmask
Bshift
BytesPerPixel
colorkey
Gloss
Gmask
Gshift
palette
Rloss
Rmask
Rshift

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Aloss Field

public byte Aloss;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.alpha Field

public byte alpha;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Amask Field

public uint Amask;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Ashift Field

public byte Ashift;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.BitsPerPixel Field

public byte BitsPerPixel;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Bloss Field

public byte Bloss;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Bmask Field

public uint Bmask;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Bshift Field

public byte Bshift;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.BytesPerPixel Field

public byte BytesPerPixel;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.colorkey Field

public uint colorkey;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Gloss Field

public byte Gloss;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Gmask Field

public uint Gmask;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Gshift Field

public byte Gshift;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.palette Field

public SDL_Palette* palette;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Rloss Field

public byte Rloss;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Rmask Field

public uint Rmask;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_PixelFormat.Rshift Field

public byte Rshift;

See Also

SDL_PixelFormat Class | y4cs.sdl.video Namespace


SDL_Rect Structure

For a list of all members of this type, see SDL_Rect Members.

System.Object
ValueType
SDL_Rect

public struct SDL_Rect

Requirements

Namespace: y4cs.sdl.video

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_Rect Members | y4cs.sdl.video Namespace


SDL_Rect Members

SDL_Rect overview

Public Instance Fields

h
w
x
y

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_Rect Class | y4cs.sdl.video Namespace


SDL_Rect Fields

The fields of the SDL_Rect structure are listed below. For a complete list of SDL_Rect structure members, see the SDL_Rect Members topic.

Public Instance Fields

h
w
x
y

See Also

SDL_Rect Class | y4cs.sdl.video Namespace


SDL_Rect.h Field

public ushort h;

See Also

SDL_Rect Class | y4cs.sdl.video Namespace


SDL_Rect.w Field

public ushort w;

See Also

SDL_Rect Class | y4cs.sdl.video Namespace


SDL_Rect.x Field

public short x;

See Also

SDL_Rect Class | y4cs.sdl.video Namespace


SDL_Rect.y Field

public short y;

See Also

SDL_Rect Class | y4cs.sdl.video Namespace


SDL_Surface Structure

For a list of all members of this type, see SDL_Surface Members.

System.Object
ValueType
SDL_Surface

public struct SDL_Surface

Requirements

Namespace: y4cs.sdl.video

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SDL_Surface Members | y4cs.sdl.video Namespace


SDL_Surface Members

SDL_Surface overview

Public Instance Fields

clip_rect
flags
format
format_version
h
hwdata
locked
map
offset
pitch
pixels
refcount
unused1
w

Public Instance Methods

Equals (inherited from ValueType)
GetHashCode (inherited from ValueType)
GetType (inherited from Object)
ToString (inherited from ValueType)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface Fields

The fields of the SDL_Surface structure are listed below. For a complete list of SDL_Surface structure members, see the SDL_Surface Members topic.

Public Instance Fields

clip_rect
flags
format
format_version
h
hwdata
locked
map
offset
pitch
pixels
refcount
unused1
w

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.clip_rect Field

public SDL_Rect clip_rect;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.flags Field

public uint flags;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.format Field

public SDL_PixelFormat* format;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.format_version Field

public uint format_version;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.h Field

public int h;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.hwdata Field

public IntPtr hwdata;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.locked Field

public uint locked;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.map Field

public IntPtr map;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.offset Field

public int offset;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.pitch Field

public ushort pitch;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.pixels Field

public IntPtr pixels;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.refcount Field

public int refcount;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.unused1 Field

public uint unused1;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


SDL_Surface.w Field

public int w;

See Also

SDL_Surface Class | y4cs.sdl.video Namespace


Video Class

For a list of all members of this type, see Video Members.

System.Object
Video

public abstract class Video

Requirements

Namespace: y4cs.sdl.video

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Video Members | y4cs.sdl.video Namespace


Video Members

Video overview

Public Static Methods

BlitSurface
CreateRGBSurface
FillRect
FreeSurface
GL_SetAttribute
GL_SwapBuffers
LockSurface
SaveBMP
SetAlpha
SetVideoMode
UnlockSurface
UpperBlit

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Constructors

Video Constructor Initializes a new instance of the Video class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Video Class | y4cs.sdl.video Namespace


Video Constructor

Initializes a new instance of the Video class.

protected Video();

See Also

Video Class | y4cs.sdl.video Namespace


Video Methods

The methods of the Video class are listed below. For a complete list of Video class members, see the Video Members topic.

Public Static Methods

BlitSurface
CreateRGBSurface
FillRect
FreeSurface
GL_SetAttribute
GL_SwapBuffers
LockSurface
SaveBMP
SetAlpha
SetVideoMode
UnlockSurface
UpperBlit

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Video Class | y4cs.sdl.video Namespace


Video.BlitSurface Method

public static int BlitSurface(
IntPtr src,
IntPtr srcrect,
IntPtr dst,
IntPtr dstrect
);

Parameters

src
srcrect
dst
dstrect

Return Value

See Also

Video Class | y4cs.sdl.video Namespace


Video.CreateRGBSurface Method

public static IntPtr CreateRGBSurface(
SDL_SURFACE flags,
int width,
int height,
int depth,
uint Rmask,
uint Gmask,
uint Bmask,
uint Amask
);

Parameters

flags
width
height
depth
Rmask
Gmask
Bmask
Amask

Return Value

See Also

Video Class | y4cs.sdl.video Namespace


Video.FillRect Method

public static int FillRect(
IntPtr dst,
IntPtr dstrect,
uint color
);

Parameters

dst
dstrect
color

Return Value

See Also

Video Class | y4cs.sdl.video Namespace


Video.FreeSurface Method

public static void FreeSurface(
IntPtr surface
);

Parameters

surface

See Also

Video Class | y4cs.sdl.video Namespace


Video.GL_SetAttribute Method

public static int GL_SetAttribute(
int attr,
int value
);

Parameters

attr
value

Return Value

See Also

Video Class | y4cs.sdl.video Namespace


Video.GL_SwapBuffers Method

public static void GL_SwapBuffers();

See Also

Video Class | y4cs.sdl.video Namespace


Video.LockSurface Method

public static int LockSurface(
IntPtr surface
);

Parameters

surface

Return Value

See Also

Video Class | y4cs.sdl.video Namespace


Video.SaveBMP Method

public static int SaveBMP(
IntPtr surface,
string file
);

Parameters

surface
file

Return Value

See Also

Video Class | y4cs.sdl.video Namespace


Video.SetAlpha Method

public static int SetAlpha(
IntPtr surface,
uint flag,
byte alpha
);

Parameters

surface
flag
alpha

Return Value

See Also

Video Class | y4cs.sdl.video Namespace


Video.SetVideoMode Method

public static IntPtr SetVideoMode(
int width,
int height,
int bpp,
SDL_SURFACE flags
);

Parameters

width
height
bpp
flags

Return Value

See Also

Video Class | y4cs.sdl.video Namespace


Video.UnlockSurface Method

public static void UnlockSurface(
IntPtr surface
);

Parameters

surface

See Also

Video Class | y4cs.sdl.video Namespace


Video.UpperBlit Method

public static int UpperBlit(
IntPtr src,
IntPtr srcrect,
IntPtr dst,
IntPtr dstrect
);

Parameters

src
srcrect
dst
dstrect

Return Value

See Also

Video Class | y4cs.sdl.video Namespace


y4cs.sound

Yaneurao Game Library 4th for C#

y4cs.sound Namespace

Classes

Class | Description
CDDA | CD-ROMの再生(CDDA)。
Sound | サウンド再生用クラス。
SoundConfig | Sound クラスのための再生品質設定クラス。
SoundLoader | Sound の一括読み込みクラス。
SoundLoader.SoundInfo |


CDDA Class

CD-ROMの再生(CDDA)。

For a list of all members of this type, see CDDA Members.

System.Object
CDDA

public class CDDA : IDisposable

Remarks

複数ドライブの同時再生にも対応。 @todo : 作りかけ SDL_CDNumDrives()が-1返す(;´Д`)

Requirements

Namespace: y4cs.sound

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

CDDA Members | y4cs.sound Namespace


CDDA Members

CDDA overview

Public Static Methods

getDriveNum 接続されているCD-ROMの数を返す。

Public Instance Constructors

CDDA Constructor Initializes a new instance of the CDDA class.

Public Instance Methods

close | CDを閉じる。
Dispose | Overloaded.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isPlay | CD再生中かを返す。
open | CD-ROMをopenする。
playTrack | 指定したトラックを再生します。
ToString (inherited from Object) |

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

CDDA Class | y4cs.sound Namespace


CDDA Constructor

Initializes a new instance of the CDDA class.

public CDDA();

See Also

CDDA Class | y4cs.sound Namespace


CDDA Methods

The methods of the CDDA class are listed below. For a complete list of CDDA class members, see the CDDA Members topic.

Public Static Methods

getDriveNum 接続されているCD-ROMの数を返す。

Public Instance Methods

close | CDを閉じる。
Dispose | Overloaded.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isPlay | CD再生中かを返す。
open | CD-ROMをopenする。
playTrack | 指定したトラックを再生します。
ToString (inherited from Object) |

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

CDDA Class | y4cs.sound Namespace


CDDA.close Method

CDを閉じる。

public void close();

Remarks

CD使いおわったら閉じてください。 デストラクタから close が呼び出されるので 閉じ忘れても一応は安全ですが。

See Also

CDDA Class | y4cs.sound Namespace


Dispose Method

Yaneurao Game Library 4th for C#

CDDA.Dispose Method

Overload List

public void Dispose();

protected void Dispose(bool);

See Also

CDDA Class | y4cs.sound Namespace


CDDA.Dispose Method ()

public void Dispose();

Implements

IDisposable.Dispose

See Also

CDDA Class | y4cs.sound Namespace | CDDA.Dispose Overload List


CDDA.Dispose Method (Boolean)

protected void Dispose(
bool disposing
);

Parameters

disposing

See Also

CDDA Class | y4cs.sound Namespace | CDDA.Dispose Overload List


CDDA.Finalize Method

protected override void Finalize();

See Also

CDDA Class | y4cs.sound Namespace


CDDA.getDriveNum Method

接続されているCD-ROMの数を返す。

public static int getDriveNum();

See Also

CDDA Class | y4cs.sound Namespace


CDDA.isPlay Method

CD再生中かを返す。

public bool isPlay();

Remarks

playTrackのあと呼び出すと良い。

See Also

CDDA Class | y4cs.sound Namespace


CDDA.open Method

CD-ROMをopenする。

public int open(
int no
);

Parameters

no

Return Value

openに失敗すれば非0が返る。

Remarks

システムディフォルトのCDは必ず no は 0。 getDriveNum で返ってくる値-1 までを指定することが出来る。

See Also

CDDA Class | y4cs.sound Namespace


CDDA.playTrack Method

指定したトラックを再生します。

public int playTrack(
int track
);

Remarks

トラックナンバーは0～

See Also

CDDA Class | y4cs.sound Namespace


Sound Class

サウンド再生用クラス。

For a list of all members of this type, see Sound Members.

System.Object
Sound

public class Sound : ICacheObject, IDisposable

Remarks

サウンド再生の考えかた １．music(bgm) + chuck(se)×8　の9個を同時にミキシングして出力出来る ２．次のmusicが再生されると前のmusicは自動的に停止する ３．seを再生するときには1～8のchuck(チャンク)ナンバーを指定できる 同じchuckナンバーのseを再生すると、前回再生していたものは 自動的に停止する ４．musicもchunkも、どちらもwav,riff,ogg...etcを再生する能力を持つ ５．midi再生に関しては、musicチャンネルのみ。 つまり、musicとchunkに関しては、５．６．の違いを除けば同等の機能を持つ。 ６．チャンクは、0を指定しておけば、1～8の再生していないチャンクを 自動的に探す。 ７．bgmとして、musicチャンネルを用いない場合(midiか、途中から再生 させるわけでもない限りは用いる必要はないと思われる)、 bgmのクロスフェードなども出来る。

Example

使用例)

            Sound s = new Sound;
            s.load("1.ogg",-1);
            s.setLoop(-1); // endless
            s.play();

            Sound s2 = new Sound;
            s2.load("extend.wav",1);
            s2.play();
@todo volume管理(気が向いたら)

Requirements

Namespace: y4cs.sound

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Sound Members | y4cs.sound Namespace


Sound Members

Sound overview

Public Static Methods

fadeChunk
fadeMusic
getConfig
stopAll
stopAllChunk
stopMusic

Public Instance Constructors

Sound Constructor Initializes a new instance of the Sound class.

Public Instance Methods

Dispose |
Equals (inherited from Object) |
getBufferSize |
GetHashCode (inherited from Object) |
getLoop |
GetType (inherited from Object) |
isPlay |
load | サウンドファイルを読み込む (読み込みエラーならば非0が返る)。
play | loadで読み込んだサウンドを再生する(再生エラーならば非0が返る)。
playFade |
release |
setLoop | ループ回数の設定。
stop |
stopFade |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Sound Class | y4cs.sound Namespace


Sound Constructor

Initializes a new instance of the Sound class.

public Sound();

See Also

Sound Class | y4cs.sound Namespace


Sound Methods

The methods of the Sound class are listed below. For a complete list of Sound class members, see the Sound Members topic.

Public Static Methods

fadeChunk
fadeMusic
getConfig
stopAll
stopAllChunk
stopMusic

Public Instance Methods

Dispose |
Equals (inherited from Object) |
getBufferSize |
GetHashCode (inherited from Object) |
getLoop |
GetType (inherited from Object) |
isPlay |
load | サウンドファイルを読み込む (読み込みエラーならば非0が返る)。
play | loadで読み込んだサウンドを再生する(再生エラーならば非0が返る)。
playFade |
release |
setLoop | ループ回数の設定。
stop |
stopFade |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Sound Class | y4cs.sound Namespace


Sound.Dispose Method

public void Dispose();

Implements

IDisposable.Dispose

See Also

Sound Class | y4cs.sound Namespace


Sound.fadeChunk Method

public static y4cs_result fadeChunk(
int speed
);

See Also

Sound Class | y4cs.sound Namespace


Sound.fadeMusic Method

public static y4cs_result fadeMusic(
int speed
);

See Also

Sound Class | y4cs.sound Namespace


Sound.getBufferSize Method

public ulong getBufferSize();

Implements

ICacheObject.getBufferSize

See Also

Sound Class | y4cs.sound Namespace


Sound.getConfig Method

public static SoundConfig getConfig();

Return Value

See Also

Sound Class | y4cs.sound Namespace


Sound.getLoop Method

public int getLoop();

See Also

Sound Class | y4cs.sound Namespace


Sound.isPlay Method

public bool isPlay();

See Also

Sound Class | y4cs.sound Namespace


Sound.load Method

サウンドファイルを読み込む (読み込みエラーならば非0が返る)。

public y4cs_result load(
string filename,
int ch
);

Parameters

filename
ファイル名
ch
読み込むチャンネル -1 : musicチャンネル 0 : 1～8のchunkのうち再生時(play)に再生していないチャンネルをおまかせで 1～8 : chunkに読み込む

Return Value

See Also

Sound Class | y4cs.sound Namespace


Sound.play Method

loadで読み込んだサウンドを再生する(再生エラーならば非0が返る)。

public y4cs_result play();

Return Value

See Also

Sound Class | y4cs.sound Namespace


Sound.playFade Method

public y4cs_result playFade(
int speed
);

See Also

Sound Class | y4cs.sound Namespace


Sound.release Method

public void release();

See Also

Sound Class | y4cs.sound Namespace


Sound.setLoop Method

ループ回数の設定。

public void setLoop(
int loop
);

Parameters

loop
-1:endless 0 :1回のみ(default) 1 :2回 以下、再生したい回数-1を指定する。

Remarks

ここで設定した値は一度設定すれば再度この関数で 変更しない限り変わらない

See Also

Sound Class | y4cs.sound Namespace


Sound.stop Method

public y4cs_result stop();

See Also

Sound Class | y4cs.sound Namespace


Sound.stopAll Method

public static y4cs_result stopAll();

See Also

Sound Class | y4cs.sound Namespace


Sound.stopAllChunk Method

public static void stopAllChunk();

See Also

Sound Class | y4cs.sound Namespace


Sound.stopFade Method

public y4cs_result stopFade(
int speed
);

See Also

Sound Class | y4cs.sound Namespace


Sound.stopMusic Method

public static y4cs_result stopMusic();

See Also

Sound Class | y4cs.sound Namespace


SoundConfig Class

Sound クラスのための再生品質設定クラス。

For a list of all members of this type, see SoundConfig Members.

System.Object
SoundConfig

public class SoundConfig : IDisposable

Remarks

            int audio_rate; // = 44100;
            ushort audio_format; // = AUDIO_S16;
            int audio_channels; //	= 2;
            int audio_buffers; // = 4096;
初期状態では上記のようになっている。 あえて変更したければsingletonオブジェクト通じて変更すること。

Example

例) instance singleton(SoundConfig).audio_channels = 1;

Requirements

Namespace: y4cs.sound

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SoundConfig Members | y4cs.sound Namespace


SoundConfig Members

SoundConfig overview

Public Instance Constructors

SoundConfig Constructor Initializes a new instance of the SoundConfig class.

Public Instance Fields

audio_buffers | 再生バッファ長[bytes](default:4096)。
audio_channels | 再生チャンネル数(default:2)。
audio_format | 再生ビット数(default:AUDIO_S16)。
audio_rate | 再生周波数(default:44100)。

Public Instance Methods

Dispose | Overloaded.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

SoundConfig Class | y4cs.sound Namespace


SoundConfig Constructor

Initializes a new instance of the SoundConfig class.

public SoundConfig();

See Also

SoundConfig Class | y4cs.sound Namespace


SoundConfig Fields

The fields of the SoundConfig class are listed below. For a complete list of SoundConfig class members, see the SoundConfig Members topic.

Public Instance Fields

audio_buffers | 再生バッファ長[bytes](default:4096)。
audio_channels | 再生チャンネル数(default:2)。
audio_format | 再生ビット数(default:AUDIO_S16)。
audio_rate | 再生周波数(default:44100)。

See Also

SoundConfig Class | y4cs.sound Namespace


SoundConfig.audio_buffers Field

再生バッファ長[bytes](default:4096)。

public int audio_buffers;

See Also

SoundConfig Class | y4cs.sound Namespace


SoundConfig.audio_channels Field

再生チャンネル数(default:2)。

public int audio_channels;

See Also

SoundConfig Class | y4cs.sound Namespace


SoundConfig.audio_format Field

再生ビット数(default:AUDIO_S16)。

public ushort audio_format;

Remarks

このAUDIO_S16というのは、SDL_audio.d で定義されている。

See Also

SoundConfig Class | y4cs.sound Namespace


SoundConfig.audio_rate Field

再生周波数(default:44100)。

public int audio_rate;

See Also

SoundConfig Class | y4cs.sound Namespace


SoundConfig Methods

The methods of the SoundConfig class are listed below. For a complete list of SoundConfig class members, see the SoundConfig Members topic.

Public Instance Methods

Dispose | Overloaded.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Methods

Dispose | Overloaded.
Finalize |
MemberwiseClone (inherited from Object) |

See Also

SoundConfig Class | y4cs.sound Namespace


Dispose Method

Yaneurao Game Library 4th for C#

SoundConfig.Dispose Method

Overload List

public void Dispose();

protected void Dispose(bool);

See Also

SoundConfig Class | y4cs.sound Namespace


SoundConfig.Dispose Method ()

public void Dispose();

Implements

IDisposable.Dispose

See Also

SoundConfig Class | y4cs.sound Namespace | SoundConfig.Dispose Overload List


SoundConfig.Dispose Method (Boolean)

protected void Dispose(
bool disposing
);

Parameters

disposing

See Also

SoundConfig Class | y4cs.sound Namespace | SoundConfig.Dispose Overload List


SoundConfig.Finalize Method

protected override void Finalize();

See Also

SoundConfig Class | y4cs.sound Namespace


SoundLoader Class

Sound の一括読み込みクラス。

For a list of all members of this type, see SoundLoader Members.

System.Object
Iter
CacheLoader
SoundLoader

public class SoundLoader : CacheLoader

Remarks

Sound を cache したり、自動解放したりいろいろします。 詳しいことは、親クラス CacheLoader を見てください。 int loadDefFile(char[] filename); で読み込む定義ファイルは、 a.wav , 2 , -1 b.wav ,,-1 のように書き、ひとつ目は、ファイル名、二つ目は、読み込む番号、3つ目は optionである。optionとして再生するチャンクナンバーを指定できる。 これは指定しない場合0を意味し、その場合、その時点で再生していないチャンクを 用いて再生する。

Example

クロスフェードのサンプル：

            int main(){
                SoundLoader ca = new SoundLoader;
                ca.loadDefFile("filelist.txt");
                //	この↑ファイルの中身は、
                //		1.ogg
                //		2.ogg
                //	と、再生するファイル名が書いてある

                ca.playBGMFade(0,3000);
                //	0番目のファイルを読み込み、そいつをフェードインさせながら再生
                // ca.get(0).playFade(3000);でも可

                Timer t = new Timer;

                while(t.get()<5000) {}

                // ca.playBGMFade(1,3000);
                //	1番目のファイルをフェードイン再生
                // ca.stopBGMFade(0,3000);
                //	0番目のファイルをフェードアウト再生

                ca.playBGMCrossFade(1,3000); // こんな関数もある。

                t.reset();
                while(t.get()<5000) {}

                return 0;
            }
※　サウンドにおけるクロスフェードとは、片方のBGMがフェードしながら、もう片方がフェードインしてくることを言います。 このoptionは、 Sound クラスで load のときに指定する、 chunk番号として渡される。指定しなければ0である。

Requirements

Namespace: y4cs.sound

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SoundLoader Members | y4cs.sound Namespace


SoundLoader Members

SoundLoader overview

Public Instance Constructors

SoundLoader Constructor Initializes a new instance of the SoundLoader class.

Public Instance Properties

Current (inherited from CacheLoader)
IsRunning (inherited from y4cs.native.iterator.Iter)
IsStarted (inherited from y4cs.native.iterator.Iter)

Public Instance Methods

checkRelease (inherited from CacheLoader) | 解放妥当性のチェック。
createInstance |
Dispose (inherited from y4cs.native.iterator.Iter) |
enableSound | サウンドの有効/無効の切り替え。
Equals (inherited from Object) |
get |
getCacheFiles (inherited from CacheLoader) | cacheしているファイル数を返す。
getCacheSize (inherited from CacheLoader) | cacheするバッファの上限を取得。
GetEnumerator (inherited from CacheLoader) |
getGuardTime |
GetHashCode (inherited from Object) |
getInfoList (inherited from CacheLoader) | ファイルリストの取得。
getObj |
GetType (inherited from Object) |
isEnableSound | enableSoundで設定した値を読み出す。
isin (inherited from CacheLoader) | オブジェクトが生成されているかを調べる。
isPlay |
loadDefFile (inherited from CacheLoader) | 定義ファイルを読み込む。
loadDefRW (inherited from CacheLoader) | キャッシュリストを手渡しするための関数。
MoveNext (inherited from CacheLoader) |
play |
playBGM |
playBGMCrossFade |
playBGMFade |
playFade |
playSE | SE再生用のplay関数。
playSEFade |
print (inherited from CacheLoader) | 保持しているファイルリストの表示(デバッグ用)。
releaseAll (inherited from CacheLoader) | 保持していたキャッシュを解放する(ファイルリストは解放しない)。
releaseFileList (inherited from CacheLoader) | 保持していたファイルリスト、キャッシュを解放する。
releaseOldObject (inherited from CacheLoader) | 一番昔の時刻にアクセスされたファイルを解放するメソッド。
Reset (inherited from CacheLoader) |
resetGuardTime |
Resume (inherited from y4cs.native.iterator.Iter) |
setCacheSize (inherited from CacheLoader) | cacheするバッファの上限を決める。
setGuardTime |
setUpdateCacheDelegate (inherited from CacheLoader) | 古いキャッシュの破棄メソッドの登録。
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
stop |
stopBGM |
stopBGMFade |
stopFade |
ToString (inherited from Object) |
updateFileList (inherited from CacheLoader) | ファイルリストを反映させる。
updateSE |

Protected Instance Fields

bgmNo |
bSoundEnable |
bStarted_ (inherited from y4cs.native.iterator.Iter) |
cachefiles (inherited from CacheLoader) | 実体を読み込んでいるファイルの数
cacheSize (inherited from CacheLoader) | cacheするサウンドバッファの上限(-1ならば無制限)。
filelist (inherited from CacheLoader) | ファイルリスト。
guardTime |
iterStart (inherited from y4cs.native.iterator.Iter) |
nowtime (inherited from CacheLoader) |
readPath (inherited from CacheLoader) | 実ファイル読み込みフォルダ。
state (inherited from y4cs.native.iterator.Iter) |
updateCacheDelegate (inherited from CacheLoader) | updateCacheで呼び出すdelegate。

Protected Instance Methods

checkCache |
createInfo |
Finalize (inherited from CacheLoader) |
getHelpper (inherited from CacheLoader) | 番号に対応するオブジェクトを読み込み、loadメソッドを呼び出す。
getHelpperObj (inherited from CacheLoader) | 番号に対応するオブジェクトを返す。
loadFile |
MemberwiseClone (inherited from Object) |
releaseCheck |
releaseFile |
yield (inherited from y4cs.native.iterator.Iter) |

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader Constructor

Initializes a new instance of the SoundLoader class.

public SoundLoader();

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader Fields

The fields of the SoundLoader class are listed below. For a complete list of SoundLoader class members, see the SoundLoader Members topic.

Protected Instance Fields

bgmNo |
bSoundEnable |
bStarted_ (inherited from y4cs.native.iterator.Iter) |
cachefiles (inherited from CacheLoader) | 実体を読み込んでいるファイルの数
cacheSize (inherited from CacheLoader) | cacheするサウンドバッファの上限(-1ならば無制限)。
filelist (inherited from CacheLoader) | ファイルリスト。
guardTime |
iterStart (inherited from y4cs.native.iterator.Iter) |
nowtime (inherited from CacheLoader) |
readPath (inherited from CacheLoader) | 実ファイル読み込みフォルダ。
state (inherited from y4cs.native.iterator.Iter) |
updateCacheDelegate (inherited from CacheLoader) | updateCacheで呼び出すdelegate。

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.bgmNo Field

protected int bgmNo;

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.bSoundEnable Field

protected bool bSoundEnable;

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.guardTime Field

protected int guardTime;

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader Methods

The methods of the SoundLoader class are listed below. For a complete list of SoundLoader class members, see the SoundLoader Members topic.

Public Instance Methods

checkRelease (inherited from CacheLoader) | 解放妥当性のチェック。
createInstance |
Dispose (inherited from y4cs.native.iterator.Iter) |
enableSound | サウンドの有効/無効の切り替え。
Equals (inherited from Object) |
get |
getCacheFiles (inherited from CacheLoader) | cacheしているファイル数を返す。
getCacheSize (inherited from CacheLoader) | cacheするバッファの上限を取得。
GetEnumerator (inherited from CacheLoader) |
getGuardTime |
GetHashCode (inherited from Object) |
getInfoList (inherited from CacheLoader) | ファイルリストの取得。
getObj |
GetType (inherited from Object) |
isEnableSound | enableSoundで設定した値を読み出す。
isin (inherited from CacheLoader) | オブジェクトが生成されているかを調べる。
isPlay |
loadDefFile (inherited from CacheLoader) | 定義ファイルを読み込む。
loadDefRW (inherited from CacheLoader) | キャッシュリストを手渡しするための関数。
MoveNext (inherited from CacheLoader) |
play |
playBGM |
playBGMCrossFade |
playBGMFade |
playFade |
playSE | SE再生用のplay関数。
playSEFade |
print (inherited from CacheLoader) | 保持しているファイルリストの表示(デバッグ用)。
releaseAll (inherited from CacheLoader) | 保持していたキャッシュを解放する(ファイルリストは解放しない)。
releaseFileList (inherited from CacheLoader) | 保持していたファイルリスト、キャッシュを解放する。
releaseOldObject (inherited from CacheLoader) | 一番昔の時刻にアクセスされたファイルを解放するメソッド。
Reset (inherited from CacheLoader) |
resetGuardTime |
Resume (inherited from y4cs.native.iterator.Iter) |
setCacheSize (inherited from CacheLoader) | cacheするバッファの上限を決める。
setGuardTime |
setUpdateCacheDelegate (inherited from CacheLoader) | 古いキャッシュの破棄メソッドの登録。
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
stop |
stopBGM |
stopBGMFade |
stopFade |
ToString (inherited from Object) |
updateFileList (inherited from CacheLoader) | ファイルリストを反映させる。
updateSE |

Protected Instance Methods

checkCache |
createInfo |
Finalize (inherited from CacheLoader) |
getHelpper (inherited from CacheLoader) | 番号に対応するオブジェクトを読み込み、loadメソッドを呼び出す。
getHelpperObj (inherited from CacheLoader) | 番号に対応するオブジェクトを返す。
loadFile |
MemberwiseClone (inherited from Object) |
releaseCheck |
releaseFile |
yield (inherited from y4cs.native.iterator.Iter) |

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.checkCache Method

protected override void checkCache();

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.createInfo Method

protected override Info createInfo();

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.createInstance Method

public override object createInstance();

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.enableSound Method

サウンドの有効/無効の切り替え。

public void enableSound(
bool bEnable
);

Parameters

bEnable

Remarks

初期状態ではenable(有効)状態。 これを無効にして、そのあと有効に戻したとき、playBGMで再生指定が されているBGMがあれば、有効に戻した瞬間にその番号のBGMを 再生する。

無効状態においては、play/playFade/playSE/playBGMの呼び出しすべてに おいて何も再生されないことが保証される。(ただし、このクラスを通じて 再生するときのみの話で、Soundクラスを直接getで取得して再生するならば この限りではない)

また、有効状態から無効状態へ切り替えた瞬間、musicとすべてのchunkでの 再生を停止させる。

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.get Method

public override object get(
int no
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.getGuardTime Method

public int getGuardTime();

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.getObj Method

public override object getObj(
int no
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.isEnableSound Method

enableSoundで設定した値を読み出す。

public bool isEnableSound();

Return Value

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.isPlay Method

public bool isPlay(
int no
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.loadFile Method

protected override y4cs_result loadFile(
string filename,
ref object obj,
int option1,
int option2
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.play Method

public y4cs_result play(
int no
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.playBGM Method

public y4cs_result playBGM(
int no
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.playBGMCrossFade Method

public y4cs_result playBGMCrossFade(
int no,
int speed
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.playBGMFade Method

public y4cs_result playBGMFade(
int no,
int speed
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.playFade Method

public y4cs_result playFade(
int no,
int speed
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.playSE Method

SE再生用のplay関数。

public y4cs_result playSE(
int no
);

Parameters

no

Return Value

Remarks

SEの再生は例えばシューティングで発弾時に行なわれたりして、 1フレーム間に何十回と同じSE再生を呼び出してしまうことがある。 そのときに、毎回SEの再生をサウンドミキサに要求していたのでは 確実にコマ落ちしてしまう。そこで、一定時間は同じ番号のSE再生要求は 無視する必要がある。それが、このplaySEである。

playSEで再生させたものをstopさせるときは stop/stopFade関数を用いれば良い。

この関数を用いる場合は、 updateSE を毎フレーム呼び出さないと いけないことに注意。

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.playSEFade Method

public y4cs_result playSEFade(
int no,
int speed
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.releaseCheck Method

protected bool releaseCheck(
Info info
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.releaseFile Method

protected override y4cs_result releaseFile(
ref object obj
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.resetGuardTime Method

public void resetGuardTime();

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.setGuardTime Method

public void setGuardTime(
int t
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.stop Method

public y4cs_result stop(
int no
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.stopBGM Method

public y4cs_result stopBGM();

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.stopBGMFade Method

public y4cs_result stopBGMFade(
int speed
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.stopFade Method

public y4cs_result stopFade(
int no,
int speed
);

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.updateSE Method

public void updateSE();

See Also

SoundLoader Class | y4cs.sound Namespace


SoundLoader.SoundInfo Class

For a list of all members of this type, see SoundLoader.SoundInfo Members.

System.Object
Info
SoundLoader.SoundInfo

public class SoundLoader.SoundInfo : Info

Requirements

Namespace: y4cs.sound

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SoundLoader.SoundInfo Members | y4cs.sound Namespace


SoundLoader.SoundInfo Members

SoundLoader.SoundInfo overview

Public Instance Constructors

SoundLoader.SoundInfo Constructor Initializes a new instance of the SoundInfo class.

Public Instance Fields

accesstime (inherited from y4cs.aux.CacheLoader+Info)
bLoaded (inherited from y4cs.aux.CacheLoader+Info)
bLoadFailed (inherited from y4cs.aux.CacheLoader+Info)
filename (inherited from y4cs.aux.CacheLoader+Info)
obj (inherited from y4cs.aux.CacheLoader+Info)
option1 (inherited from y4cs.aux.CacheLoader+Info)
option2 (inherited from y4cs.aux.CacheLoader+Info)

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SoundLoader.SoundInfo Class | y4cs.sound Namespace


SoundLoader.SoundInfo Constructor

Initializes a new instance of the SoundInfo class.

public SoundLoader.SoundInfo();

See Also

SoundLoader.SoundInfo Class | y4cs.sound Namespace


y4cs.thread

Yaneurao Game Library 4th for C#

y4cs.thread Namespace

Classes

Class | Description
GameSceneController | taskを用いたシーンコントローラー。
GameTaskBase | ゲーム用のタスクの基底クラス
GameTaskController | ゲーム用のタスクコントローラー。
GameTaskFactoryBase |
MicroThread | MicroThread の概要の説明です。
SimpleGameTask |

Delegates

Delegate | Description
SimpleGameTask.TaskDeleteHandler |


GameSceneController Class

taskを用いたシーンコントローラー。

For a list of all members of this type, see GameSceneController Members.

System.Object
GameTaskBase
GameSceneController

public class GameSceneController : GameTaskBase

Remarks

いわゆる、シーンコントローラー。 逐次的なタスク実行を実現する。

Example

例) タスクAを呼び出して、そのあとB,Cを呼び出すことを シーンコントローラーに要求。 タスクBは、その処理のなかでシーンコントローラーにタスクD,Eを 呼び出すことを要求。 結果として、タスクは、A,B,D,E,Cと呼び出される。 以下、サンプル。

            //	そのゲームで使う構造体各種よせ集め
            class GameInfo {
                GameTaskController gameTaskController;
                GameSceneController gameSceneController;

                //	他、いろいろ持たせる
            }
            enum Task { Task0,Task1,Task2,Task3,Task4 };

            class Task0 : GameTaskBase {
                void task (Object o) {
                    c++;
                    if (c==5) {
                        ((GameInfo)o).gameSceneController.jumpScene(Task.Task1);
                    }
                    printf("Task0\n");
                }
            private:
                int c;
            }

            class Task1 : GameTaskBase {
                void task(Object o) {
                    c++;
                    if (c==5) {
                        ((GameInfo)o).gameSceneController.callScene(Task.Task2);
                    } else if (c==10) {
                        ((GameInfo)o).gameSceneController.exitScene();
                        //	この呼び出し以降、このTask1.taskは呼び出されない

                        //	ゲーム自体を終了させるならば、タスクコントローラーに
                        //	要求する必要がある。
                        //	例)
                        ((GameInfo)o).gameTaskController.terminate();
                    }
                    printf("Task1\n");
                }
            private:
                int c;
            }

            class Task2 : GameTaskBase {
                void task (Object o) {
                    c++;
                    if (c==5) {
                        static int[] a = [ Task.Task4, Task.Task3 ];
                        ((GameInfo)o).gameSceneController.pushScene(a);
                        //	pushしてもすぐに呼び出されるわけではない。
                        //	returnSceneしてはじめて呼び出される
                        ((GameInfo)o).gameSceneController.returnScene();
                    }
                    printf("Task2\n");
                }
            private:
                int c;
            }

            class Task3 : GameTaskBase {
                void task (Object o) {
                    c++;
                    if (c==5) {
                        ((GameInfo)o).gameSceneController.returnScene();
                    }
                        printf("Task3\n");
                }
            private:
                int c;
            }

            class Task4 : GameTaskBase {
                void task (Object o) {
                    c++;
                    if (c==5) {
                        ((GameInfo)o).gameSceneController.returnScene();
                    }
                    printf("Task4\n");
                }
            private:
                int c;
            }

            class myGameSceneFactory : GameTaskFactoryBase {
                GameTaskBase createTask(int priority) {
                    switch (priority) {
                        case Task.Task0 : return new Task0;
                        case Task.Task1 : return new Task1;
                        case Task.Task2 : return new Task2;
                        case Task.Task3 : return new Task3;
                        case Task.Task4 : return new Task4;
                    }
                }
            }

            int main(){

                GameInfo info = new GameInfo;
                info.gameTaskController = new GameTaskController(100);
                info.gameSceneController = new GameSceneController(int.min);
                info.gameSceneController.setGameTaskFactory(new myGameSceneFactory);

                //	シーンコントローラーもタスクの一部なのでタスクコントローラーに
                //	登録しておく。
                info.gameTaskController.addTask = info.gameSceneController;

                //	最初に実行するタスクをシーンコントローラーに指定
                info.gameSceneController.jumpScene(Task.Task0);

                while (!info.gameTaskController.isEnd()) {
                    info.gameTaskController.callTask(info);
                }
                return 0;
            }

Requirements

Namespace: y4cs.thread

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

GameSceneController Members | y4cs.thread Namespace


GameSceneController Members

GameSceneController overview

Public Instance Constructors

GameSceneController Constructor Initializes a new instance of the GameSceneController class.

Public Instance Methods

callScene |
Equals (inherited from Object) |
exitScene |
getGameTaskFactory |
GetHashCode (inherited from Object) |
getNowTask |
getTaskInfo (inherited from GameTaskBase) |
getTaskName (inherited from GameTaskBase) | デバッグ用にタスク名を返す関数。
GetType (inherited from Object) |
isEnd |
jumpScene |
pushScene |
returnScene |
setGameTaskFactory |
task |
ToString (inherited from Object) |

Protected Instance Fields

gameTaskController
gameTaskFactory

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController Constructor

Initializes a new instance of the GameSceneController class.

public GameSceneController();

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController Fields

The fields of the GameSceneController class are listed below. For a complete list of GameSceneController class members, see the GameSceneController Members topic.

Protected Instance Fields

gameTaskController
gameTaskFactory

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.gameTaskController Field

protected GameTaskController gameTaskController;

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.gameTaskFactory Field

protected GameTaskFactoryBase gameTaskFactory;

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController Methods

The methods of the GameSceneController class are listed below. For a complete list of GameSceneController class members, see the GameSceneController Members topic.

Public Instance Methods

callScene |
Equals (inherited from Object) |
exitScene |
getGameTaskFactory |
GetHashCode (inherited from Object) |
getNowTask |
getTaskInfo (inherited from GameTaskBase) |
getTaskName (inherited from GameTaskBase) | デバッグ用にタスク名を返す関数。
GetType (inherited from Object) |
isEnd |
jumpScene |
pushScene |
returnScene |
setGameTaskFactory |
task |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.callScene Method

public void callScene(
int nPriority
);

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.exitScene Method

public void exitScene();

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.getGameTaskFactory Method

public GameTaskFactoryBase getGameTaskFactory();

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.getNowTask Method

public GameTaskBase getNowTask();

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.isEnd Method

public bool isEnd();

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.jumpScene Method

public void jumpScene(
int nPriority
);

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.pushScene Method

public void pushScene(
int[] a
);

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.returnScene Method

public void returnScene();

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.setGameTaskFactory Method

public void setGameTaskFactory(
GameTaskFactoryBase c
);

See Also

GameSceneController Class | y4cs.thread Namespace


GameSceneController.task Method

public override int task(
object o
);

See Also

GameSceneController Class | y4cs.thread Namespace


GameTaskBase Class

ゲーム用のタスクの基底クラス

For a list of all members of this type, see GameTaskBase Members.

System.Object
GameTaskBase

public abstract class GameTaskBase

Requirements

Namespace: y4cs.thread

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

GameTaskBase Members | y4cs.thread Namespace


GameTaskBase Members

GameTaskBase overview

Public Instance Constructors

GameTaskBase Constructor Initializes a new instance of the GameTaskBase class.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getTaskInfo |
getTaskName | デバッグ用にタスク名を返す関数。
GetType (inherited from Object) |
task | 呼び出されるべきタスク。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

GameTaskBase Class | y4cs.thread Namespace


GameTaskBase Constructor

Initializes a new instance of the GameTaskBase class.

public GameTaskBase();

See Also

GameTaskBase Class | y4cs.thread Namespace


GameTaskBase Methods

The methods of the GameTaskBase class are listed below. For a complete list of GameTaskBase class members, see the GameTaskBase Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getTaskInfo |
getTaskName | デバッグ用にタスク名を返す関数。
GetType (inherited from Object) |
task | 呼び出されるべきタスク。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

GameTaskBase Class | y4cs.thread Namespace


GameTaskBase.getTaskInfo Method

public virtual string getTaskInfo();

See Also

GameTaskBase Class | y4cs.thread Namespace


GameTaskBase.getTaskName Method

デバッグ用にタスク名を返す関数。

public virtual string getTaskName();

Remarks

必要ならばオーバーライドして使うと良い。

See Also

GameTaskBase Class | y4cs.thread Namespace


GameTaskBase.task Method

呼び出されるべきタスク。

public abstract int task(
object o
);

Remarks

派生クラス側で、これをオーバーライドして使う。 この引数には、 GameTaskController.callTask 呼び出し時に 渡したパラメータが入る。 非0を返せば、このタスクは消される。

See Also

GameTaskBase Class | y4cs.thread Namespace


GameTaskController Class

ゲーム用のタスクコントローラー。

For a list of all members of this type, see GameTaskController Members.

System.Object
GameTaskController

public class GameTaskController

Remarks

タスクの管理を行ないます。 タスク( GameTaskBase の派生クラス)を管理するために使います。 タスクには優先順位をつけおけば、指定した優先順位において 呼び出されます。 ※　実装メモ タスクのlistを持っていてそれを呼び出す。 ただし、listはnewを行なうので、速度低下を招く可能性がある。 大量のタスク(100～1000個単位)を扱うときにはこういう実装は 良くないと思われる。 よって少なくともタスクのinsert,removeに際してnewは行なわない ようなlist管理の方法が問われることになる。 サンプルについては、 GameSceneController の説明のものを参考にどうぞ。

Requirements

Namespace: y4cs.thread

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

GameTaskController Members | y4cs.thread Namespace


GameTaskController Members

GameTaskController overview

Public Instance Constructors

GameTaskController Overloaded. Initializes a new instance of the GameTaskController class.

Public Instance Methods

addTask | 生成したタスクをタスクリストに登録する。
callTask | すべてのタスクを呼び出す。
changePriority |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getTask |
getTaskList |
GetType (inherited from Object) |
isEnd |
isExistTask |
killTask | Overloaded.
print |
setTaskMax |
terminate |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController Constructor

Initializes a new instance of the GameTaskController class.

Overload List

Initializes a new instance of the GameTaskController class.

public GameTaskController();

public GameTaskController(int);

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController Constructor ()

Initializes a new instance of the GameTaskController class.

public GameTaskController();

See Also

GameTaskController Class | y4cs.thread Namespace | GameTaskController Constructor Overload List


GameTaskController Constructor (Int32)

public GameTaskController(
int nMaxTask
);

See Also

GameTaskController Class | y4cs.thread Namespace | GameTaskController Constructor Overload List


GameTaskController Methods

The methods of the GameTaskController class are listed below. For a complete list of GameTaskController class members, see the GameTaskController Members topic.

Public Instance Methods

addTask | 生成したタスクをタスクリストに登録する。
callTask | すべてのタスクを呼び出す。
changePriority |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getTask |
getTaskList |
GetType (inherited from Object) |
isEnd |
isExistTask |
killTask | Overloaded.
print |
setTaskMax |
terminate |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController.addTask Method

生成したタスクをタスクリストに登録する。

public y4cs_result addTask(
GameTaskBase task,
int priority
);

Parameters

task
priority

Return Value

Remarks

new したCTaskControlBase派生クラスを渡してチョ プライオリティは、タスクの優先度。0だと一番優先順位が高い。 万が一に備えてマイナスの値を渡しても良いようにはなっている。

空きがなくてタスクが生成できなかったときは非0が返る。 (通常、有ってはならないのだが)

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController.callTask Method

すべてのタスクを呼び出す。

public int callTask(
object o
);

Parameters

o

Return Value

Remarks

タスクプライオリティ(実行優先順位)に従い、 すべてのタスクを呼び出します。

ここで引数として渡しているObject型は、 GameTaskBase の task メソッドの引数として渡されます。

terminateメンバが呼び出されると、この関数は非0を返すように なります。

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController.changePriority Method

public void changePriority(
int beforePriority,
int afterPriority
);

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController.getTask Method

public GameTaskBase getTask(
int priority
);

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController.getTaskList Method

public fastlist getTaskList();

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController.isEnd Method

public bool isEnd();

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController.isExistTask Method

public bool isExistTask(
int priority
);

See Also

GameTaskController Class | y4cs.thread Namespace


killTask Method

Yaneurao Game Library 4th for C#

GameTaskController.killTask Method

Overload List

public void killTask(int);

タスクの一括削除。

public void killTask(int,int);

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController.killTask Method (Int32)

public void killTask(
int priority
);

See Also

GameTaskController Class | y4cs.thread Namespace | GameTaskController.killTask Overload List


GameTaskController.killTask Method (Int32, Int32)

タスクの一括削除。

public void killTask(
int nStartPriority,
int nEndPriority
);

Parameters

nStartPriority
nEndPriority

Remarks

優先度を指定してのタスクの一括削除。 自分のタスクが含まれても構わない。

nStartPriority～nEndPriorityまでを削除する。 (nEndPriorityも削除対象に含む。)

See Also

GameTaskController Class | y4cs.thread Namespace | GameTaskController.killTask Overload List


GameTaskController.print Method

public void print();

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController.setTaskMax Method

public void setTaskMax(
int n
);

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskController.terminate Method

public void terminate();

See Also

GameTaskController Class | y4cs.thread Namespace


GameTaskFactoryBase Class

For a list of all members of this type, see GameTaskFactoryBase Members.

System.Object
GameTaskFactoryBase

public abstract class GameTaskFactoryBase

Requirements

Namespace: y4cs.thread

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

GameTaskFactoryBase Members | y4cs.thread Namespace


GameTaskFactoryBase Members

GameTaskFactoryBase overview

Public Instance Methods

createTask | factory.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Constructors

GameTaskFactoryBase Constructor Initializes a new instance of the GameTaskFactoryBase class.

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

GameTaskFactoryBase Class | y4cs.thread Namespace


GameTaskFactoryBase Constructor

Initializes a new instance of the GameTaskFactoryBase class.

protected GameTaskFactoryBase();

See Also

GameTaskFactoryBase Class | y4cs.thread Namespace


GameTaskFactoryBase Methods

The methods of the GameTaskFactoryBase class are listed below. For a complete list of GameTaskFactoryBase class members, see the GameTaskFactoryBase Members topic.

Public Instance Methods

createTask | factory.
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

GameTaskFactoryBase Class | y4cs.thread Namespace


GameTaskFactoryBase.createTask Method

factory.

public abstract GameTaskBase createTask(
int priority
);

Parameters

priority

Return Value

Remarks

指定されたプライオリティのタスクを生成して返すfactoryを オーバーライドして書く。

newで生成しなくとも、事前に生成しておいたpoolから 割り当てても良い。

See Also

GameTaskFactoryBase Class | y4cs.thread Namespace


MicroThread Class

MicroThread の概要の説明です。

For a list of all members of this type, see MicroThread Members.

System.Object
Iter
MicroThread

public class MicroThread : Iter

Requirements

Namespace: y4cs.thread

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

MicroThread Members | y4cs.thread Namespace


MicroThread Members

MicroThread overview

Public Instance Constructors

MicroThread Overloaded. Initializes a new instance of the MicroThread class.

Public Instance Properties

IsRunning (inherited from y4cs.native.iterator.Iter)
IsStarted (inherited from y4cs.native.iterator.Iter)

Public Instance Methods

Dispose (inherited from y4cs.native.iterator.Iter) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isEnd |
isSuspended |
onMove |
resume |
Resume (inherited from y4cs.native.iterator.Iter) |
sleep |
start | Overloaded.
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
suspend |
ToString (inherited from Object) |

Protected Instance Fields

bStarted_ (inherited from y4cs.native.iterator.Iter)
iterStart (inherited from y4cs.native.iterator.Iter)
state (inherited from y4cs.native.iterator.Iter)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
yield (inherited from y4cs.native.iterator.Iter)

See Also

MicroThread Class | y4cs.thread Namespace


MicroThread Constructor

Initializes a new instance of the MicroThread class.

Overload List

Initializes a new instance of the MicroThread class.

public MicroThread();

public MicroThread(IterStart);

See Also

MicroThread Class | y4cs.thread Namespace


MicroThread Constructor ()

Initializes a new instance of the MicroThread class.

public MicroThread();

See Also

MicroThread Class | y4cs.thread Namespace | MicroThread Constructor Overload List


MicroThread Constructor (IterStart)

public MicroThread(
IterStart start_func
);

Parameters

start_func

See Also

MicroThread Class | y4cs.thread Namespace | MicroThread Constructor Overload List


MicroThread Methods

The methods of the MicroThread class are listed below. For a complete list of MicroThread class members, see the MicroThread Members topic.

Public Instance Methods

Dispose (inherited from y4cs.native.iterator.Iter) |
Equals (inherited from Object) |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
isEnd |
isSuspended |
onMove |
resume |
Resume (inherited from y4cs.native.iterator.Iter) |
sleep |
start | Overloaded.
start (inherited from y4cs.native.iterator.Iter) | Overloaded.
suspend |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)
yield (inherited from y4cs.native.iterator.Iter)

See Also

MicroThread Class | y4cs.thread Namespace


MicroThread.isEnd Method

public bool isEnd();

Return Value

See Also

MicroThread Class | y4cs.thread Namespace


MicroThread.isSuspended Method

public bool isSuspended();

Return Value

See Also

MicroThread Class | y4cs.thread Namespace


MicroThread.onMove Method

public void onMove();

See Also

MicroThread Class | y4cs.thread Namespace


MicroThread.resume Method

public void resume();

See Also

MicroThread Class | y4cs.thread Namespace


MicroThread.sleep Method

public void sleep(
int n
);

Parameters

n

See Also

MicroThread Class | y4cs.thread Namespace


start Method

Yaneurao Game Library 4th for C#

MicroThread.start Method

Overload List

Inherited from Iter.

public void start();

new public void start(IterStart);

See Also

MicroThread Class | y4cs.thread Namespace


MicroThread.start Method (IterStart)

new public void start(
IterStart start_func
);

Parameters

start_func

See Also

MicroThread Class | y4cs.thread Namespace | MicroThread.start Overload List


MicroThread.suspend Method

public void suspend();

See Also

MicroThread Class | y4cs.thread Namespace


SimpleGameTask Class

For a list of all members of this type, see SimpleGameTask Members.

System.Object
GameTaskBase
SimpleGameTask

public class SimpleGameTask : GameTaskBase

Requirements

Namespace: y4cs.thread

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

SimpleGameTask Members | y4cs.thread Namespace


SimpleGameTask Members

SimpleGameTask overview

Public Instance Constructors

SimpleGameTask Constructor

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getTaskInfo (inherited from GameTaskBase) |
getTaskName (inherited from GameTaskBase) | デバッグ用にタスク名を返す関数。
GetType (inherited from Object) |
task |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SimpleGameTask Class | y4cs.thread Namespace


SimpleGameTask Constructor

public SimpleGameTask(
TaskDeleteHandler dg
);

Parameters

dg

See Also

SimpleGameTask Class | y4cs.thread Namespace


SimpleGameTask Methods

The methods of the SimpleGameTask class are listed below. For a complete list of SimpleGameTask class members, see the SimpleGameTask Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetHashCode (inherited from Object) |
getTaskInfo (inherited from GameTaskBase) |
getTaskName (inherited from GameTaskBase) | デバッグ用にタスク名を返す関数。
GetType (inherited from Object) |
task |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

SimpleGameTask Class | y4cs.thread Namespace


SimpleGameTask.task Method

public override int task(
object o
);

Parameters

o

Return Value

See Also

SimpleGameTask Class | y4cs.thread Namespace


SimpleGameTask.TaskDeleteHandler Delegate

public delegate int SimpleGameTask.TaskDeleteHandler(
object o
);

Requirements

Namespace: y4cs.thread

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

y4cs.thread Namespace


y4cs.timer

Yaneurao Game Library 4th for C#

y4cs.timer Namespace

Classes

Class | Description
FixTimer | FixTimer
FpsTimer | 時間を効率的に待つためのタイマー。
Timer | Timer の概要の説明です。


FixTimer Class

FixTimer

For a list of all members of this type, see FixTimer Members.

System.Object
FixTimer

public class FixTimer

Requirements

Namespace: y4cs.timer

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FixTimer Members | y4cs.timer Namespace


FixTimer Members

FixTimer overview

Public Instance Constructors

FixTimer Constructor Initializes a new instance of the FixTimer class.

Public Instance Methods

Equals (inherited from Object)
get
GetHashCode (inherited from Object)
GetType (inherited from Object)
pause
reset
restart
set
ToString (inherited from Object)
update

Protected Instance Fields

dwTimeGetTime
timer

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer Constructor

Initializes a new instance of the FixTimer class.

public FixTimer();

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer Fields

The fields of the FixTimer class are listed below. For a complete list of FixTimer class members, see the FixTimer Members topic.

Protected Instance Fields

dwTimeGetTime
timer

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer.dwTimeGetTime Field

protected uint dwTimeGetTime;

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer.timer Field

protected Timer timer;

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer Methods

The methods of the FixTimer class are listed below. For a complete list of FixTimer class members, see the FixTimer Members topic.

Public Instance Methods

Equals (inherited from Object)
get
GetHashCode (inherited from Object)
GetType (inherited from Object)
pause
reset
restart
set
ToString (inherited from Object)
update

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer.get Method

public uint get();

Return Value

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer.pause Method

public void pause();

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer.reset Method

public void reset();

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer.restart Method

public void restart();

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer.set Method

public void set(
uint t
);

Parameters

t

See Also

FixTimer Class | y4cs.timer Namespace


FixTimer.update Method

public void update();

See Also

FixTimer Class | y4cs.timer Namespace


FpsTimer Class

時間を効率的に待つためのタイマー。

For a list of all members of this type, see FpsTimer Members.

System.Object
FpsTimer

public class FpsTimer

Remarks

フレームレート（一秒間の描画枚数）を60FPS（Frames Par Second）に 調整する時などに使う。

Requirements

Namespace: y4cs.timer

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

FpsTimer Members | y4cs.timer Namespace


FpsTimer Members

FpsTimer overview

Public Instance Constructors

FpsTimer Constructor Initializes a new instance of the FpsTimer class.

Public Instance Methods

Equals (inherited from Object) |
getCallCounter |
getCpuPower |
getElapseTimeCounter |
getFps | FPSの取得。
GetHashCode (inherited from Object) |
getRealFps | FPSの取得（測定値）。
getSkipFrame |
GetType (inherited from Object) |
resetCallCounter |
resetElapseTimeCounter |
resetTimer |
setFps |
toBeSkip |
ToString (inherited from Object) |
waitFrame |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer Constructor

Initializes a new instance of the FpsTimer class.

public FpsTimer();

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer Methods

The methods of the FpsTimer class are listed below. For a complete list of FpsTimer class members, see the FpsTimer Members topic.

Public Instance Methods

Equals (inherited from Object) |
getCallCounter |
getCpuPower |
getElapseTimeCounter |
getFps | FPSの取得。
GetHashCode (inherited from Object) |
getRealFps | FPSの取得（測定値）。
getSkipFrame |
GetType (inherited from Object) |
resetCallCounter |
resetElapseTimeCounter |
resetTimer |
setFps |
toBeSkip |
ToString (inherited from Object) |
waitFrame |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.getCallCounter Method

public uint getCallCounter();

Return Value

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.getCpuPower Method

public uint getCpuPower();

Return Value

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.getElapseTimeCounter Method

public uint getElapseTimeCounter();

Return Value

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.getFps Method

FPSの取得。

public uint getFps();

Return Value

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.getRealFps Method

FPSの取得（測定値）。

public uint getRealFps();

Return Value

Remarks

1秒間に何回WaitFrameを呼び出すかを、 前回32回の呼び出し時間の平均から算出する。

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.getSkipFrame Method

public uint getSkipFrame();

Return Value

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.resetCallCounter Method

public void resetCallCounter();

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.resetElapseTimeCounter Method

public void resetElapseTimeCounter();

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.resetTimer Method

public void resetTimer();

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.setFps Method

public void setFps(
uint fps
);

Parameters

fps

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.toBeSkip Method

public bool toBeSkip();

Return Value

See Also

FpsTimer Class | y4cs.timer Namespace


FpsTimer.waitFrame Method

public void waitFrame();

See Also

FpsTimer Class | y4cs.timer Namespace


Timer Class

Timer の概要の説明です。

For a list of all members of this type, see Timer Members.

System.Object
Timer

public class Timer

Requirements

Namespace: y4cs.timer

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Timer Members | y4cs.timer Namespace


Timer Members

Timer overview

Public Instance Constructors

Timer Constructor Initializes a new instance of the Timer class.

Public Instance Methods

Equals (inherited from Object)
get
GetHashCode (inherited from Object)
GetType (inherited from Object)
pause
reset
restart
set
ToString (inherited from Object)

Protected Instance Fields

bPaused
dwOffsetTime
dwPauseTime

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Timer Class | y4cs.timer Namespace


Timer Constructor

Initializes a new instance of the Timer class.

public Timer();

See Also

Timer Class | y4cs.timer Namespace


Timer Fields

The fields of the Timer class are listed below. For a complete list of Timer class members, see the Timer Members topic.

Protected Instance Fields

bPaused
dwOffsetTime
dwPauseTime

See Also

Timer Class | y4cs.timer Namespace


Timer.bPaused Field

protected int bPaused;

See Also

Timer Class | y4cs.timer Namespace


Timer.dwOffsetTime Field

protected uint dwOffsetTime;

See Also

Timer Class | y4cs.timer Namespace


Timer.dwPauseTime Field

protected uint dwPauseTime;

See Also

Timer Class | y4cs.timer Namespace


Timer Methods

The methods of the Timer class are listed below. For a complete list of Timer class members, see the Timer Members topic.

Public Instance Methods

Equals (inherited from Object)
get
GetHashCode (inherited from Object)
GetType (inherited from Object)
pause
reset
restart
set
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Timer Class | y4cs.timer Namespace


Timer.get Method

public uint get();

Return Value

See Also

Timer Class | y4cs.timer Namespace


Timer.pause Method

public void pause();

See Also

Timer Class | y4cs.timer Namespace


Timer.reset Method

public void reset();

See Also

Timer Class | y4cs.timer Namespace


Timer.restart Method

public void restart();

See Also

Timer Class | y4cs.timer Namespace


Timer.set Method

public void set(
uint t
);

Parameters

t

See Also

Timer Class | y4cs.timer Namespace


y4cs.ytl

Yaneurao Game Library 4th for C#

y4cs.ytl Namespace

Classes

Class | Description
fastlist | fastlist本体
fastlist.iterator |
fastlist.Node | ひとつの要素。
fastmap | 高速な巡回の出来るmap
list | C++のSTLのlistのようなクラス。
list.iterator |
list.list_element |
list.reverse_iterator |
list.reverse_list |
map |
objectPool | オブジェクトを事前に生成して貯めておく仕組み。
objectPool.iterator |
Singleton | Singleton の概要の説明です。
vector | vector
vector.iterator |
vector.reverse_iterator |
Y4CS_Exception | 例外発生時に使用するクラス。

Enumerations

Enumeration | Description
y4cs_result | ライブラリ全体で用いる、エラーを表す列挙体。


fastlist Class

fastlist本体

For a list of all members of this type, see fastlist Members.

System.Object
fastlist

public class fastlist : IEnumerable

Remarks

listを持っていてそれを呼び出す処理を考える。 ただし、listはnewを行なうので、速度低下を招く可能性がある。 大量の要素(100～1000個単位)を扱うときにはこういう実装は 良くないと思われる。 よって少なくともタスクのinsert,removeに際してnewは行なわない ようなlist管理の方法が問われることになる。 それがこのクラスの目的である。 このクラスの使用例は、 GameTaskController を参照すること。

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

fastlist Members | y4cs.ytl Namespace


fastlist Members

fastlist overview

Public Instance Constructors

fastlist Constructor Initializes a new instance of the fastlist class.

Public Instance Methods

add | Overloaded. 要素の挿入。
changePriority | プライオリティを変更。
collect | デリートマーカーのついているものを削除する。
Equals (inherited from Object) |
getElement | 指定したプライオリティの要素を得る。
getEmptyNode | 空き要素をひとつ取得する。
GetEnumerator |
GetHashCode (inherited from Object) |
getNodeList | 全部の要素を得る。
GetType (inherited from Object) |
insert | Overloaded. 要素の挿入。
isExistElement |
kill | Overloaded. 要素の削除。
setMax | 事前にサイズを指定してpoolを確保する。
ToString (inherited from Object) |

Protected Instance Fields

nodeList

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

fastlist Class | y4cs.ytl Namespace


fastlist Constructor

Initializes a new instance of the fastlist class.

public fastlist();

See Also

fastlist Class | y4cs.ytl Namespace


fastlist Fields

The fields of the fastlist class are listed below. For a complete list of fastlist class members, see the fastlist Members topic.

Protected Instance Fields

nodeList

See Also

fastlist Class | y4cs.ytl Namespace


fastlist.nodeList Field

protected Node[] nodeList;

See Also

fastlist Class | y4cs.ytl Namespace


fastlist Methods

The methods of the fastlist class are listed below. For a complete list of fastlist class members, see the fastlist Members topic.

Public Instance Methods

add | Overloaded. 要素の挿入。
changePriority | プライオリティを変更。
collect | デリートマーカーのついているものを削除する。
Equals (inherited from Object) |
getElement | 指定したプライオリティの要素を得る。
getEmptyNode | 空き要素をひとつ取得する。
GetEnumerator |
GetHashCode (inherited from Object) |
getNodeList | 全部の要素を得る。
GetType (inherited from Object) |
insert | Overloaded. 要素の挿入。
isExistElement |
kill | Overloaded. 要素の削除。
setMax | 事前にサイズを指定してpoolを確保する。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

fastlist Class | y4cs.ytl Namespace


add Method

Yaneurao Game Library 4th for C#

fastlist.add Method

要素の挿入。

Overload List

要素の挿入。

public y4cs_result add(object);

要素の挿入。

public y4cs_result add(object,int);

See Also

fastlist Class | y4cs.ytl Namespace


fastlist.add Method (Object)

要素の挿入。

public y4cs_result add(
object t
);

Remarks

空きブロックから一個空きをもらって、 順序無視で生きブロックの先頭に突っ込む。

See Also

fastlist Class | y4cs.ytl Namespace | fastlist.add Overload List


fastlist.add Method (Object, Int32)

要素の挿入。

public y4cs_result add(
object t,
int priority
);

Remarks

空きブロックから一個空きをもらって、 生きブロックのpriorityの順序のところに突っ込む。

See Also

fastlist Class | y4cs.ytl Namespace | fastlist.add Overload List


fastlist.changePriority Method

プライオリティを変更。

public void changePriority(
int beforePriority,
int afterPriority
);

Remarks

プライオリティを変更する。

See Also

fastlist Class | y4cs.ytl Namespace


fastlist.collect Method

デリートマーカーのついているものを削除する。

public void collect();

Remarks

巡回のあととかに呼び出すようにしてネ。

See Also

fastlist Class | y4cs.ytl Namespace


fastlist.getElement Method

指定したプライオリティの要素を得る。

public object getElement(
int priority
);

Remarks

もし指定したプライオリティの要素がなければnullが戻る。 プライオリティに対応する要素が唯一であるような設計をしている 場合に使うと便利。

See Also

fastlist Class | y4cs.ytl Namespace


fastlist.getEmptyNode Method

空き要素をひとつ取得する。

public Node getEmptyNode(
object t
);

Remarks

空きがなければ、nullが返る。 空きリストを調べて空きがあれば、そこに登録して、 登録したNodeのポインタを返す。 これを、生きてるチェインの正しい位置に挿入する必要がある。

See Also

fastlist Class | y4cs.ytl Namespace


fastlist.GetEnumerator Method

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

fastlist Class | y4cs.ytl Namespace


fastlist.getNodeList Method

全部の要素を得る。

public Node[] getNodeList();

Remarks

ただし、Node[0].nextは、使用しているブロックの先頭へのポインタ。 Node[1].nextは、空きブロックの先頭へのポインタ。 そのポイント先からは、nextを数珠つなぎにして管理されている。

See Also

fastlist Class | y4cs.ytl Namespace


insert Method

Yaneurao Game Library 4th for C#

fastlist.insert Method

要素の挿入。

Overload List

要素の挿入。

public y4cs_result insert(Node);

要素の挿入。

public y4cs_result insert(Node,int);

See Also

fastlist Class | y4cs.ytl Namespace


fastlist.insert Method (Node)

要素の挿入。

public y4cs_result insert(
Node emptyblock
);

Remarks

getEmptyNodeで取得した空きブロックを生きブロックの先頭に突っ込む。

See Also

fastlist Class | y4cs.ytl Namespace | fastlist.insert Overload List


fastlist.insert Method (Node, Int32)

要素の挿入。

public y4cs_result insert(
Node emptyNode,
int priority
);

Remarks

getEmptyNodeで取得した空きブロックを 生きブロックのpriorityで指定されたところに突っ込む。

See Also

fastlist Class | y4cs.ytl Namespace | fastlist.insert Overload List


fastlist.isExistElement Method

public bool isExistElement(
int priority
);

Parameters

priority

Return Value

See Also

fastlist Class | y4cs.ytl Namespace


kill Method

Yaneurao Game Library 4th for C#

fastlist.kill Method

要素の削除。

Overload List

要素の削除。

public void kill(int);

要素の一括削除。

public void kill(int,int);

See Also

fastlist Class | y4cs.ytl Namespace


fastlist.kill Method (Int32)

要素の削除。

public void kill(
int priority
);

Remarks

優先度を指定して、その要素を削除する。 消したオブジェクトは、デリートマーカーをつけておき、 次回のcollect時に回収される。

See Also

fastlist Class | y4cs.ytl Namespace | fastlist.kill Overload List


fastlist.kill Method (Int32, Int32)

要素の一括削除。

public void kill(
int nStartPriority,
int nEndPriority
);

Remarks

nStartPriority～nEndPriorityまでを削除する。 (nEndPriorityも削除対象に含む。)

消したオブジェクトは、デリートマーカーをつけておき、 次回のcollect時に回収される。

See Also

fastlist Class | y4cs.ytl Namespace | fastlist.kill Overload List


fastlist.setMax Method

事前にサイズを指定してpoolを確保する。

public y4cs_result setMax(
int n
);

Remarks

確保できれば0が返る。

See Also

fastlist Class | y4cs.ytl Namespace


fastlist.iterator Class

For a list of all members of this type, see fastlist.iterator Members.

System.Object
fastlist.iterator

public class fastlist.iterator : IEnumerator

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

fastlist.iterator Members | y4cs.ytl Namespace


fastlist.iterator Members

fastlist.iterator overview

Public Instance Constructors

fastlist.iterator Constructor

Public Instance Properties

Current

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

fastlist.iterator Class | y4cs.ytl Namespace


fastlist.iterator Constructor

public fastlist.iterator(
Node[] nodeList_
);

Parameters

nodeList_

See Also

fastlist.iterator Class | y4cs.ytl Namespace


fastlist.iterator Properties

The properties of the fastlist.iterator class are listed below. For a complete list of fastlist.iterator class members, see the fastlist.iterator Members topic.

Public Instance Properties

Current

See Also

fastlist.iterator Class | y4cs.ytl Namespace


fastlist.iterator.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

fastlist.iterator Class | y4cs.ytl Namespace


fastlist.iterator Methods

The methods of the fastlist.iterator class are listed below. For a complete list of fastlist.iterator class members, see the fastlist.iterator Members topic.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

fastlist.iterator Class | y4cs.ytl Namespace


fastlist.iterator.MoveNext Method

public bool MoveNext();

Return Value

Implements

IEnumerator.MoveNext

See Also

fastlist.iterator Class | y4cs.ytl Namespace


fastlist.iterator.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

fastlist.iterator Class | y4cs.ytl Namespace


fastlist.Node Class

ひとつの要素。

For a list of all members of this type, see fastlist.Node Members.

System.Object
fastlist.Node

public class fastlist.Node

Remarks

C#ではアドレスが動かないことを保証出来ないのでクラスで実装する。

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

fastlist.Node Members | y4cs.ytl Namespace


fastlist.Node Members

fastlist.Node overview

Public Instance Constructors

fastlist.Node Constructor Initializes a new instance of the Node class.

Public Instance Fields

dead | このデータは死亡なので回収すべき。
element | データ。
next | 数珠つなぎにして管理。
priority | 順位(Nodeを降順で並べるときに使う)。

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

fastlist.Node Class | y4cs.ytl Namespace


fastlist.Node Constructor

Initializes a new instance of the Node class.

public fastlist.Node();

See Also

fastlist.Node Class | y4cs.ytl Namespace


fastlist.Node Fields

The fields of the fastlist.Node class are listed below. For a complete list of fastlist.Node class members, see the fastlist.Node Members topic.

Public Instance Fields

dead | このデータは死亡なので回収すべき。
element | データ。
next | 数珠つなぎにして管理。
priority | 順位(Nodeを降順で並べるときに使う)。

See Also

fastlist.Node Class | y4cs.ytl Namespace


fastlist.Node.dead Field

このデータは死亡なので回収すべき。

public bool dead;

See Also

fastlist.Node Class | y4cs.ytl Namespace


fastlist.Node.element Field

データ。

public object element;

See Also

fastlist.Node Class | y4cs.ytl Namespace


fastlist.Node.next Field

数珠つなぎにして管理。

public Node next;

See Also

fastlist.Node Class | y4cs.ytl Namespace


fastlist.Node.priority Field

順位(Nodeを降順で並べるときに使う)。

public int priority;

See Also

fastlist.Node Class | y4cs.ytl Namespace


fastmap Class

高速な巡回の出来るmap

For a list of all members of this type, see fastmap Members.

System.Object
fastmap

public class fastmap : IEnumerable

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

fastmap Members | y4cs.ytl Namespace


fastmap Members

fastmap overview

Public Instance Constructors

fastmap Constructor Initializes a new instance of the fastmap class.

Public Instance Methods

clear
Equals (inherited from Object)
erase
get
GetEnumerator
GetHashCode (inherited from Object)
getKeys
getMap
GetType (inherited from Object)
getVector
insert
isin
size
ToString (inherited from Object)
update

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

fastmap Class | y4cs.ytl Namespace


fastmap Constructor

Initializes a new instance of the fastmap class.

public fastmap();

See Also

fastmap Class | y4cs.ytl Namespace


fastmap Methods

The methods of the fastmap class are listed below. For a complete list of fastmap class members, see the fastmap Members topic.

Public Instance Methods

clear
Equals (inherited from Object)
erase
get
GetEnumerator
GetHashCode (inherited from Object)
getKeys
getMap
GetType (inherited from Object)
getVector
insert
isin
size
ToString (inherited from Object)
update

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.clear Method

public void clear();

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.erase Method

public void erase(
object key
);

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.get Method

public object get(
object key
);

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.GetEnumerator Method

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.getKeys Method

public object[] getKeys();

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.getMap Method

public HybridDictionary getMap();

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.getVector Method

public object[] getVector();

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.insert Method

public void insert(
object key,
object data
);

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.isin Method

public bool isin(
object key
);

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.size Method

public int size();

See Also

fastmap Class | y4cs.ytl Namespace


fastmap.update Method

public void update();

See Also

fastmap Class | y4cs.ytl Namespace


list Class

C++のSTLのlistのようなクラス。

For a list of all members of this type, see list Members.

System.Object
list

public class list : IEnumerable

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

list Members | y4cs.ytl Namespace


list Members

list overview

Public Instance Constructors

list Overloaded. Initializes a new instance of the list class.

Public Instance Methods

back
begin
empty
end
Equals (inherited from Object)
erase
front
GetEnumerator
GetHashCode (inherited from Object)
GetType (inherited from Object)
pop_back
pop_front
push_back
push_front
rbegin
rend
reverse
size
ToString (inherited from Object)

Protected Instance Fields

endnode
s

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

list Class | y4cs.ytl Namespace


list Constructor

Initializes a new instance of the list class.

Overload List

Initializes a new instance of the list class.

public list();

public list(list_element,int);

See Also

list Class | y4cs.ytl Namespace


list Constructor ()

Initializes a new instance of the list class.

public list();

See Also

list Class | y4cs.ytl Namespace | list Constructor Overload List


list Constructor (list_element, Int32)

public list(
list_element e,
int s
);

Parameters

e
s

See Also

list Class | y4cs.ytl Namespace | list Constructor Overload List


list Fields

The fields of the list class are listed below. For a complete list of list class members, see the list Members topic.

Protected Instance Fields

endnode
s

See Also

list Class | y4cs.ytl Namespace


list.endnode Field

protected list_element endnode;

See Also

list Class | y4cs.ytl Namespace


list.s Field

protected int s;

See Also

list Class | y4cs.ytl Namespace


list Methods

The methods of the list class are listed below. For a complete list of list class members, see the list Members topic.

Public Instance Methods

back
begin
empty
end
Equals (inherited from Object)
erase
front
GetEnumerator
GetHashCode (inherited from Object)
GetType (inherited from Object)
pop_back
pop_front
push_back
push_front
rbegin
rend
reverse
size
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

list Class | y4cs.ytl Namespace


list.back Method

public object back();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.begin Method

public iterator begin();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.empty Method

public bool empty();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.end Method

public iterator end();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.erase Method

public void erase();

See Also

list Class | y4cs.ytl Namespace


list.front Method

public object front();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.GetEnumerator Method

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

list Class | y4cs.ytl Namespace


list.pop_back Method

public object pop_back();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.pop_front Method

public object pop_front();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.push_back Method

public void push_back(
object x
);

Parameters

x

See Also

list Class | y4cs.ytl Namespace


list.push_front Method

public void push_front(
object x
);

Parameters

x

See Also

list Class | y4cs.ytl Namespace


list.rbegin Method

public reverse_iterator rbegin();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.rend Method

public reverse_iterator rend();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.reverse Method

public IEnumerable reverse();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.size Method

public int size();

Return Value

See Also

list Class | y4cs.ytl Namespace


list.iterator Class

For a list of all members of this type, see list.iterator Members.

System.Object
list.iterator

public class list.iterator : IEnumerator

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

list.iterator Members | y4cs.ytl Namespace


list.iterator Members

list.iterator overview

Public Static Operators

Decrement Operator
Equality Operator
Increment Operator
Inequality Operator

Public Instance Constructors

list.iterator Overloaded. Initializes a new instance of the list.iterator class.

Public Instance Properties

Current
value

Public Instance Methods

Equals
GetHashCode
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator Constructor

Initializes a new instance of the iterator class.

Overload List

Initializes a new instance of the iterator class.

public list.iterator();

public list.iterator(iterator);

public list.iterator(list_element);

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator Constructor ()

Initializes a new instance of the iterator class.

public list.iterator();

See Also

list.iterator Class | y4cs.ytl Namespace | list.iterator Constructor Overload List


list.iterator Constructor (list_element)

public list.iterator(
list_element e
);

Parameters

e

See Also

list.iterator Class | y4cs.ytl Namespace | list.iterator Constructor Overload List


list.iterator Constructor (iterator)

public list.iterator(
iterator it
);

Parameters

it

See Also

list.iterator Class | y4cs.ytl Namespace | list.iterator Constructor Overload List


list.iterator Properties

The properties of the list.iterator class are listed below. For a complete list of list.iterator class members, see the list.iterator Members topic.

Public Instance Properties

Current
value

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator.value Property

public object value {get; set;}

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator Methods

The methods of the list.iterator class are listed below. For a complete list of list.iterator class members, see the list.iterator Members topic.

Public Instance Methods

Equals
GetHashCode
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator.Equals Method

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator.MoveNext Method

public bool MoveNext();

Return Value

Implements

IEnumerator.MoveNext

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator Operators

The operators of the list.iterator class are listed below. For a complete list of list.iterator class members, see the list.iterator Members topic.

Public Static Operators

Decrement Operator
Equality Operator
Increment Operator
Inequality Operator

See Also

list.iterator Class | list.iterator Members | y4cs.ytl Namespace


list.iterator Decrement Operator

public static list+iterator operator --(
iterator it
);

Parameters

it

Return Value

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator Equality Operator

public static bool operator ==(
iterator a,
iterator b
);

Parameters

a
b

Return Value

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator Increment Operator

public static list+iterator operator ++(
iterator it
);

Parameters

it

Return Value

See Also

list.iterator Class | y4cs.ytl Namespace


list.iterator Inequality Operator

public static bool operator !=(
iterator a,
iterator b
);

Parameters

a
b

Return Value

See Also

list.iterator Class | y4cs.ytl Namespace


list.list_element Class

For a list of all members of this type, see list.list_element Members.

System.Object
list.list_element

public class list.list_element

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

list.list_element Members | y4cs.ytl Namespace


list.list_element Members

list.list_element overview

Public Instance Constructors

list.list_element Overloaded. Initializes a new instance of the list.list_element class.

Public Instance Fields

next
prev
x

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

list.list_element Class | y4cs.ytl Namespace


list.list_element Constructor

Initializes a new instance of the list_element class.

Overload List

Initializes a new instance of the list_element class.

public list.list_element();

public list.list_element(object);

public list.list_element(object,list_element,list_element);

See Also

list.list_element Class | y4cs.ytl Namespace


list.list_element Constructor ()

Initializes a new instance of the list_element class.

public list.list_element();

See Also

list.list_element Class | y4cs.ytl Namespace | list.list_element Constructor Overload List


list.list_element Constructor (Object)

public list.list_element(
object x
);

Parameters

x

See Also

list.list_element Class | y4cs.ytl Namespace | list.list_element Constructor Overload List


list.list_element Constructor (Object, list_element, list_element)

public list.list_element(
object x,
list_element prev,
list_element next
);

Parameters

x
prev
next

See Also

list.list_element Class | y4cs.ytl Namespace | list.list_element Constructor Overload List


list.list_element Fields

The fields of the list.list_element class are listed below. For a complete list of list.list_element class members, see the list.list_element Members topic.

Public Instance Fields

next
prev
x

See Also

list.list_element Class | y4cs.ytl Namespace


list.list_element.next Field

public list_element next;

See Also

list.list_element Class | y4cs.ytl Namespace


list.list_element.prev Field

public list_element prev;

See Also

list.list_element Class | y4cs.ytl Namespace


list.list_element.x Field

public object x;

See Also

list.list_element Class | y4cs.ytl Namespace


list.reverse_iterator Class

For a list of all members of this type, see list.reverse_iterator Members.

System.Object
list.reverse_iterator

public class list.reverse_iterator : IEnumerator

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

list.reverse_iterator Members | y4cs.ytl Namespace


list.reverse_iterator Members

list.reverse_iterator overview

Public Static Operators

Decrement Operator
Equality Operator
Increment Operator
Inequality Operator

Public Instance Constructors

list.reverse_iterator Overloaded. Initializes a new instance of the list.reverse_iterator class.

Public Instance Properties

Current
value

Public Instance Methods

Equals
GetHashCode
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator Constructor

Initializes a new instance of the reverse_iterator class.

Overload List

Initializes a new instance of the reverse_iterator class.

public list.reverse_iterator();

public list.reverse_iterator(list_element);

public list.reverse_iterator(reverse_iterator);

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator Constructor ()

Initializes a new instance of the reverse_iterator class.

public list.reverse_iterator();

See Also

list.reverse_iterator Class | y4cs.ytl Namespace | list.reverse_iterator Constructor Overload List


list.reverse_iterator Constructor (list_element)

public list.reverse_iterator(
list_element e
);

Parameters

e

See Also

list.reverse_iterator Class | y4cs.ytl Namespace | list.reverse_iterator Constructor Overload List


list.reverse_iterator Constructor (reverse_iterator)

public list.reverse_iterator(
reverse_iterator it
);

Parameters

it

See Also

list.reverse_iterator Class | y4cs.ytl Namespace | list.reverse_iterator Constructor Overload List


list.reverse_iterator Properties

The properties of the list.reverse_iterator class are listed below. For a complete list of list.reverse_iterator class members, see the list.reverse_iterator Members topic.

Public Instance Properties

Current
value

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator.value Property

public object value {get; set;}

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator Methods

The methods of the list.reverse_iterator class are listed below. For a complete list of list.reverse_iterator class members, see the list.reverse_iterator Members topic.

Public Instance Methods

Equals
GetHashCode
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator.Equals Method

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator.MoveNext Method

public bool MoveNext();

Return Value

Implements

IEnumerator.MoveNext

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator Operators

The operators of the list.reverse_iterator class are listed below. For a complete list of list.reverse_iterator class members, see the list.reverse_iterator Members topic.

Public Static Operators

Decrement Operator
Equality Operator
Increment Operator
Inequality Operator

See Also

list.reverse_iterator Class | list.reverse_iterator Members | y4cs.ytl Namespace


list.reverse_iterator Decrement Operator

public static list+reverse_iterator operator --(
reverse_iterator it
);

Parameters

it

Return Value

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator Equality Operator

public static bool operator ==(
reverse_iterator a,
reverse_iterator b
);

Parameters

a
b

Return Value

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator Increment Operator

public static list+reverse_iterator operator ++(
reverse_iterator it
);

Parameters

it

Return Value

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_iterator Inequality Operator

public static bool operator !=(
reverse_iterator a,
reverse_iterator b
);

Parameters

a
b

Return Value

See Also

list.reverse_iterator Class | y4cs.ytl Namespace


list.reverse_list Class

For a list of all members of this type, see list.reverse_list Members.

System.Object
list
list.reverse_list

public class list.reverse_list : list

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

list.reverse_list Members | y4cs.ytl Namespace


list.reverse_list Members

list.reverse_list overview

Public Instance Constructors

list.reverse_list Constructor

Public Instance Methods

back (inherited from list)
begin (inherited from list)
empty (inherited from list)
end (inherited from list)
Equals (inherited from Object)
erase (inherited from list)
front (inherited from list)
GetEnumerator
GetHashCode (inherited from Object)
GetType (inherited from Object)
pop_back (inherited from list)
pop_front (inherited from list)
push_back (inherited from list)
push_front (inherited from list)
rbegin (inherited from list)
rend (inherited from list)
reverse (inherited from list)
size (inherited from list)
ToString (inherited from Object)

Protected Instance Fields

endnode (inherited from list)
s (inherited from list)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

list.reverse_list Class | y4cs.ytl Namespace


list.reverse_list Constructor

public list.reverse_list(
list_element e,
int s
);

Parameters

e
s

See Also

list.reverse_list Class | y4cs.ytl Namespace


list.reverse_list Methods

The methods of the list.reverse_list class are listed below. For a complete list of list.reverse_list class members, see the list.reverse_list Members topic.

Public Instance Methods

back (inherited from list)
begin (inherited from list)
empty (inherited from list)
end (inherited from list)
Equals (inherited from Object)
erase (inherited from list)
front (inherited from list)
GetEnumerator
GetHashCode (inherited from Object)
GetType (inherited from Object)
pop_back (inherited from list)
pop_front (inherited from list)
push_back (inherited from list)
push_front (inherited from list)
rbegin (inherited from list)
rend (inherited from list)
reverse (inherited from list)
size (inherited from list)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

list.reverse_list Class | y4cs.ytl Namespace


list.reverse_list.GetEnumerator Method

new public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

list.reverse_list Class | y4cs.ytl Namespace


map Class

For a list of all members of this type, see map Members.

System.Object
map

public class map

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

map Members | y4cs.ytl Namespace


map Members

map overview

Public Instance Constructors

map Constructor Initializes a new instance of the map class.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

map Class | y4cs.ytl Namespace


map Constructor

Initializes a new instance of the map class.

public map();

See Also

map Class | y4cs.ytl Namespace


objectPool Class

オブジェクトを事前に生成して貯めておく仕組み。

For a list of all members of this type, see objectPool Members.

System.Object
objectPool

public class objectPool : IEnumerable

Remarks

オブジェクトプールは、結局のところ有限スタックとして実装される。 すなわち、サイズが事前に決まっているスタックであり、未使用オブジェクトを このスタック上にpushして(積んで)いき、未使用オブジェクトをもらうには、 このスタックからpopして(降ろして)いくことにより、プールという仕組みを 実現することが出来る。

            alias objectPool!(Star) StarPool;
のようにして、
            //	☆オブジェクトを事前に生成しておく。
            StarPool pool = new StarPool;
            pool.setMax(500);
            foreach(inout Star s;pool) s = new Star;
プールからもらうときは、
            //	プールからオブジェクトをひとつもらう
            Star s = pool.pop();
            if (s) {
                s.reset(info,x,y);
                controller.addTask(s,0);
            }
プールに返すときは、
            if (time > 50){
                // 自殺する
                pool.push(this); // このオブジェクトをプールに戻す
                return 1;
            }
のようにする。

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

objectPool Members | y4cs.ytl Namespace


objectPool Members

objectPool overview

Public Instance Constructors

objectPool Constructor

Public Instance Methods

Equals (inherited from Object) |
GetEnumerator |
GetHashCode (inherited from Object) |
getRest | 未使用のオブジェクト数を返す。
getSP | 内部で使用しているspポインタそのまま返す。
getStack | 内部で使用しているスタックをそのまま返す。
GetType (inherited from Object) |
pop | オブジェクトをひとつもらう。
popForced | オブジェクトをひとつ返す。
push | オブジェクトをひとつ返す。
pushForced | オブジェクトをプールに戻す。
release |
setMax | poolするオブジェクトの最大数を設定する。
setSP | 内部で使用しているspポインタにそのまま設定する。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

objectPool Class | y4cs.ytl Namespace


objectPool Constructor

public objectPool(
Type t
);

Parameters

t

See Also

objectPool Class | y4cs.ytl Namespace


objectPool Methods

The methods of the objectPool class are listed below. For a complete list of objectPool class members, see the objectPool Members topic.

Public Instance Methods

Equals (inherited from Object) |
GetEnumerator |
GetHashCode (inherited from Object) |
getRest | 未使用のオブジェクト数を返す。
getSP | 内部で使用しているspポインタそのまま返す。
getStack | 内部で使用しているスタックをそのまま返す。
GetType (inherited from Object) |
pop | オブジェクトをひとつもらう。
popForced | オブジェクトをひとつ返す。
push | オブジェクトをひとつ返す。
pushForced | オブジェクトをプールに戻す。
release |
setMax | poolするオブジェクトの最大数を設定する。
setSP | 内部で使用しているspポインタにそのまま設定する。
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.GetEnumerator Method

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.getRest Method

未使用のオブジェクト数を返す。

public int getRest();

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.getSP Method

内部で使用しているspポインタそのまま返す。

public int getSP();

Return Value

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.getStack Method

内部で使用しているスタックをそのまま返す。

public object[] getStack();

Return Value

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.pop Method

オブジェクトをひとつもらう。

public object pop();

Remarks

未使用のオブジェクトがなければ、nullが返る。

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.popForced Method

オブジェクトをひとつ返す。

public object popForced();

Remarks

オブジェクトに空きがない場合は、一番最後にpushForcedで返された オブジェクトを返す。(pushForcedと対にして使う) パーティクル等で一番古いオブジェクトを再利用したいときに これを使うと良い。

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.push Method

オブジェクトをひとつ返す。

public void push(
object t
);

Remarks

最初setMaxで確保して、ここからpopで取得した分以外の オブジェクトを返してはならない。

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.pushForced Method

オブジェクトをプールに戻す。

public void pushForced(
object t
);

Remarks

popForcedと対にして使えるように、戻すときに 順序づけを行なって戻す。

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.release Method

public void release();

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.setMax Method

poolするオブジェクトの最大数を設定する。

public void setMax(
int n
);

Remarks

事前に設定すること。 設定すると、以前保持していたオブジェクトは 解放してしまうので注意。

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.setSP Method

内部で使用しているspポインタにそのまま設定する。

public void setSP(
int sp_
);

Parameters

sp_

See Also

objectPool Class | y4cs.ytl Namespace


objectPool.iterator Class

For a list of all members of this type, see objectPool.iterator Members.

System.Object
objectPool.iterator

public class objectPool.iterator : IEnumerator

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

objectPool.iterator Members | y4cs.ytl Namespace


objectPool.iterator Members

objectPool.iterator overview

Public Instance Constructors

objectPool.iterator Constructor

Public Instance Properties

Current

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

objectPool.iterator Class | y4cs.ytl Namespace


objectPool.iterator Constructor

public objectPool.iterator(
object[] stack_
);

Parameters

stack_

See Also

objectPool.iterator Class | y4cs.ytl Namespace


objectPool.iterator Properties

The properties of the objectPool.iterator class are listed below. For a complete list of objectPool.iterator class members, see the objectPool.iterator Members topic.

Public Instance Properties

Current

See Also

objectPool.iterator Class | y4cs.ytl Namespace


objectPool.iterator.Current Property

public object Current {get; set;}

Implements

IEnumerator.Current

See Also

objectPool.iterator Class | y4cs.ytl Namespace


objectPool.iterator Methods

The methods of the objectPool.iterator class are listed below. For a complete list of objectPool.iterator class members, see the objectPool.iterator Members topic.

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

objectPool.iterator Class | y4cs.ytl Namespace


objectPool.iterator.MoveNext Method

public bool MoveNext();

Return Value

Implements

IEnumerator.MoveNext

See Also

objectPool.iterator Class | y4cs.ytl Namespace


objectPool.iterator.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

objectPool.iterator Class | y4cs.ytl Namespace


Singleton Class

Singleton の概要の説明です。

For a list of all members of this type, see Singleton Members.

System.Object
Singleton

public class Singleton

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Singleton Members | y4cs.ytl Namespace


Singleton Members

Singleton overview

Public Static Methods

getInstance

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Singleton Class | y4cs.ytl Namespace


Singleton Methods

The methods of the Singleton class are listed below. For a complete list of Singleton class members, see the Singleton Members topic.

Public Static Methods

getInstance

Public Instance Methods

Equals (inherited from Object)
GetHashCode (inherited from Object)
GetType (inherited from Object)
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Singleton Class | y4cs.ytl Namespace


Singleton.getInstance Method

public static object getInstance(
Type t
);

Parameters

t

Return Value

See Also

Singleton Class | y4cs.ytl Namespace


vector Class

vector

For a list of all members of this type, see vector Members.

System.Object
vector

public class vector : IEnumerable

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

vector Members | y4cs.ytl Namespace


vector Members

vector overview

Public Instance Constructors

vector Overloaded. Initializes a new instance of the vector class.

Public Instance Properties

Item

Public Instance Methods

at |
back |
begin |
capacity |
clear |
empty |
end |
Equals (inherited from Object) |
erase | Overloaded.
front |
GetEnumerator |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
pop_back |
push_back |
rbegin |
rend |
reserve |
resize |
reverse |
size |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

vector Class | y4cs.ytl Namespace


vector Constructor

Initializes a new instance of the vector class.

Overload List

Initializes a new instance of the vector class.

public vector();

public vector(object[],int);

See Also

vector Class | y4cs.ytl Namespace


vector Constructor ()

Initializes a new instance of the vector class.

public vector();

See Also

vector Class | y4cs.ytl Namespace | vector Constructor Overload List


vector Constructor (Object[], Int32)

public vector(
object[] a,
int size
);

Parameters

a
size

See Also

vector Class | y4cs.ytl Namespace | vector Constructor Overload List


vector Properties

The properties of the vector class are listed below. For a complete list of vector class members, see the vector Members topic.

Public Instance Properties

Item

See Also

vector Class | y4cs.ytl Namespace


vector.Item Property

public object this[
int n
] {get; set;}

See Also

vector Class | y4cs.ytl Namespace


vector Methods

The methods of the vector class are listed below. For a complete list of vector class members, see the vector Members topic.

Public Instance Methods

at |
back |
begin |
capacity |
clear |
empty |
end |
Equals (inherited from Object) |
erase | Overloaded.
front |
GetEnumerator |
GetHashCode (inherited from Object) |
GetType (inherited from Object) |
pop_back |
push_back |
rbegin |
rend |
reserve |
resize |
reverse |
size |
ToString (inherited from Object) |

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

vector Class | y4cs.ytl Namespace


vector.at Method

public object at(
int n
);

Parameters

n

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.back Method

public object back();

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.begin Method

public iterator begin();

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.capacity Method

public int capacity();

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.clear Method

public void clear();

See Also

vector Class | y4cs.ytl Namespace


vector.empty Method

public bool empty();

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.end Method

public iterator end();

Return Value

See Also

vector Class | y4cs.ytl Namespace


erase Method

Yaneurao Game Library 4th for C#

vector.erase Method

Overload List

public void erase(int);

public void erase(int,int);

public iterator erase(iterator);

public iterator erase(iterator,iterator);

See Also

vector Class | y4cs.ytl Namespace


vector.erase Method (Int32)

public void erase(
int n
);

Parameters

n

See Also

vector Class | y4cs.ytl Namespace | vector.erase Overload List


vector.erase Method (Int32, Int32)

public void erase(
int n,
int m
);

Parameters

n
m

See Also

vector Class | y4cs.ytl Namespace | vector.erase Overload List


vector.erase Method (iterator)

public iterator erase(
iterator it
);

Parameters

it

Return Value

See Also

vector Class | y4cs.ytl Namespace | vector.erase Overload List


vector.erase Method (iterator, iterator)

public iterator erase(
iterator bgn,
iterator end
);

Parameters

bgn
end

Return Value

See Also

vector Class | y4cs.ytl Namespace | vector.erase Overload List


vector.front Method

public object front();

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.GetEnumerator Method

public IEnumerator GetEnumerator();

Return Value

Implements

IEnumerable.GetEnumerator

See Also

vector Class | y4cs.ytl Namespace


vector.pop_back Method

public object pop_back();

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.push_back Method

public void push_back(
object o
);

Parameters

o

See Also

vector Class | y4cs.ytl Namespace


vector.rbegin Method

public reverse_iterator rbegin();

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.rend Method

public reverse_iterator rend();

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.reserve Method

public void reserve(
int n
);

Parameters

n

See Also

vector Class | y4cs.ytl Namespace


vector.resize Method

public void resize(
int n
);

Parameters

n

See Also

vector Class | y4cs.ytl Namespace


vector.reverse Method

public IEnumerable reverse();

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.size Method

public int size();

Return Value

See Also

vector Class | y4cs.ytl Namespace


vector.iterator Class

For a list of all members of this type, see vector.iterator Members.

System.Object
vector.iterator

public class vector.iterator : IEnumerator, IComparable

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

vector.iterator Members | y4cs.ytl Namespace


vector.iterator Members

vector.iterator overview

Public Static Operators

Addition Operator
Decrement Operator
Equality Operator
Increment Operator
Inequality Operator
Subtraction Operator

Public Instance Constructors

vector.iterator Overloaded. Initializes a new instance of the vector.iterator class.

Public Instance Properties

Current
pos
value

Public Instance Methods

CompareTo
Equals
GetHashCode
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator Constructor

Initializes a new instance of the iterator class.

Overload List

Initializes a new instance of the iterator class.

public vector.iterator();

public vector.iterator(object[],int);

public vector.iterator(object[],int,int);

public vector.iterator(iterator);

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator Constructor ()

Initializes a new instance of the iterator class.

public vector.iterator();

See Also

vector.iterator Class | y4cs.ytl Namespace | vector.iterator Constructor Overload List


vector.iterator Constructor (Object[], Int32)

public vector.iterator(
object[] a,
int size
);

Parameters

a
size

See Also

vector.iterator Class | y4cs.ytl Namespace | vector.iterator Constructor Overload List


vector.iterator Constructor (Object[], Int32, Int32)

public vector.iterator(
object[] a,
int size,
int pos
);

Parameters

a
size
pos

See Also

vector.iterator Class | y4cs.ytl Namespace | vector.iterator Constructor Overload List


vector.iterator Constructor (iterator)

public vector.iterator(
iterator it
);

Parameters

it

See Also

vector.iterator Class | y4cs.ytl Namespace | vector.iterator Constructor Overload List


vector.iterator Properties

The properties of the vector.iterator class are listed below. For a complete list of vector.iterator class members, see the vector.iterator Members topic.

Public Instance Properties

Current
pos
value

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator.pos Property

public int pos {get; set;}

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator.value Property

public object value {get; set;}

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator Methods

The methods of the vector.iterator class are listed below. For a complete list of vector.iterator class members, see the vector.iterator Members topic.

Public Instance Methods

CompareTo
Equals
GetHashCode
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator.CompareTo Method

public int CompareTo(
object obj
);

Parameters

obj

Return Value

Implements

IComparable.CompareTo

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator.Equals Method

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator.MoveNext Method

public bool MoveNext();

Return Value

Implements

IEnumerator.MoveNext

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator Operators

The operators of the vector.iterator class are listed below. For a complete list of vector.iterator class members, see the vector.iterator Members topic.

Public Static Operators

Addition Operator
Decrement Operator
Equality Operator
Increment Operator
Inequality Operator
Subtraction Operator

See Also

vector.iterator Class | vector.iterator Members | y4cs.ytl Namespace


vector.iterator Addition Operator

public static vector+iterator operator +(
iterator it,
int n
);

Parameters

it
n

Return Value

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator Decrement Operator

public static vector+iterator operator --(
iterator it
);

Parameters

it

Return Value

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator Equality Operator

public static bool operator ==(
iterator a,
iterator b
);

Parameters

a
b

Return Value

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator Increment Operator

public static vector+iterator operator ++(
iterator it
);

Parameters

it

Return Value

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator Inequality Operator

public static bool operator !=(
iterator a,
iterator b
);

Parameters

a
b

Return Value

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.iterator Subtraction Operator

public static vector+iterator operator -(
iterator it,
int n
);

Parameters

it
n

Return Value

See Also

vector.iterator Class | y4cs.ytl Namespace


vector.reverse_iterator Class

For a list of all members of this type, see vector.reverse_iterator Members.

System.Object
vector.reverse_iterator

public class vector.reverse_iterator : IEnumerator, IComparable

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

vector.reverse_iterator Members | y4cs.ytl Namespace


vector.reverse_iterator Members

vector.reverse_iterator overview

Public Static Operators

Addition Operator
Decrement Operator
Equality Operator
Increment Operator
Inequality Operator
Subtraction Operator

Public Instance Constructors

vector.reverse_iterator Overloaded. Initializes a new instance of the vector.reverse_iterator class.

Public Instance Properties

Current
pos
value

Public Instance Methods

CompareTo
Equals
GetHashCode
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator Constructor

Initializes a new instance of the reverse_iterator class.

Overload List

Initializes a new instance of the reverse_iterator class.

public vector.reverse_iterator();

public vector.reverse_iterator(object[],int);

public vector.reverse_iterator(object[],int,int);

public vector.reverse_iterator(reverse_iterator);

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator Constructor ()

Initializes a new instance of the reverse_iterator class.

public vector.reverse_iterator();

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace | vector.reverse_iterator Constructor Overload List


vector.reverse_iterator Constructor (Object[], Int32)

public vector.reverse_iterator(
object[] a,
int size
);

Parameters

a
size

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace | vector.reverse_iterator Constructor Overload List


vector.reverse_iterator Constructor (Object[], Int32, Int32)

public vector.reverse_iterator(
object[] a,
int size,
int pos
);

Parameters

a
size
pos

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace | vector.reverse_iterator Constructor Overload List


vector.reverse_iterator Constructor (reverse_iterator)

public vector.reverse_iterator(
reverse_iterator it
);

Parameters

it

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace | vector.reverse_iterator Constructor Overload List


vector.reverse_iterator Properties

The properties of the vector.reverse_iterator class are listed below. For a complete list of vector.reverse_iterator class members, see the vector.reverse_iterator Members topic.

Public Instance Properties

Current
pos
value

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator.Current Property

public object Current {get;}

Implements

IEnumerator.Current

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator.pos Property

public int pos {get; set;}

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator.value Property

public object value {get; set;}

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator Methods

The methods of the vector.reverse_iterator class are listed below. For a complete list of vector.reverse_iterator class members, see the vector.reverse_iterator Members topic.

Public Instance Methods

CompareTo
Equals
GetHashCode
GetType (inherited from Object)
MoveNext
Reset
ToString (inherited from Object)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator.CompareTo Method

public int CompareTo(
object obj
);

Parameters

obj

Return Value

Implements

IComparable.CompareTo

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator.Equals Method

public override bool Equals(
object obj
);

Parameters

obj

Return Value

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator.GetHashCode Method

public override int GetHashCode();

Return Value

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator.MoveNext Method

public bool MoveNext();

Return Value

Implements

IEnumerator.MoveNext

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator.Reset Method

public void Reset();

Implements

IEnumerator.Reset

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator Operators

The operators of the vector.reverse_iterator class are listed below. For a complete list of vector.reverse_iterator class members, see the vector.reverse_iterator Members topic.

Public Static Operators

Addition Operator
Decrement Operator
Equality Operator
Increment Operator
Inequality Operator
Subtraction Operator

See Also

vector.reverse_iterator Class | vector.reverse_iterator Members | y4cs.ytl Namespace


vector.reverse_iterator Addition Operator

public static vector+reverse_iterator operator +(
reverse_iterator it,
int n
);

Parameters

it
n

Return Value

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator Decrement Operator

public static vector+reverse_iterator operator --(
reverse_iterator it
);

Parameters

it

Return Value

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator Equality Operator

public static bool operator ==(
reverse_iterator a,
reverse_iterator b
);

Parameters

a
b

Return Value

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator Increment Operator

public static vector+reverse_iterator operator ++(
reverse_iterator it
);

Parameters

it

Return Value

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator Inequality Operator

public static bool operator !=(
reverse_iterator a,
reverse_iterator b
);

Parameters

a
b

Return Value

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


vector.reverse_iterator Subtraction Operator

public static vector+reverse_iterator operator -(
reverse_iterator it,
int n
);

Parameters

it
n

Return Value

See Also

vector.reverse_iterator Class | y4cs.ytl Namespace


Y4CS_Exception Class

例外発生時に使用するクラス。

For a list of all members of this type, see Y4CS_Exception Members.

System.Object
Exception
Y4CS_Exception

public class Y4CS_Exception : Exception

Example

エラーの時に投げる例外 例)

                throw new Y4CS_Exception(this,"エラーだぴょん");

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

Y4CS_Exception Members | y4cs.ytl Namespace


Y4CS_Exception Members

Y4CS_Exception overview

Public Instance Constructors

Y4CS_Exception Overloaded. Initializes a new instance of the Y4CS_Exception class.

Public Instance Properties

HelpLink (inherited from Exception)
InnerException (inherited from Exception)
Message (inherited from Exception)
Source (inherited from Exception)
StackTrace (inherited from Exception)
TargetSite (inherited from Exception)

Public Instance Methods

Equals (inherited from Object)
GetBaseException (inherited from Exception)
GetHashCode (inherited from Object)
GetObjectData (inherited from Exception)
GetType (inherited from Object)
ToString (inherited from Exception)

Protected Instance Properties

HResult (inherited from Exception)

Protected Instance Methods

Finalize (inherited from Object)
MemberwiseClone (inherited from Object)

See Also

Y4CS_Exception Class | y4cs.ytl Namespace


Y4CS_Exception Constructor

Overload List

public Y4CS_Exception(object,string);

例外の発生したオブジェクトとy4cs_resultをそのままエラーメッセージとするタイプ。

public Y4CS_Exception(object,y4cs_result);

public Y4CS_Exception(string);

y4cs_resultをそのままエラーメッセージとするタイプ。

public Y4CS_Exception(y4cs_result);

See Also

Y4CS_Exception Class | y4cs.ytl Namespace


Y4CS_Exception Constructor (String)

public Y4CS_Exception(
string msg
);

Parameters

msg

See Also

Y4CS_Exception Class | y4cs.ytl Namespace | Y4CS_Exception Constructor Overload List


Y4CS_Exception Constructor (Object, String)

public Y4CS_Exception(
object o,
string msg
);

Parameters

o
msg

See Also

Y4CS_Exception Class | y4cs.ytl Namespace | Y4CS_Exception Constructor Overload List


Y4CS_Exception Constructor (y4cs_result)

y4cs_resultをそのままエラーメッセージとするタイプ。

public Y4CS_Exception(
y4cs_result msg
);

Parameters

msg

See Also

Y4CS_Exception Class | y4cs.ytl Namespace | Y4CS_Exception Constructor Overload List


Y4CS_Exception Constructor (Object, y4cs_result)

例外の発生したオブジェクトとy4cs_resultをそのままエラーメッセージとするタイプ。

public Y4CS_Exception(
object o,
y4cs_result msg
);

Parameters

o
msg

See Also

Y4CS_Exception Class | y4cs.ytl Namespace | Y4CS_Exception Constructor Overload List


y4cs_result Enumeration

ライブラリ全体で用いる、エラーを表す列挙体。

public enum y4cs_result

Members

Member Name | Description
no_error | エラーなし。
not_implemented | 未実装。
should_be_quit | quitすべき。
precondition_error | 完了できない(前提条件が守られていないため)。
already_done | すでに完了している。
happen_some_error | 何らかのエラーが発生した。
file_not_found | ファイルが見つからない。
file_read_error | ファイルの読み込み、解読上のエラー。
file_write_error | ファイルが書き込めない。
invalid_parameter | パラメータが不正。
win32api_error | Win32のAPI関連のエラー。
SDL_error | SDL関連のエラー。
zlib_error | zlib上のエラー。

Requirements

Namespace: y4cs.ytl

Assembly: yaneSDK4Cs (in yaneSDK4Cs.dll)

See Also

y4cs.ytl Namespace